summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-06-24 15:00:58 +0200
committerLars Wendler <polynomial-c@gentoo.org>2019-06-24 15:08:30 +0200
commita1884920e44debfc789d07c4e9312e8f6ea2ab0b (patch)
tree59b80b53518f882630a9cefbc6613d70b5844e8f /dev-libs/libinput
parentnet-proxy/haproxy: Add prometheus-exporter re bug 688350 (diff)
downloadgentoo-a1884920e44debfc789d07c4e9312e8f6ea2ab0b.tar.gz
gentoo-a1884920e44debfc789d07c4e9312e8f6ea2ab0b.tar.bz2
gentoo-a1884920e44debfc789d07c4e9312e8f6ea2ab0b.zip
dev-libs/libinput: Bump to versionb 1.13.3
Package-Manager: Portage-2.3.67, Repoman-2.3.16 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'dev-libs/libinput')
-rw-r--r--dev-libs/libinput/Manifest1
-rw-r--r--dev-libs/libinput/libinput-1.13.3.ebuild78
2 files changed, 79 insertions, 0 deletions
diff --git a/dev-libs/libinput/Manifest b/dev-libs/libinput/Manifest
index 031ec2d3f46c..b4c7e9a7b2db 100644
--- a/dev-libs/libinput/Manifest
+++ b/dev-libs/libinput/Manifest
@@ -1,3 +1,4 @@
DIST libinput-1.12.6.tar.xz 518784 BLAKE2B 7462f47be3628f9c66ef5b7c8265b588bd0ca328bafe91932f5341a010ac882648b4e7cfd0db241ae526836172e0829d68d21f8966d2be8b49f4e1c0c40df018 SHA512 02ad90c77a0c8c27fd96ec34e1546c5f0947ced49bad386372c1ef7c41b3b2157c39020f0766f20aaf2ab3c97128567e169279bea21115ced39499dda325d2ef
DIST libinput-1.13.1.tar.xz 529516 BLAKE2B 9eb9952ca2762470ee3e9ac0eab6b11c4b404b2702cd81b9f0720e539124a8f71a032803cf77105bbdce412b3c5d4a7fee4e24b8d3ceae991bd2ee9b3460e373 SHA512 a19deec802e704038df0901c103a82a3370f56e0299f4cc1b6aa84c1832a66fb638e6f9d0fa708b51df6c3b939cdc1271e4ff547c645c566be03dce0bc9ff7e0
DIST libinput-1.13.2.tar.xz 529488 BLAKE2B 489f962ca0b0385817fc76a5bc7254143d12c07e32a91dd118dca53fcdd6eaf5d2eef8aa5c5598a2aadda9e4a20b8a4c9340b60dee8286cd322fe2d294f1f6b7 SHA512 26f11c5274c26acc38b9b5729195010c0799a9563f1eb0e0cd67e323f8ed73b0fc8db8584ec8fdf1b726417f64c2daeb54832167079832626c8c1190fccf459f
+DIST libinput-1.13.3.tar.xz 530916 BLAKE2B af88659252d509c22ad255963353109ad9cf05171b3bf2222f6d71872b6d2675a524c54a6ec0af28e1eab484dfeb91a9cd9db227084ffbfd6469d5726c4c882f SHA512 427ec838975444571770e129ef78fd42e4438a11e89ed0b3fc98793184d00c0ca8ed282eab2045cc6cb345804ad6fce1061af563b4f41d75405cdf2f09cb01e1
diff --git a/dev-libs/libinput/libinput-1.13.3.ebuild b/dev-libs/libinput/libinput-1.13.3.ebuild
new file mode 100644
index 000000000000..fd529371d3d1
--- /dev/null
+++ b/dev-libs/libinput/libinput-1.13.3.ebuild
@@ -0,0 +1,78 @@
+# Copyright 2014-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python{2_7,3_{5,6,7}} )
+
+inherit meson python-any-r1 udev
+
+DESCRIPTION="Library to handle input devices in Wayland"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/libinput/ https://gitlab.freedesktop.org/libinput/libinput"
+SRC_URI="https://www.freedesktop.org/software/${PN}/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0/10"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="doc input_devices_wacom"
+# Tests require write access to udev rules directory which is a no-no for live system.
+# Other tests are just about logs, exported symbols and autotest of the test library.
+RESTRICT="test"
+
+BDEPEND="
+ virtual/pkgconfig
+ doc? (
+ $(python_gen_any_dep '
+ dev-python/commonmark[${PYTHON_USEDEP}]
+ dev-python/recommonmark[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ >=dev-python/sphinx_rtd_theme-0.2.4[${PYTHON_USEDEP}]
+ ')
+ >=app-doc/doxygen-1.8.3
+ >=media-gfx/graphviz-2.38.0
+ )
+"
+# test? ( dev-util/valgrind )
+RDEPEND="
+ input_devices_wacom? ( >=dev-libs/libwacom-0.20 )
+ >=dev-libs/libevdev-1.3
+ >=sys-libs/mtdev-1.1
+ virtual/libudev:=
+ virtual/udev
+"
+DEPEND="${RDEPEND}"
+# test? ( >=dev-libs/check-0.9.10 )
+
+python_check_deps() {
+ has_version "dev-python/commonmark[${PYTHON_USEDEP}]" && \
+ has_version "dev-python/recommonmark[${PYTHON_USEDEP}]" && \
+ has_version "dev-python/sphinx[${PYTHON_USEDEP}]" && \
+ has_version ">=dev-python/sphinx_rtd_theme-0.2.4[${PYTHON_USEDEP}]"
+}
+
+pkg_setup() {
+ use doc && python-any-r1_pkg_setup
+}
+
+src_configure() {
+ # gui can be built but will not be installed
+ local emesonargs=(
+ -Ddebug-gui=false
+ $(meson_use doc documentation)
+ $(meson_use input_devices_wacom libwacom)
+ -Dtests=false # tests are restricted
+ -Dudev-dir="$(get_udevdir)"
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ if use doc ; then
+ docinto html
+ dodoc -r "${BUILD_DIR}"/Documentation/.
+ fi
+}
+
+pkg_postinst() {
+ udevadm hwdb --update --root="${ROOT%/}"
+}