summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-03-29 09:06:32 +0100
committerLars Wendler <polynomial-c@gentoo.org>2019-03-29 09:07:43 +0100
commite6ecda0e32276a893fa307879ec8c12cf44020c9 (patch)
tree6ddc6c4d070b7bbc2f0b047b5079c2c98fa017b9 /dev-libs/libinput
parentdev-ruby/dalli: add ruby26 (diff)
downloadgentoo-e6ecda0e32276a893fa307879ec8c12cf44020c9.tar.gz
gentoo-e6ecda0e32276a893fa307879ec8c12cf44020c9.tar.bz2
gentoo-e6ecda0e32276a893fa307879ec8c12cf44020c9.zip
dev-libs/libinput: Bump to version 1.13.0
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'dev-libs/libinput')
-rw-r--r--dev-libs/libinput/Manifest1
-rw-r--r--dev-libs/libinput/libinput-1.13.0.ebuild81
2 files changed, 82 insertions, 0 deletions
diff --git a/dev-libs/libinput/Manifest b/dev-libs/libinput/Manifest
index 68d2bd54bc66..fd64b782ab0a 100644
--- a/dev-libs/libinput/Manifest
+++ b/dev-libs/libinput/Manifest
@@ -2,3 +2,4 @@ DIST libinput-1.11.3.tar.xz 487408 BLAKE2B 38dc14cf018ca59279e8b6e85fd91f4b29545
DIST libinput-1.12.1.tar.xz 520072 BLAKE2B 2d2b2d82f27ac01ff25b3bf6fd7b77ca56467ab818cdc5d4a641629fed623ef5042915889f54f71b1881595af1d85770bbf4ecfd798c079878efa0a0546c4a36 SHA512 de1714526ee1244e3086729efa5b72724b2b989fa8d04418e633d1ef5a8ea777ae3cd4b8c5b015ca0da2b8cf5b07111bff2283c7d6068abcdfa81c3f71b81d68
DIST libinput-1.12.5.tar.xz 518612 BLAKE2B 6bd4c770aa4e22f3ef80cff12731dd8ed8f50ddfbc6d06c02af7b4f1b38122baea412b806825ed511ac3e586505c2dfec66061ed459c6526a74af91d275e7709 SHA512 9365b91b3ac2c4ff0f9927913242afac7677979682dd7b541001b13d09d7982acd854f6d348101cfa4b0854c6a92b4c683f62593a97870e32ae3d607eaeae3ff
DIST libinput-1.12.6.tar.xz 518784 BLAKE2B 7462f47be3628f9c66ef5b7c8265b588bd0ca328bafe91932f5341a010ac882648b4e7cfd0db241ae526836172e0829d68d21f8966d2be8b49f4e1c0c40df018 SHA512 02ad90c77a0c8c27fd96ec34e1546c5f0947ced49bad386372c1ef7c41b3b2157c39020f0766f20aaf2ab3c97128567e169279bea21115ced39499dda325d2ef
+DIST libinput-1.13.0.tar.xz 529912 BLAKE2B 830dca7387c6527ebdf41e8b01bf9d8df094ec2309e229e3933b56217d51e3ef0b0c53106d6e4d55946a238d947c17a1d7c0a8f43b63119a6f3aa1063a703d64 SHA512 0e3f53acf90fe142ad677b416d1ee830ad7f7f8a83b80023278ea7d3696ff7af5612379b387b1eb5daae6277a8c30d84c21f0086fe3d8b4b6189f239b1eeb4f8
diff --git a/dev-libs/libinput/libinput-1.13.0.ebuild b/dev-libs/libinput/libinput-1.13.0.ebuild
new file mode 100644
index 000000000000..fe9e7e7cf8c1
--- /dev/null
+++ b/dev-libs/libinput/libinput-1.13.0.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python{2_7,3_{4,5,6,7}} )
+
+inherit meson python-any-r1 udev
+
+DESCRIPTION="Library to handle input devices in Wayland"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/libinput/"
+SRC_URI="https://www.freedesktop.org/software/${PN}/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0/10"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc input_devices_wacom"
+# Tests require write access to udev rules directory which is a no-no for live system.
+# Other tests are just about logs, exported symbols and autotest of the test library.
+RESTRICT="test"
+
+RDEPEND="
+ input_devices_wacom? ( >=dev-libs/libwacom-0.20 )
+ >=dev-libs/libevdev-1.3
+ >=sys-libs/mtdev-1.1
+ virtual/libudev:=
+ virtual/udev
+"
+DEPEND="${RDEPEND}
+ doc? (
+ $(python_gen_any_dep '
+ dev-python/commonmark[${PYTHON_USEDEP}]
+ dev-python/recommonmark[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ >=dev-python/sphinx_rtd_theme-0.2.4[${PYTHON_USEDEP}]
+ ')
+ >=app-doc/doxygen-1.8.3
+ >=media-gfx/graphviz-2.38.0
+ )
+"
+# test? (
+# >=dev-libs/check-0.9.10
+# dev-util/valgrind
+# sys-libs/libunwind )
+BDEPEND="
+ virtual/pkgconfig
+"
+
+python_check_deps() {
+ has_version "dev-python/commonmark[${PYTHON_USEDEP}]" && \
+ has_version "dev-python/recommonmark[${PYTHON_USEDEP}]" && \
+ has_version "dev-python/sphinx[${PYTHON_USEDEP}]" && \
+ has_version ">=dev-python/sphinx_rtd_theme-0.2.4[${PYTHON_USEDEP}]"
+}
+
+pkg_setup() {
+ use doc && python-any-r1_pkg_setup
+}
+
+src_configure() {
+ # gui can be built but will not be installed
+ local emesonargs=(
+ -Ddebug-gui=false
+ $(meson_use doc documentation)
+ $(meson_use input_devices_wacom libwacom)
+ -Dtests=false # tests are restricted
+ -Dudev-dir="$(get_udevdir)"
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ if use doc ; then
+ docinto html
+ dodoc -r "${BUILD_DIR}"/Documentation/.
+ fi
+}
+
+pkg_postinst() {
+ udevadm hwdb --update --root="${ROOT%/}"
+}