summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Andrejak <thomas.andrejak@gmail.com>2018-05-19 18:32:52 +0200
committerTony Vroon <chainsaw@gentoo.org>2018-07-18 08:31:49 +0100
commit2bc6b2674f0f1fe9f4bd0828ba35214962d64c94 (patch)
treec1d8a1e65f040009e49b77ec09195b15250922b5 /dev-libs/libprelude
parentmedia-sound/grip: Removed old. (diff)
downloadgentoo-2bc6b2674f0f1fe9f4bd0828ba35214962d64c94.tar.gz
gentoo-2bc6b2674f0f1fe9f4bd0828ba35214962d64c94.tar.bz2
gentoo-2bc6b2674f0f1fe9f4bd0828ba35214962d64c94.zip
dev-libs/libprelude: Bump version 4.1
Closes: https://github.com/gentoo/gentoo/pull/9239 Closes: https://bugs.gentoo.org/645852
Diffstat (limited to 'dev-libs/libprelude')
-rw-r--r--dev-libs/libprelude/Manifest1
-rw-r--r--dev-libs/libprelude/libprelude-4.1.0.ebuild92
2 files changed, 93 insertions, 0 deletions
diff --git a/dev-libs/libprelude/Manifest b/dev-libs/libprelude/Manifest
index 4db09474f9e3..d853c53840be 100644
--- a/dev-libs/libprelude/Manifest
+++ b/dev-libs/libprelude/Manifest
@@ -1,3 +1,4 @@
DIST libprelude-3.0.0.tar.gz 2900153 BLAKE2B dd03b46a11b673252dc36701e4568c445fe1e3a61a79c92ce04ed6fefac804983ba03e39928038a67768d9e5e0542d74703c07254c0112d5a6906a7c37ae4403 SHA512 a1fd51aa3bb1b68759a00dd1636cb96379f0e954a66f4e39887ab20a5b4c191a0455dd6bd5f41b20ad94d06fff59af7f89b258f42e1c0dd4cfc99185a77d1797
DIST libprelude-3.1.0.tar.gz 2949462 BLAKE2B 52764791766c54e2c1baa96231c6578f06219a6d1c48a97ad318fc8445fc64f90a63019654f7350d65ec4e0a336eef66bd449484321c590d1ee4596a6a386724 SHA512 f2878b19b4ba3cc74b0530f8741525ecf1425540d30356d182c4e0a797dbb5f4023792351bd059105dafc6b7818d4caa2e9c8b39be9a7039a89680244fcf1239
DIST libprelude-4.0.0.tar.gz 2864402 BLAKE2B 2e51eb1af74b63140bc66a358b112a753c1a0fd86d6bb8bb43ccddca4cd396e34566168edca55a626a0b43ba56e676301f3792247c25f64c7a31430af3708311 SHA512 5d88e8f211b09cc3e43dbe299e935d8f11575ae3f1894059793966cd14a8e47177ef8963d45305e1a24f9efc4048520329b31681301a21815909bd38606c2ce7
+DIST libprelude-4.1.0.tar.gz 2852916 BLAKE2B a18babb24795d17d72eb1c0755f4b0330125c8b289af0b52753f6f69b5e820f0f972019b57eaded3abfc45c69bd75c0d120fe29982887e55d75f2c4c8b6486f7 SHA512 073307ca070794b47643e2ef2db4788fa92374735558b466441f0663f420cab45aecc7a1d99bb487ad23ebe602d5668369ffa6ab29fa3b0504356420ab3a7878
diff --git a/dev-libs/libprelude/libprelude-4.1.0.ebuild b/dev-libs/libprelude/libprelude-4.1.0.ebuild
new file mode 100644
index 000000000000..975d9e553ea4
--- /dev/null
+++ b/dev-libs/libprelude/libprelude-4.1.0.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} )
+USE_RUBY="ruby22 ruby23 ruby24 ruby25"
+DISTUTILS_OPTIONAL=1
+
+inherit autotools distutils-r1 ruby-single
+
+DESCRIPTION="Prelude-SIEM Framework Library"
+HOMEPAGE="https://www.prelude-siem.org"
+SRC_URI="https://www.prelude-siem.org/pkg/src/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="lua perl python ruby"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="net-libs/gnutls:=
+ lua? ( dev-lang/lua:* )
+ perl? ( dev-lang/perl:= virtual/perl-ExtUtils-MakeMaker )
+ python? ( ${PYTHON_DEPS} )
+ ruby? ( ${RUBY_DEPS} )"
+
+DEPEND="${RDEPEND}
+ >=dev-lang/swig-3.0.11
+ dev-util/gtk-doc-am
+ sys-devel/flex
+ virtual/pkgconfig
+ virtual/yacc"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-4.0.0-fix-python-bindings.patch"
+)
+
+src_prepare() {
+ default
+
+ # Avoid null runpaths in Perl bindings.
+ sed -e 's/ LD_RUN_PATH=""//' -i "${S}/bindings/Makefile.am" || die "sed failed"
+
+ eautoreconf
+
+ if use python; then
+ cd bindings/python || die
+ distutils-r1_src_prepare
+ fi
+}
+
+src_configure() {
+ local myconf=(
+ --enable-easy-bindings
+ --with-swig
+ $(use_with lua)
+ $(use_with perl)
+ $(usex perl '--with-perl-installdirs=vendor' '')
+ $(use_with ruby)
+ )
+
+ if use python; then
+ python_setup
+ if python_is_python3; then
+ myconf+=(--without-python2 --with-python3="${EPYTHON}")
+ else
+ myconf+=(--without-python3 --with-python2="${EPYTHON}")
+ fi
+ else
+ myconf+=(--without-python2 --without-python3)
+ fi
+
+ econf "${myconf[@]}"
+}
+
+src_compile() {
+ default
+ if use python; then
+ cd bindings/python || die
+ distutils-r1_src_compile
+ fi
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+ if use python; then
+ cd bindings/python || die
+ distutils-r1_src_install
+ fi
+}