summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@whissi.de>2016-05-10 14:40:09 +0200
committerLars Wendler <polynomial-c@gentoo.org>2016-05-10 14:42:14 +0200
commitf318caf29ae5bc7722447481538875bc48aad4e5 (patch)
tree869c172f42e2c8328a74debd50d57696fd79fb08 /dev-libs/librdkafka
parentnet-libs/onion: bump to 0.8; bug #582534 (diff)
downloadgentoo-f318caf29ae5bc7722447481538875bc48aad4e5.tar.gz
gentoo-f318caf29ae5bc7722447481538875bc48aad4e5.tar.bz2
gentoo-f318caf29ae5bc7722447481538875bc48aad4e5.zip
dev-libs/librdkafka: Respect CC/CXX variables (bug #581512).
Package-Manager: portage-2.2.28 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'dev-libs/librdkafka')
-rw-r--r--dev-libs/librdkafka/librdkafka-0.9.0.99.ebuild5
1 files changed, 5 insertions, 0 deletions
diff --git a/dev-libs/librdkafka/librdkafka-0.9.0.99.ebuild b/dev-libs/librdkafka/librdkafka-0.9.0.99.ebuild
index f1bf44992785..267ff49c810a 100644
--- a/dev-libs/librdkafka/librdkafka-0.9.0.99.ebuild
+++ b/dev-libs/librdkafka/librdkafka-0.9.0.99.ebuild
@@ -4,6 +4,8 @@
EAPI=6
+inherit toolchain-funcs
+
DESCRIPTION="Apache Kafka C/C++ client library"
HOMEPAGE="https://github.com/edenhill/librdkafka"
@@ -38,9 +40,12 @@ DEPEND="
"
src_configure() {
+ tc-export CC CXX LD NM OBJDUMP PKG_CONFIG STRIP
+
local myeconf=(
--no-cache
--no-download
+ --disable-debug-symbols
$(use_enable sasl)
$(usex static-libs '--enable-static' '')
$(use_enable ssl)