summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2021-09-07 17:05:34 +0200
committerPacho Ramos <pacho@gentoo.org>2021-09-07 17:08:10 +0200
commit16478b44b865d25cd538ff9b2d2716beba62d601 (patch)
tree558da65c5ad16941c8ede37bf6f36d49d085890d /dev-libs/libreport
parentdev-libs/satyr: Drop old (diff)
downloadgentoo-16478b44b865d25cd538ff9b2d2716beba62d601.tar.gz
gentoo-16478b44b865d25cd538ff9b2d2716beba62d601.tar.bz2
gentoo-16478b44b865d25cd538ff9b2d2716beba62d601.zip
dev-libs/libreport: Bump to 2.15.2
Package-Manager: Portage-3.0.22, Repoman-3.0.3 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'dev-libs/libreport')
-rw-r--r--dev-libs/libreport/Manifest1
-rw-r--r--dev-libs/libreport/libreport-2.15.2.ebuild100
2 files changed, 101 insertions, 0 deletions
diff --git a/dev-libs/libreport/Manifest b/dev-libs/libreport/Manifest
index 3986245a1653..640e49ba9cd2 100644
--- a/dev-libs/libreport/Manifest
+++ b/dev-libs/libreport/Manifest
@@ -1,3 +1,4 @@
DIST libreport-2.13.1.tar.gz 1841698 BLAKE2B e0fbebbb557fb9fb320dea0a8face6a2eabdb0ad80b5de092e5e4dfe2a0439a4804d4ec99c1286aaafa31064496a94fabce5e26f851001eb9c3bb9989a46e4bb SHA512 6c2ea47e6efa36f23030fbe08946d1e524690e5f6279cbfdaf7c463ef71b23ae82a5e4471ddce89b35d4024f58197cef9f58a07dfcf5bbc1a9b310e39966f81a
DIST libreport-2.15.0.tar.gz 1859305 BLAKE2B ceedd392bd0c7fc5c3f0db5d4a63ced6a1e430b09d1d085996ce735daef5f48cd18267fb1401d9343857619daef6f7f3dcea8508c62313a9f908e5573508649c SHA512 7baaa1fb65face910e55ad06e53af08c5e31f058bf5936c3c1d45581e050380b5db75659b5a493cc626a81795d82616a2dfad696d60c107929cfb8e2905e7f4c
DIST libreport-2.15.1.tar.gz 1860410 BLAKE2B 43743fc7a7698851e247956621286cc94dbfcc451b8d95aaff9263e65f787b23f7bbf5d7ec087196d5f9f30a697c66e547bbccdc913b3ea2a17ea4c7bf77ee02 SHA512 70f947690173a0afa57981c9755a18bdd0ad44c888c00713de74624296b81ff25203d5dda5d5c57eac85da4a1631585184b77715c7adf6688b469e32d4113cf4
+DIST libreport-2.15.2.tar.gz 1859867 BLAKE2B f890e3cb8b2a23647e4c3fb0caaf984b1b21fd32e066d04f835f8a475e317cbc75287375e0a10a01b91670d04bba1f15b1180065f7029b8d7d1c0a2fb890914b SHA512 c98003325fa70d674177c9f602a7f121815a9675701ee780ad8908ed69862f2c69be65c7483fd3f017ba299dda51ba304f0908c771c9d97cb5bba057e3a9c5dc
diff --git a/dev-libs/libreport/libreport-2.15.2.ebuild b/dev-libs/libreport/libreport-2.15.2.ebuild
new file mode 100644
index 000000000000..debf3b612b4a
--- /dev/null
+++ b/dev-libs/libreport/libreport-2.15.2.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{7..10} )
+
+inherit autotools python-r1
+
+DESCRIPTION="Generic library for reporting software bugs"
+HOMEPAGE="https://github.com/abrt/libreport"
+SRC_URI="https://github.com/abrt/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0/2"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="gtk +python"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}
+ app-admin/augeas
+ app-arch/libarchive:0=
+ >=dev-libs/glib-2.43.4:2
+ dev-libs/satyr:0=
+ dev-libs/json-c:=
+ dev-libs/libxml2:2
+ dev-libs/nettle:=
+ dev-libs/newt:=
+ dev-libs/xmlrpc-c:=
+ net-libs/libproxy:=
+ net-misc/curl:=[ssl]
+ sys-apps/dbus
+ sys-apps/systemd
+ gtk? ( >=x11-libs/gtk+-3.3.12:3 )
+ python? ( ${PYTHON_DEPS} )
+ x11-misc/xdg-utils
+"
+RDEPEND="${DEPEND}
+ acct-user/abrt
+ acct-group/abrt
+"
+BDEPEND="
+ app-text/asciidoc
+ app-text/xmlto
+ >=dev-util/intltool-0.3.50
+ >=sys-devel/gettext-0.17
+ virtual/pkgconfig
+"
+
+# Tests require python-meh, which is highly redhat-specific.
+RESTRICT="test"
+
+src_prepare() {
+ default
+ ./gen-version || die # Needed to be run before autoreconf
+ eautoreconf
+ use python && python_copy_sources
+}
+
+src_configure() {
+ use python && python_setup
+
+ local myargs=(
+ --localstatedir="${EPREFIX}/var"
+ --without-bugzilla
+ $(use_with gtk)
+ $(use_with python python3)
+ )
+ if use python; then
+ python_foreach_impl run_in_build_dir econf "${myargs[@]}"
+ else
+ econf "${myargs[@]}"
+ fi
+}
+
+src_compile() {
+ if use python; then
+ python_foreach_impl run_in_build_dir default
+ else
+ default
+ fi
+}
+
+src_install() {
+ if use python; then
+ python_install() {
+ default
+ python_optimize
+ }
+ python_foreach_impl run_in_build_dir python_install
+ else
+ default
+ fi
+
+ # Need to set correct ownership for use by app-admin/abrt
+ diropts -o abrt -g abrt
+ keepdir /var/spool/abrt
+
+ find "${D}" -name '*.la' -exec rm -f {} + || die
+}