summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Strogin <steils@gentoo.org>2019-10-02 01:15:38 +0300
committerStefan Strogin <steils@gentoo.org>2019-10-02 03:04:01 +0300
commitf8dffd44d05a3f1c883b0e80f8b3aec20a5ee6a6 (patch)
tree1d7ad2e8ea099654c4210ec1373572c123bb909e /dev-libs/libressl
parentdev-java/openjdk-bin: drop 11.0.3_p7-r1 (diff)
downloadgentoo-f8dffd44d05a3f1c883b0e80f8b3aec20a5ee6a6.tar.gz
gentoo-f8dffd44d05a3f1c883b0e80f8b3aec20a5ee6a6.tar.bz2
gentoo-f8dffd44d05a3f1c883b0e80f8b3aec20a5ee6a6.zip
dev-libs/libressl: version bump to 3.0.1
Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Stefan Strogin <steils@gentoo.org>
Diffstat (limited to 'dev-libs/libressl')
-rw-r--r--dev-libs/libressl/Manifest1
-rw-r--r--dev-libs/libressl/libressl-3.0.1.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-libs/libressl/Manifest b/dev-libs/libressl/Manifest
index 733e24a4f32e..37752079053f 100644
--- a/dev-libs/libressl/Manifest
+++ b/dev-libs/libressl/Manifest
@@ -3,3 +3,4 @@ DIST libressl-2.8.3.tar.gz 3366196 BLAKE2B e32c097b31998d68a31266fbbf3624d5ab8ca
DIST libressl-2.9.1.tar.gz 3607116 BLAKE2B a4542d7fc97bfd213162fe908e28b27d52329e2b6a5d77e0cb67d1a6732c500ca772d0c5735c9fcd036c477e6ede330305b4675bfcff9f72fd7886a781f30015 SHA512 7051911e566bb093c48a70da72c9981b870e3bf49a167ba6c934eece873084cc41221fbe3cd0c8baba268d0484070df7164e4b937854e716337540a87c214354
DIST libressl-2.9.2.tar.gz 3607549 BLAKE2B 496e993e4f1c85167e0344afab61259d4e3f094a7e5dfac85878191070e2c196753162532efb921fab582481aeda3705fca9a2b48921cba82465192f2c1eef95 SHA512 b43e73e47c1f14da3c702ab42f29f1d67645a4fa425441337bd6c125b481ef78a40fd13e6b34dadb2af337e1c0c190cfb616186d4db9c9a743a37e594b9b8033
DIST libressl-3.0.0.tar.gz 3620475 BLAKE2B c1dc1709e60cfbfa9907c206340262b78e1bfb991d3956dfc0a5d8d80f80b61df41059e645f9f096185724470e8466a5b7a444a575f5f09d5a0f9eb35ff3ae7e SHA512 460fa390012218262b7c148a28e6ddfc0dc3d669c4bdd37b68bfa6f50a0cb2fb81a277fb46ae0ac22673aae5b5cc4476fe96e56471a6812176bf76e9c5e10838
+DIST libressl-3.0.1.tar.gz 3668819 BLAKE2B 0e0e9db5018f7fd6c5d3f15dd911e375ae51885321fda2a6bef8f56620ca9d8b63d587f5acdf78afafabdd7ee1243c79bdf9b68a890dfc5f76fa45bbaf060563 SHA512 d2d665734d8aab2b998769492cbb1e7fddead52430ef503650c14786196241a6d1137f47b33ddf2037cc1ff13c240283f591dce83ec0da475619679a051d725f
diff --git a/dev-libs/libressl/libressl-3.0.1.ebuild b/dev-libs/libressl/libressl-3.0.1.ebuild
new file mode 100644
index 000000000000..65dfe075bbcc
--- /dev/null
+++ b/dev-libs/libressl/libressl-3.0.1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multilib-minimal libtool
+
+DESCRIPTION="Free version of the SSL/TLS protocol forked from OpenSSL"
+HOMEPAGE="https://www.libressl.org/"
+SRC_URI="https://ftp.openbsd.org/pub/OpenBSD/LibreSSL/${P}.tar.gz"
+
+LICENSE="ISC openssl"
+# Reflects ABI of libcrypto.so and libssl.so. Since these can differ,
+# we'll try to use the max of either. However, if either change between
+# versions, we have to change the subslot to trigger rebuild of consumers.
+SLOT="0/47"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="+asm static-libs test"
+REQUIRED_USE="test? ( static-libs )"
+
+RDEPEND="!dev-libs/openssl:0"
+DEPEND="${RDEPEND}"
+PDEPEND="app-misc/ca-certificates"
+
+src_prepare() {
+ touch crypto/Makefile.in
+
+ sed -i \
+ -e '/^[ \t]*CFLAGS=/s#-g ##' \
+ -e '/^[ \t]*CFLAGS=/s#-g"#"#' \
+ -e '/^[ \t]*CFLAGS=/s#-O2 ##' \
+ -e '/^[ \t]*CFLAGS=/s#-O2"#"#' \
+ -e '/^[ \t]*USER_CFLAGS=/s#-O2 ##' \
+ -e '/^[ \t]*USER_CFLAGS=/s#-O2"#"#' \
+ configure || die "fixing CFLAGS failed"
+
+ if ! use test ; then
+ sed -i \
+ -e '/^[ \t]*SUBDIRS =/s#tests##' \
+ Makefile.in || die "Removing tests failed"
+ fi
+
+ eapply "${FILESDIR}"/${PN}-2.8.3-solaris10.patch
+ eapply_user
+
+ elibtoolize # for Solaris
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf \
+ $(use_enable asm) \
+ $(use_enable static-libs static)
+}
+
+multilib_src_test() {
+ emake check
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ find "${D}" -name '*.la' -exec rm -f {} + || die
+}