summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2016-09-16 01:43:57 +0200
committerDavid Seifert <soap@gentoo.org>2016-09-16 01:58:32 +0200
commit4e84a3962bec6a22d6128e1d4594815c96656985 (patch)
tree042d0377326b304869acf6825fccb5b4dc09fd6f /dev-libs/log4cxx
parentdev-libs/log4cxx: Allow for compiling with GCC 6 (diff)
downloadgentoo-4e84a3962bec6a22d6128e1d4594815c96656985.tar.gz
gentoo-4e84a3962bec6a22d6128e1d4594815c96656985.tar.bz2
gentoo-4e84a3962bec6a22d6128e1d4594815c96656985.zip
dev-libs/log4cxx: Remove old ebuild
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-libs/log4cxx')
-rw-r--r--dev-libs/log4cxx/log4cxx-0.10.0.ebuild65
1 files changed, 0 insertions, 65 deletions
diff --git a/dev-libs/log4cxx/log4cxx-0.10.0.ebuild b/dev-libs/log4cxx/log4cxx-0.10.0.ebuild
deleted file mode 100644
index 95e943783628..000000000000
--- a/dev-libs/log4cxx/log4cxx-0.10.0.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=2
-inherit eutils
-
-MY_P=apache-${P}
-
-DESCRIPTION="Library of C++ classes for flexible logging to files, syslog and other destinations"
-HOMEPAGE="http://logging.apache.org/log4cxx/"
-SRC_URI="mirror://apache/logging/${PN}/${PV}/${MY_P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~x86 ~amd64-linux ~ppc-macos"
-IUSE="iodbc unicode odbc smtp"
-
-DEPEND="dev-libs/apr:1
- dev-libs/apr-util:1
- odbc? (
- iodbc? ( >=dev-db/libiodbc-3.52.4 )
- !iodbc? ( dev-db/unixODBC ) )
- smtp? ( net-libs/libesmtp )"
-
-S=${WORKDIR}/${MY_P}
-
-pkg_setup() {
- if use iodbc && ! use odbc; then
- elog "Please enable the odbc USE-flag as well if you want odbc-support through iodbc."
- fi
-}
-
-src_prepare() {
- epatch "${FILESDIR}"/${PV}-missing_includes.patch \
- "${FILESDIR}"/${P}-gcc44.patch \
- "${FILESDIR}"/${P}-unixODBC.patch
-}
-
-src_configure() {
- local myconf
- use smtp && myconf="${myconf} --with-SMTP=libesmtp"
- if use odbc; then
- if use iodbc; then
- myconf="${myconf} --with-ODBC=iODBC"
- else
- myconf="${myconf} --with-ODBC=unixODBC"
- fi
- fi
- use unicode && myconf="${myconf} --with-charset=utf-8"
-
- econf \
- --disable-doxygen \
- --disable-html-docs \
- --with-apr-util="${SYSROOT:-${EPREFIX}}/usr" \
- ${myconf}
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
- dohtml -r site/*
-
- insinto /usr/share/doc/${PF}/examples
- doins src/examples/cpp/*.cpp
-}