summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikhail Klementev <jollheef@riseup.net>2018-08-10 07:58:21 +0000
committerMichał Górny <mgorny@gentoo.org>2018-09-13 19:37:41 +0200
commit3734b0e038e549ebd1942b73c95c7c84f1750a0d (patch)
tree1fcc5a7bc6b5adfe82d2a1959b52e31ddcae2f7c /dev-libs/processor-trace/processor-trace-1.6.1.ebuild
parentdev-qt/qtwebengine: Drop net-libs/libsrtp DEPEND (diff)
downloadgentoo-3734b0e038e549ebd1942b73c95c7c84f1750a0d.tar.gz
gentoo-3734b0e038e549ebd1942b73c95c7c84f1750a0d.tar.bz2
gentoo-3734b0e038e549ebd1942b73c95c7c84f1750a0d.zip
dev-libs/processor-trace: Intel(R) Processor Trace decoder library
Closes: https://github.com/gentoo/gentoo/pull/9523
Diffstat (limited to 'dev-libs/processor-trace/processor-trace-1.6.1.ebuild')
-rw-r--r--dev-libs/processor-trace/processor-trace-1.6.1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-libs/processor-trace/processor-trace-1.6.1.ebuild b/dev-libs/processor-trace/processor-trace-1.6.1.ebuild
new file mode 100644
index 000000000000..5e70a10ca37a
--- /dev/null
+++ b/dev-libs/processor-trace/processor-trace-1.6.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="Intel(R) Processor Trace decoder library"
+HOMEPAGE="https://github.com/01org/processor-trace"
+SRC_URI="https://github.com/01org/processor-trace/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT=0
+KEYWORDS="-* ~amd64"
+IUSE="doc test"
+
+DEPEND="doc? ( app-text/pandoc )"
+
+src_configure() {
+ local mycmakeargs=(
+ -DMAN=$(usex doc)
+ -DPTUNIT=$(usex test)
+ )
+
+ cmake-utils_src_configure
+}