summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2020-12-05 18:43:48 -0800
committerPatrick McLean <chutzpah@gentoo.org>2020-12-05 18:43:54 -0800
commit41ad8bd14fea96b6b5c96e5e62568bf62d15f292 (patch)
treede5baa8d031e00fbb184a401f125bc1166e9989c /dev-libs/simdjson
parentdev-lang/lua: migrate 5.2.4 to eapi 7 (diff)
downloadgentoo-41ad8bd14fea96b6b5c96e5e62568bf62d15f292.tar.gz
gentoo-41ad8bd14fea96b6b5c96e5e62568bf62d15f292.tar.bz2
gentoo-41ad8bd14fea96b6b5c96e5e62568bf62d15f292.zip
dev-libs/simdjson-0.7.0-r3: Revbump, fix file collision
Package-Manager: Portage-3.0.11, Repoman-3.0.2 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-libs/simdjson')
-rw-r--r--dev-libs/simdjson/files/simdjson-0.7.0-dont-bundle-cssopts.patch7
-rw-r--r--dev-libs/simdjson/simdjson-0.7.0-r3.ebuild (renamed from dev-libs/simdjson/simdjson-0.7.0-r2.ebuild)0
2 files changed, 4 insertions, 3 deletions
diff --git a/dev-libs/simdjson/files/simdjson-0.7.0-dont-bundle-cssopts.patch b/dev-libs/simdjson/files/simdjson-0.7.0-dont-bundle-cssopts.patch
index 1f82151fb3d4..f734a65bd891 100644
--- a/dev-libs/simdjson/files/simdjson-0.7.0-dont-bundle-cssopts.patch
+++ b/dev-libs/simdjson/files/simdjson-0.7.0-dont-bundle-cssopts.patch
@@ -10,7 +10,7 @@ index 51ab3a31..d3d5e86e 100644
-import_dependency(cxxopts jarro2783/cxxopts 794c975)
-add_dependency(cxxopts)
diff --git a/tools/CMakeLists.txt b/tools/CMakeLists.txt
-index f1a82be7..217a9fee 100644
+index f1a82be7..5c36d994 100644
--- a/tools/CMakeLists.txt
+++ b/tools/CMakeLists.txt
@@ -1,10 +1,7 @@
@@ -20,10 +20,11 @@ index f1a82be7..217a9fee 100644
+ link_libraries(simdjson simdjson-internal-flags simdjson-windows-headers)
add_executable(json2json json2json.cpp)
add_executable(jsonstats jsonstats.cpp)
- add_executable(jsonpointer jsonpointer.cpp)
+- add_executable(jsonpointer jsonpointer.cpp)
++ add_executable(simdjsonpointer jsonpointer.cpp)
add_executable(minify minify.cpp)
-else()
- message(STATUS "We are missing cxxopts as a dependency so the tools (e.g., json2json) are omitted.")
-endif()
\ No newline at end of file
-+ install(TARGETS json2json jsonstats jsonpointer minify DESTINATION bin)
++ install(TARGETS json2json jsonstats simdjsonpointer minify DESTINATION bin)
diff --git a/dev-libs/simdjson/simdjson-0.7.0-r2.ebuild b/dev-libs/simdjson/simdjson-0.7.0-r3.ebuild
index 9a29c8f04503..9a29c8f04503 100644
--- a/dev-libs/simdjson/simdjson-0.7.0-r2.ebuild
+++ b/dev-libs/simdjson/simdjson-0.7.0-r3.ebuild