summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernd Waibel <waebbl-gentoo@posteo.net>2021-06-16 10:43:01 +0200
committerSam James <sam@gentoo.org>2021-06-21 23:26:04 +0100
commit9d31cdd2b84207dafe2af4e969a12742a7630836 (patch)
treece944906e7ffef3252f0c270fc5591a78fc1dc4f /dev-libs/tvision
parentgnome-extra/cinnamon-settings-daemon: 5.0.2 version bump (diff)
downloadgentoo-9d31cdd2b84207dafe2af4e969a12742a7630836.tar.gz
gentoo-9d31cdd2b84207dafe2af4e969a12742a7630836.tar.bz2
gentoo-9d31cdd2b84207dafe2af4e969a12742a7630836.zip
dev-libs/tvision: properly detect ar
Closes: https://bugs.gentoo.org/796278 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Bernd Waibel <waebbl-gentoo@posteo.net> Closes: https://github.com/gentoo/gentoo/pull/21333 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/tvision')
-rw-r--r--dev-libs/tvision/files/tvision-2.2.3-0001-Added-ar-command-now-can-be-configured-from-the-envi.patch56
-rw-r--r--dev-libs/tvision/files/tvision-2.2.3-0001-use-proper-AR.patch23
-rw-r--r--dev-libs/tvision/files/tvision-2.2.3-0002-Added-configuration-option-to-exclude-libgpm.patch60
-rw-r--r--dev-libs/tvision/files/tvision-2.2.3-0003-Adjusted-c-years.patch34
-rw-r--r--dev-libs/tvision/files/tvision-2.2.3-0004-Made-ar-command-configurable.patch23
-rw-r--r--dev-libs/tvision/tvision-2.2.3.ebuild10
6 files changed, 180 insertions, 26 deletions
diff --git a/dev-libs/tvision/files/tvision-2.2.3-0001-Added-ar-command-now-can-be-configured-from-the-envi.patch b/dev-libs/tvision/files/tvision-2.2.3-0001-Added-ar-command-now-can-be-configured-from-the-envi.patch
new file mode 100644
index 000000000000..239161b2f0a9
--- /dev/null
+++ b/dev-libs/tvision/files/tvision-2.2.3-0001-Added-ar-command-now-can-be-configured-from-the-envi.patch
@@ -0,0 +1,56 @@
+From: "Salvador E. Tropea" <salvador@inti.gob.ar>
+Date: Thu, 17 Jun 2021 13:11:22 -0300
+Subject: [PATCH 1/4] Added `ar` command now can be configured from the
+ environment
+
+- Using the AR environment variable.
+- Related to issue: #1
+- Gentoo issue: https://bugs.gentoo.org/796278
+---
+ conflib.pl | 24 +++++++++++++++---------
+ 1 file changed, 15 insertions(+), 9 deletions(-)
+
+diff --git a/conflib.pl b/conflib.pl
+index 0abd33df..946bfa95 100644
+--- a/conflib.pl
++++ b/conflib.pl
+@@ -1386,21 +1386,27 @@ sub LookForGNUMake
+
+ sub LookForGNUar
+ {
+- my $test;
+- print 'Looking for GNU ar: ';
++ my ($ar, $test);
+
+- if ($conf{'GNU_AR'})
++ print 'Looking for GNU ar: ';
++ $ar=$conf{'GNU_AR'};
++ if ($ar)
+ {
+- print "$conf{'GNU_AR'} (cached)\n";
+- return $conf{'GNU_AR'};
++ print "$ar (cached)\n";
++ return $ar;
++ }
++ $ar=$ENV{'AR'};
++ if (!length($ar))
++ {
++ $ar='ar';
+ }
+ $conf{'UseRanLib'}=0;
+- $test=RunRedirect('ar --version',$ErrorLog);
++ $test=RunRedirect($ar.' --version',$ErrorLog);
+ if (($test=~/GNU ar/) || ($test=~/BSD ar/))
+ {
+- $conf{'GNU_AR'}='ar';
+- print "ar\n";
+- return 'ar';
++ $conf{'GNU_AR'}=$ar;
++ print "$ar\n";
++ return $ar;
+ }
+ $test=RunRedirect('gar --version',$ErrorLog);
+ if ($test=~/GNU ar/)
+--
+2.32.0
+
diff --git a/dev-libs/tvision/files/tvision-2.2.3-0001-use-proper-AR.patch b/dev-libs/tvision/files/tvision-2.2.3-0001-use-proper-AR.patch
deleted file mode 100644
index ce45ec32ef5e..000000000000
--- a/dev-libs/tvision/files/tvision-2.2.3-0001-use-proper-AR.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-From 017a1059067ab58a9286b3049505cb3e77696de5 Mon Sep 17 00:00:00 2001
-From: Bernd Waibel <waebbl-gentoo@posteo.net>
-Date: Mon, 14 Jun 2021 17:48:45 +0200
-Subject: [PATCH 2/2] use proper AR
-
-Signed-off-by: Bernd Waibel <waebbl-gentoo@posteo.net>
----
- intl/dummy/Makefile | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/intl/dummy/Makefile b/intl/dummy/Makefile
-index c32b0a8..d47e185 100644
---- a/intl/dummy/Makefile
-+++ b/intl/dummy/Makefile
-@@ -2,4 +2,4 @@ RHIDE_GCC=gcc
- CC=$(RHIDE_GCC)
-
- libtvfintl.a: intldummy.o
-- ar -rv libtvfintl.a intldummy.o
-+ $(AR) -rv libtvfintl.a intldummy.o
---
-2.32.0
-
diff --git a/dev-libs/tvision/files/tvision-2.2.3-0002-Added-configuration-option-to-exclude-libgpm.patch b/dev-libs/tvision/files/tvision-2.2.3-0002-Added-configuration-option-to-exclude-libgpm.patch
new file mode 100644
index 000000000000..03cbb76a82d9
--- /dev/null
+++ b/dev-libs/tvision/files/tvision-2.2.3-0002-Added-configuration-option-to-exclude-libgpm.patch
@@ -0,0 +1,60 @@
+From: "Salvador E. Tropea" <salvador@inti.gob.ar>
+Date: Thu, 17 Jun 2021 13:28:36 -0300
+Subject: [PATCH 2/4] Added configuration option to exclude libgpm
+
+- Fixes #1
+---
+ config.pl | 16 ++++++++++++++--
+ 1 file changed, 14 insertions(+), 2 deletions(-)
+
+diff --git a/config.pl b/config.pl
+index 21d81ff3..424e3065 100644
+--- a/config.pl
++++ b/config.pl
+@@ -73,7 +73,14 @@ if ($OS eq 'DOS')
+
+ if ($OS eq 'UNIX')
+ {
+- LookForGPM($GPMVersionNeeded);
++ if ($conf{'gpm'} eq 'no')
++ {
++ $conf{'HAVE_GPM'}='no';
++ }
++ else
++ {
++ LookForGPM($GPMVersionNeeded);
++ }
+ LookForNCurses($NCursesVersionNeeded);
+ LookForKeysyms();
+ LookForXlib();
+@@ -424,6 +431,10 @@ sub SeeCommandLine
+ {
+ $conf{'no-dynamic'}='yes';
+ }
++ elsif ($i eq '--without-gpm')
++ {
++ $conf{'gpm'}='no';
++ }
+ # elsif ($i eq '--unsafe-memcpy')
+ # {
+ # $conf{'HAVE_UNSAFE_MEMCPY'}='yes';
+@@ -482,6 +493,7 @@ sub ShowHelp
+ print "--no-intl : don't use international support.\n";
+ print "--without-static : don't create the static library.\n";
+ print "--without-dynamic: don't create the dynamic library.\n";
++ print "--without-gpm : skip gpm library detection.\n";
+ print "--with-mss : compiles with MSS memory debugger.\n";
+ print "--without-mss : compiles without MSS [default].\n";
+ print "--with-ssc : compiles using Simple Streams Compatibility.\n";
+@@ -532,7 +544,7 @@ sub GiveAdvice
+ print " using this library reconfigure using --no-intl. Read about it in the readme.\n";
+ print " [[[[[[[*******************>>>>> IMPORTANT!!! <<<<<*******************]]]]]]]\n";
+ }
+- if ((@conf{'HAVE_GPM'} eq 'no') && ($OSf eq 'Linux'))
++ if ((@conf{'HAVE_GPM'} eq 'no') && ($OSf eq 'Linux') && ($conf{'gpm'} ne 'no'))
+ {
+ print "\n";
+ print "* No mouse support for console! please install the libgpm package needed\n";
+--
+2.32.0
+
diff --git a/dev-libs/tvision/files/tvision-2.2.3-0003-Adjusted-c-years.patch b/dev-libs/tvision/files/tvision-2.2.3-0003-Adjusted-c-years.patch
new file mode 100644
index 000000000000..743591c324ad
--- /dev/null
+++ b/dev-libs/tvision/files/tvision-2.2.3-0003-Adjusted-c-years.patch
@@ -0,0 +1,34 @@
+From: "Salvador E. Tropea" <salvador@inti.gob.ar>
+Date: Thu, 17 Jun 2021 13:35:42 -0300
+Subject: [PATCH 3/4] Adjusted (c) years
+
+---
+ config.pl | 2 +-
+ conflib.pl | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/config.pl b/config.pl
+index 424e3065..cda54600 100644
+--- a/config.pl
++++ b/config.pl
+@@ -1,5 +1,5 @@
+ #!/usr/bin/perl
+-# Copyright (C) 1999-2012 by Salvador E. Tropea (SET),
++# Copyright (C) 1999-2021 by Salvador E. Tropea (SET),
+ # see copyrigh file for details
+ #
+ # To specify the compilation flags define the CFLAGS environment variable.
+diff --git a/conflib.pl b/conflib.pl
+index 946bfa95..c8e70204 100644
+--- a/conflib.pl
++++ b/conflib.pl
+@@ -1,5 +1,5 @@
+ #!/usr/bin/perl
+-# Copyright (C) 1999-2004 by Salvador E. Tropea (SET),
++# Copyright (C) 1999-2021 by Salvador E. Tropea (SET),
+ # see copyrigh file for details
+ #
+ # Common configuration routines.
+--
+2.32.0
+
diff --git a/dev-libs/tvision/files/tvision-2.2.3-0004-Made-ar-command-configurable.patch b/dev-libs/tvision/files/tvision-2.2.3-0004-Made-ar-command-configurable.patch
new file mode 100644
index 000000000000..9c67313523aa
--- /dev/null
+++ b/dev-libs/tvision/files/tvision-2.2.3-0004-Made-ar-command-configurable.patch
@@ -0,0 +1,23 @@
+From: "Salvador E. Tropea" <salvador@inti.gob.ar>
+Date: Thu, 17 Jun 2021 13:36:09 -0300
+Subject: [PATCH 4/4] Made ar command configurable.
+
+---
+ intl/dummy/Makefile | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/intl/dummy/Makefile b/intl/dummy/Makefile
+index c32b0a8b..e24c1976 100644
+--- a/intl/dummy/Makefile
++++ b/intl/dummy/Makefile
+@@ -1,5 +1,6 @@
+ RHIDE_GCC=gcc
++RHIDE_AR=ar
+ CC=$(RHIDE_GCC)
+
+ libtvfintl.a: intldummy.o
+- ar -rv libtvfintl.a intldummy.o
++ $(RHIDE_AR) -rv libtvfintl.a intldummy.o
+--
+2.32.0
+
diff --git a/dev-libs/tvision/tvision-2.2.3.ebuild b/dev-libs/tvision/tvision-2.2.3.ebuild
index 28c667ecd8dd..9f8e1f689593 100644
--- a/dev-libs/tvision/tvision-2.2.3.ebuild
+++ b/dev-libs/tvision/tvision-2.2.3.ebuild
@@ -16,7 +16,7 @@ S="${WORKDIR}/${PN}"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="examples nls"
+IUSE="examples gpm nls"
DOCS=( readme.txt THANKS TODO )
HTML_DOCS=( www-site/. )
@@ -25,7 +25,6 @@ RDEPEND="
dev-libs/libbsd
media-libs/allegro:0[X]
sys-apps/util-linux
- sys-libs/gpm
sys-libs/ncurses:0=
x11-libs/libICE
x11-libs/libSM
@@ -36,6 +35,7 @@ RDEPEND="
x11-libs/libXmu
x11-libs/libXt
x11-libs/libxcb:=
+ gpm? ( sys-libs/gpm )
"
DEPEND="${RDEPEND}"
BDEPEND="sys-devel/gettext"
@@ -43,7 +43,10 @@ BDEPEND="sys-devel/gettext"
PATCHES=(
"${FILESDIR}"/${PN}-2.2.1.4-flags.patch
"${FILESDIR}"/${PN}-2.2.1.4-ldconfig.patch
- "${FILESDIR}"/${P}-0001-use-proper-AR.patch
+ "${FILESDIR}"/${P}-0001-Added-ar-command-now-can-be-configured-from-the-envi.patch
+ "${FILESDIR}"/${P}-0002-Added-configuration-option-to-exclude-libgpm.patch
+ "${FILESDIR}"/${P}-0003-Adjusted-c-years.patch
+ "${FILESDIR}"/${P}-0004-Made-ar-command-configurable.patch
)
src_configure() {
@@ -58,6 +61,7 @@ src_configure() {
--x-include="${EPREFIX}/usr/include/X11"
)
+ use gpm || myconf+=( --without-gpm )
use nls || myconf+=( --no-intl )
# Note: Do not use econf here, this isn't an autoconf configure script,