summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2021-03-25 20:14:43 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2021-03-25 20:31:43 +0000
commitc19eb8372a5bbf7cd5c191431618d116ef77d02e (patch)
treea1d0d8af8416795855d2a95026ef006fdbbba121 /dev-libs
parentdev-util/diffoscope: bump up to 170 (diff)
downloadgentoo-c19eb8372a5bbf7cd5c191431618d116ef77d02e.tar.gz
gentoo-c19eb8372a5bbf7cd5c191431618d116ef77d02e.tar.bz2
gentoo-c19eb8372a5bbf7cd5c191431618d116ef77d02e.zip
dev-libs/distorm64: bump up to 3.5.2
Package-Manager: Portage-3.0.17, Repoman-3.0.2 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/distorm64/Manifest1
-rw-r--r--dev-libs/distorm64/distorm64-3.5.2.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-libs/distorm64/Manifest b/dev-libs/distorm64/Manifest
index f9f235de0e51..b1be86c66b29 100644
--- a/dev-libs/distorm64/Manifest
+++ b/dev-libs/distorm64/Manifest
@@ -1 +1,2 @@
DIST distorm3-3.5.1.tar.gz 137638 BLAKE2B cecd29dd30a78514e8f8275fef6d0d8338f8d3f5c22b9b48abf2a156b9dc14626455db92172a9bcf6ce36fab8975149395437697a464ce8dd7fb73e9acfcad9d SHA512 0f4cc669c0c562f8458f29d7d6c5d6c308e4681c1c1737d9d81dd2d02e11e5af236b7084d1b24980d1bd0fac514a043bb83d3b6c499b731d43cb4b7458172c48
+DIST distorm3-3.5.2.tar.gz 138371 BLAKE2B 76cc9c987d53a5c7336632ee96878df62865a862bba9b3d07fa95cd585aff428a0187033b78e0731f14a24cc37d7d19f290b2ca06a5a3dd6ee8116a0e68678c8 SHA512 bc08a12f87e6bf22ff9bbba8a34b88b0988b80ddec405c669ba5cd863545128f8b3df4b122a69f4849af3d08818c836b368332e6546871bdfee99e611b3f8d19
diff --git a/dev-libs/distorm64/distorm64-3.5.2.ebuild b/dev-libs/distorm64/distorm64-3.5.2.ebuild
new file mode 100644
index 000000000000..e2793ecdb564
--- /dev/null
+++ b/dev-libs/distorm64/distorm64-3.5.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+
+inherit distutils-r1
+
+DESCRIPTION="The ultimate disassembler library (X86-32, X86-64)"
+HOMEPAGE="http://www.ragestorm.net/distorm/"
+
+MY_PN=distorm3
+MY_P=${MY_PN}-${PV}
+
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+DEPEND=""
+RDEPEND=""
+
+LICENSE="BSD-4"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+python_install() {
+ distutils-r1_python_install
+
+ # don't know why it does not happen by default
+ python_optimize
+}