summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-08-31 22:08:36 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-08-31 22:46:10 +0200
commitfa23ba7eaf8200d34fc7c0551f1cde1ee221e966 (patch)
tree64828b1514105400658c48edb02a56a6180d2781 /dev-libs
parentmedia-libs/mlt: 6.16.0-r2 stable for ruby25 compat (diff)
downloadgentoo-fa23ba7eaf8200d34fc7c0551f1cde1ee221e966.tar.gz
gentoo-fa23ba7eaf8200d34fc7c0551f1cde1ee221e966.tar.bz2
gentoo-fa23ba7eaf8200d34fc7c0551f1cde1ee221e966.zip
dev-libs/libwacom: 1.0 version bump
Package-Manager: Portage-2.3.74, Repoman-2.3.17 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libwacom/Manifest1
-rw-r--r--dev-libs/libwacom/libwacom-1.0.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-libs/libwacom/Manifest b/dev-libs/libwacom/Manifest
index e684231e15ef..b77c31a128d5 100644
--- a/dev-libs/libwacom/Manifest
+++ b/dev-libs/libwacom/Manifest
@@ -1,2 +1,3 @@
DIST libwacom-0.30.tar.gz 119261 BLAKE2B 4f76fcbed42c5453701e3b5dda880a26f9956a803827584aeaf080196b26bedb65f6bdccb7ffe18e7f93861dfee8a633894869b1ea4f6b95e72d64273087b60c SHA512 952ead4b39461d64d9592d0e05824669d0a8bc721aced46f5a99832da0fc63a4023f9803d416ceaf71dc7182660d05d45b799424bca7f54128fa7c44447b688b
DIST libwacom-0.33.tar.bz2 503217 BLAKE2B 034b06495209cc88e9a3131a8a23b35fdadf8bc038ff9db62d4dc05b31657d1cfbe4856cf7b1a6112c97d47bb532b664e4e59c3b00a2aebf14dfacbcac141063 SHA512 de4d9cf3b5f4d87a159ba8ee617bafce9d13b67dc23d9dc67efd57317b0df2079dd0de328bc800de47f14ee49ea82bb842e34297cef23ba336c1ddca3afa826d
+DIST libwacom-1.0.tar.bz2 502457 BLAKE2B c7de15e8e403a4778662c711a4318ffd46c65fcb895e50181b14f6f9c4169493fcd14a78bae62cfad8af0e4d762b5babb06df21ff257994b1890d5ec9078e6ef SHA512 43a8098ed06c86edc647d6a6b0ee0b465bcb6089df77fd361909271aaf5f18ae2fecfa34062fd4a9fdee6983ff1303b99636485ebde6a75a669307bd19c2b313
diff --git a/dev-libs/libwacom/libwacom-1.0.ebuild b/dev-libs/libwacom/libwacom-1.0.ebuild
new file mode 100644
index 000000000000..db48fc2994dc
--- /dev/null
+++ b/dev-libs/libwacom/libwacom-1.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools udev
+
+DESCRIPTION="Library for identifying Wacom tablets and their model-specific features"
+HOMEPAGE="https://github.com/linuxwacom/libwacom"
+SRC_URI="https://github.com/linuxwacom/${PN}/releases/download/${P}/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc static-libs"
+
+BDEPEND="
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+"
+RDEPEND="
+ dev-libs/glib:2
+ virtual/libgudev:=
+"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+ if ! use doc; then
+ sed -e 's:^\(SUBDIRS = .* \)doc:\1:' -i Makefile.am || die
+ fi
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --with-udev-dir=$(get_udevdir)
+ $(use_enable static-libs static)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ use doc && local HTML_DOCS=( doc/html/. )
+ default
+ find "${D}" -name '*.la' -type f -delete || die
+}