summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2017-12-19 19:13:32 +0700
committerAndrey Grozin <grozin@gentoo.org>2017-12-19 19:13:32 +0700
commitd2f64170d3270b0dfff8ff3d5f9dae417510ba40 (patch)
tree2620428b29d160287e5197f96e3d637e6558fc39 /dev-lisp/cmucl
parentmedia-libs/speexdsp: amd64 stable (diff)
downloadgentoo-d2f64170d3270b0dfff8ff3d5f9dae417510ba40.tar.gz
gentoo-d2f64170d3270b0dfff8ff3d5f9dae417510ba40.tar.bz2
gentoo-d2f64170d3270b0dfff8ff3d5f9dae417510ba40.zip
dev-lisp/cmucl: bump to 21c, USE flag doc added
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'dev-lisp/cmucl')
-rw-r--r--dev-lisp/cmucl/Manifest2
-rw-r--r--dev-lisp/cmucl/cmucl-21c.ebuild109
2 files changed, 111 insertions, 0 deletions
diff --git a/dev-lisp/cmucl/Manifest b/dev-lisp/cmucl/Manifest
index c1c2d97c99e7..87e8d72e536e 100644
--- a/dev-lisp/cmucl/Manifest
+++ b/dev-lisp/cmucl/Manifest
@@ -1,4 +1,6 @@
DIST cmucl-20e-x86-linux.tar.bz2 18861880 BLAKE2B ed7b2dec86305ab2ad78ca5a84f0380044211e7cacf67f297c17c26d0a0a344d53c0404d82c86415dd923b92920cbd873436d925417f3590ac3a4c88d919b231 SHA512 1eee852b2a11733d0fac2c046137ccd099370bf208be71becc03710e832510b288768f557e326b1ce95cba16490413142e607fd71346e20e5f8592b51d86b0fe
DIST cmucl-21a-x86-linux.tar.bz2 10870693 BLAKE2B a4fb258cef17eaf281ffd1fdff7f5e953b650c45822ed94722e4df5065b41a53cd0a9f481fba9ac38824dab4952bbb6d45e432b37fe73142c2ead1c8a4b17141 SHA512 7f7d327e47b01dcee1cbb05aae826ef7c64d4d192d7d32d1aba51c8839a06d65942fff5d4c7dbccc955e1e233d2065d83d078266327caee07201e9dce59c39ee
+DIST cmucl-21c-x86-linux.tar.bz2 11127872 BLAKE2B b9089a40b4a0738f9faccdfddb7b33256a561a07cedc3ef9b3ec7afddbbb9de493c2ffb9af4a8d6b6ce70ef857576870901a6b7a607f52bdaf8a0f53ddd2d07e SHA512 9097220aef612aa3d8367a86a86dc62d86d918190d2688f6e90d415c9f9d881f97f0829e9d310f700b014821d30bf5a15f7a05cdb9201c9deab10a7231e0bcb6
DIST cmucl-src-20e.tar.bz2 6147575 BLAKE2B a9f31b9a34c513dc88d935e18b9a07854d024d236f1f0294f888c84fd4b781afcd99a3cceac148edd1d1fe6c2dc00c5c8de4069d84b227872e376422275b6984 SHA512 d04f6ac7335572198d37d5df00934edfc82495294446cc5420dada4f2df44009f0983b438d6f10ce5bb02e46fd89df985da5eee3e91a6a75d98e9f86240c0dcc
DIST cmucl-src-21a.tar.bz2 8195492 BLAKE2B 5ca24e1ee258b52b805ab933e80915da6af022d47f8171327e318edb28d9f87c8901fe10ea48d54b6737a808cb03b08f8d3db41688b347971147b991570752cc SHA512 74b077732030dbc3681aadcf9c802fd5b399362c9653b972063e49eb0a2ad528d02d6dde74107210c94c94dc7e9664472c2d072a6ae6f75e7e8c4cf847987e3b
+DIST cmucl-src-21c.tar.bz2 6947775 BLAKE2B 828075c71ddf459d09076199af4a02f2294063bd9ef0beb6d4bcbb473dd0ff8cfdff7faa9416f640e125603301fa37c73a280db597bf4301c22fbe88c4cc2dbb SHA512 98ea0516b71af7c6f92b5f67f6c1545949fcd1dc95e1238a989c1c2858a75e2751e5eb765b29812ad5cc5de015333787dac2a63a9ddea9bb83cfd72fef6794f4
diff --git a/dev-lisp/cmucl/cmucl-21c.ebuild b/dev-lisp/cmucl/cmucl-21c.ebuild
new file mode 100644
index 000000000000..d626b8677e9b
--- /dev/null
+++ b/dev-lisp/cmucl/cmucl-21c.ebuild
@@ -0,0 +1,109 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils toolchain-funcs multilib
+
+MY_PV=${PV:0:3}
+
+DESCRIPTION="CMU Common Lisp is an implementation of ANSI Common Lisp"
+HOMEPAGE="http://www.cons.org/cmucl/"
+SRC_URI="http://common-lisp.net/project/cmucl/downloads/release/${MY_PV}/cmucl-src-${MY_PV}.tar.bz2
+ http://common-lisp.net/project/cmucl/downloads/release/${MY_PV}/cmucl-${MY_PV}-x86-linux.tar.bz2"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="X doc source"
+
+CDEPEND=">=dev-lisp/asdf-2.33-r3:=
+ x11-libs/motif:0"
+DEPEND="${CDEPEND}
+ sys-devel/bc
+ doc? ( virtual/latex-base )"
+RDEPEND="${CDEPEND}"
+
+S="${WORKDIR}"
+
+TARGET=linux-4
+
+src_prepare() {
+ eapply "${FILESDIR}"/${MY_PV}-execstack-fixes.patch
+ eapply "${FILESDIR}"/${MY_PV}-customize-lisp-implementation-version.patch
+ eapply "${FILESDIR}"/${MY_PV}-build.patch
+ eapply_user
+ cp "${FILESDIR}"/os-common.h src/lisp/ || die
+ cp /usr/share/common-lisp/source/asdf/build/asdf.lisp src/contrib/asdf/ || die
+}
+
+src_compile() {
+ local cmuopts buildimage
+
+ if use X; then
+ cmuopts=""
+ else
+ cmuopts="-u"
+ fi
+
+ buildimage="bin/lisp -batch"
+
+ env CC="$(tc-getCC)" bin/build.sh -v "-gentoo-${PR}" -C "" -o "${buildimage}" ${cmuopts} || die "Cannot build the compiler"
+
+ # Compile up the asdf and defsystem modules
+ ${TARGET}/lisp/lisp -noinit -nositeinit -batch << EOF || die
+(in-package :cl-user)
+(setf (ext:search-list "target:")
+ '("$TARGET/" "src/"))
+(setf (ext:search-list "modules:")
+ '("target:contrib/"))
+
+(compile-file "modules:asdf/asdf")
+(compile-file "modules:defsystem/defsystem")
+EOF
+
+ # documentation
+ if use doc; then
+ pushd src/docs/cmu-user > /dev/null || die "directory src/docs/cmu-user does not exist"
+ emake
+ cd ../internals || die "directory src/docs/internals does not exist"
+ emake
+ popd > /dev/null
+ fi
+}
+
+src_install() {
+ bin/make-dist.sh -S -g -G root -O root -M share/man/man1 -V ${MY_PV} -A x86 -o linux ${TARGET} \
+ || die "Cannot build installation archive"
+ # Necessary otherwise tar will fail
+ dodir /usr
+ pushd "${D}"/usr > /dev/null
+ tar xzpf "${WORKDIR}"/cmucl-${MY_PV}-x86-linux.tar.gz \
+ || die "Cannot install main system"
+ if use X ; then
+ tar xzpf "${WORKDIR}"/cmucl-${MY_PV}-x86-linux.extra.tar.gz \
+ || die "Cannot install extra files"
+ fi
+ if use source; then
+ # Necessary otherwise tar will fail
+ dodir /usr/share/common-lisp/source/${PN}
+ cd "${D}"/usr/share/common-lisp/source/${PN}
+ tar --strip-components 1 -xzpf "${WORKDIR}"/cmucl-src-${MY_PV}.tar.gz \
+ || die "Cannot install sources"
+ fi
+ popd > /dev/null
+
+ # Install site config file
+ sed "s,@PF@,${PF},g ; s,@VERSION@,$(date +%F),g" \
+ < "${FILESDIR}"/site-init.lisp.in \
+ > "${D}"/usr/$(get_libdir)/cmucl/site-init.lisp \
+ || die "Cannot fix site-init.lisp"
+ insinto /etc/common-lisp
+ doins "${FILESDIR}"/cmuclrc || die "Failed to install cmuclrc"
+
+ # documentation
+ dodoc doc/cmucl/README
+ if use doc; then
+ insinto /usr/share/doc/${PF}
+ doins src/docs/cmu-user/cmu-user.pdf src/docs/internals/design.pdf
+ fi
+}