summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHarald Judt <h.judt@gmx.at>2020-06-05 00:39:28 +0200
committerJoonas Niilola <juippis@gentoo.org>2020-06-24 19:29:37 +0300
commitfa0cbe2e00fc7c43ff5fceee213b89254f54cdc1 (patch)
tree8b86031ad8104be8a1f70bb7da297423d08a247a /dev-lisp
parentsys-apps/fwts: cosmetic updates for 20.05.00 (diff)
downloadgentoo-fa0cbe2e00fc7c43ff5fceee213b89254f54cdc1.tar.gz
gentoo-fa0cbe2e00fc7c43ff5fceee213b89254f54cdc1.tar.bz2
gentoo-fa0cbe2e00fc7c43ff5fceee213b89254f54cdc1.zip
dev-lisp/c2ffi: Bump version to c2ffi-10.0.0
Update to c2ffi-10, using clang-10. This time, it was only necessary to add a target_link_directories directive to CMakeLists.txt. Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Harald Judt <h.judt@gmx.at> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-lisp')
-rw-r--r--dev-lisp/c2ffi/Manifest1
-rw-r--r--dev-lisp/c2ffi/c2ffi-10.0.0.20200527.ebuild26
-rw-r--r--dev-lisp/c2ffi/c2ffi-10.0.0.9999.ebuild22
-rw-r--r--dev-lisp/c2ffi/files/c2ffi-10.0.0.20200527-add-target-link-directories.patch11
4 files changed, 60 insertions, 0 deletions
diff --git a/dev-lisp/c2ffi/Manifest b/dev-lisp/c2ffi/Manifest
index 03b798a30b3a..a4c1cd2460cd 100644
--- a/dev-lisp/c2ffi/Manifest
+++ b/dev-lisp/c2ffi/Manifest
@@ -1 +1,2 @@
+DIST c2ffi-10.0.0.20200527.tar.gz 37554 BLAKE2B b1ebef370083d08513d0f02f8662ba1b090cba991864530c2304ac45e5c74d092f47e9d75a0646ae2f045d346585f371243d8a82bc37fe35f36dee1a75c0812b SHA512 452f2e8d3c81207e74334bc48dcea9bdf2770b4c77884c96abffc69ede20cc770183f363655ae853cddaee95d0512571426c6737d5db0324f7ceebbdf554cdf3
DIST c2ffi-9.0.0.20191017.tar.gz 35139 BLAKE2B a080f2cf7743aab630365fd305c106ada0318afb24093508c7667d8d702ec8dfd95a0ea9f54233a3a4b4c9b411e2f4aba5dacf7b2f35f1545b7ca63e765a7e55 SHA512 7a4743d89f431fd9ca42808358bdde03bbd85fc56f3350fddc94532c524ce373989671e706fadeb03eb240a81fb3f418176169acbf3ccd0f0f0c595d0f697832
diff --git a/dev-lisp/c2ffi/c2ffi-10.0.0.20200527.ebuild b/dev-lisp/c2ffi/c2ffi-10.0.0.20200527.ebuild
new file mode 100644
index 000000000000..56aaeae61858
--- /dev/null
+++ b/dev-lisp/c2ffi/c2ffi-10.0.0.20200527.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake llvm
+
+MY_COMMIT="a2d1f667b707fb413fc8ab2413446f15cb23de51"
+
+DESCRIPTION="Clang-based FFI wrapper generator for Common Lisp"
+HOMEPAGE="https://github.com/rpav/c2ffi"
+SRC_URI="https://github.com/rpav/c2ffi/archive/${MY_COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="sys-devel/clang:10=
+ sys-devel/llvm:10=
+"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/c2ffi-${MY_COMMIT}"
+
+PATCHES=( "${FILESDIR}"/${PN}-10.0.0.20200527-add-target-link-directories.patch )
diff --git a/dev-lisp/c2ffi/c2ffi-10.0.0.9999.ebuild b/dev-lisp/c2ffi/c2ffi-10.0.0.9999.ebuild
new file mode 100644
index 000000000000..dac9e0eb3d31
--- /dev/null
+++ b/dev-lisp/c2ffi/c2ffi-10.0.0.9999.ebuild
@@ -0,0 +1,22 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake git-r3 llvm
+
+DESCRIPTION="Clang-based FFI wrapper generator for Common Lisp"
+HOMEPAGE="https://github.com/rpav/c2ffi"
+EGIT_REPO_URI="https://github.com/rpav/c2ffi.git"
+EGIT_BRANCH="llvm-10.0.0"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE=""
+
+DEPEND="sys-devel/clang:10=
+ sys-devel/llvm:10=
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}"/${PN}-10.0.0.20200527-add-target-link-directories.patch )
diff --git a/dev-lisp/c2ffi/files/c2ffi-10.0.0.20200527-add-target-link-directories.patch b/dev-lisp/c2ffi/files/c2ffi-10.0.0.20200527-add-target-link-directories.patch
new file mode 100644
index 000000000000..2dc4a82413b2
--- /dev/null
+++ b/dev-lisp/c2ffi/files/c2ffi-10.0.0.20200527-add-target-link-directories.patch
@@ -0,0 +1,11 @@
+diff -Naur a/CMakeLists.txt b/CMakeLists.txt
+--- a/CMakeLists.txt 2020-06-05 00:21:43.509980270 +0200
++++ b/CMakeLists.txt 2020-06-05 00:22:08.679979968 +0200
+@@ -36,6 +36,7 @@
+ ${LLVM_INCLUDE_DIRS}
+ ${SOURCE_ROOT}/src/include
+ )
++target_link_directories(c2ffi PUBLIC ${LLVM_LIBRARY_DIRS})
+ target_link_libraries(c2ffi PUBLIC clang-cpp LLVM)
+
+ set(APP_BIN_DIR "${CMAKE_BINARY_DIR}/bin")