summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorcrito <crito@fnordpipe.org>2018-09-26 21:56:38 +0200
committerMichał Górny <mgorny@gentoo.org>2018-09-28 12:07:53 +0200
commitdddbeb5e4139102deda075fcef14170ec100ae27 (patch)
tree2146cd089c1f49e8377ac3b17bf1f0770dccb942 /dev-lua/luaossl
parentapp-benchmarks/stress-ng: drop old version (diff)
downloadgentoo-dddbeb5e4139102deda075fcef14170ec100ae27.tar.gz
gentoo-dddbeb5e4139102deda075fcef14170ec100ae27.tar.bz2
gentoo-dddbeb5e4139102deda075fcef14170ec100ae27.zip
dev-lua/luaossl: bump version to 20180708
Signed-off-by: Matthias Hauber <crito@fnordpipe.org> Signed-off-by: Michał Górny <mgorny@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/9977
Diffstat (limited to 'dev-lua/luaossl')
-rw-r--r--dev-lua/luaossl/Manifest1
-rw-r--r--dev-lua/luaossl/luaossl-20180708.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-lua/luaossl/Manifest b/dev-lua/luaossl/Manifest
index 50c057f3cd57..779234367679 100644
--- a/dev-lua/luaossl/Manifest
+++ b/dev-lua/luaossl/Manifest
@@ -1 +1,2 @@
DIST luaossl-20150727.tar.gz 355486 BLAKE2B 81907c3a3f565432eb2d2b17db48f381496837924ce999a58a4528a46b1b43fdd7b14041bab2a4536c89a37c6f31926f353d1bb1997e9ffd57ab6e2cfb83b6ef SHA512 de565ff7b9ac07493e771045b05902dd64e8b6c458180dd03d08cf900067d1b9cb88385c69dc29fb45774e4ec36b563cab705b34d37cec2f5cc792cf4f7b5049
+DIST luaossl-rel-20180708.tar.gz 455381 BLAKE2B d57e27638e6aee44a94f85094bab9161f0b87bdb379863fdef4517a1cb3415f4ef7e62967ee1e3fa2dde4d5629a24d732dc8ea0fd2ea54ccd84f69c4b18e2c57 SHA512 b2a73a7e7ace9a01c8c5a26603107f7741de88de32c393ed9134b70d55278c81d48e357955e671654825de282449b9570ecdc6a4fbcf4890439c0200ba471338
diff --git a/dev-lua/luaossl/luaossl-20180708.ebuild b/dev-lua/luaossl/luaossl-20180708.ebuild
new file mode 100644
index 000000000000..fd7565276080
--- /dev/null
+++ b/dev-lua/luaossl/luaossl-20180708.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+MY_P=${PN}-rel-${PV}
+DESCRIPTION="Most comprehensive OpenSSL module in the Lua universe."
+HOMEPAGE="https://github.com/wahern/luaossl"
+SRC_URI="https://github.com/wahern/luaossl/archive/rel-${PV}.tar.gz -> ${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="luajit"
+
+RDEPEND="
+ luajit? ( dev-lang/luajit:2 )
+ !luajit? ( >=dev-lang/lua-5.1:0 )
+ dev-libs/openssl:0[-bindist]
+ !dev-lua/lua-openssl"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ default
+
+ LUA_VERSION="$($(tc-getPKG_CONFIG) --variable=$(usex luajit abiver V) $(usex luajit luajit lua))"
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" prefix="${EPREFIX}/usr" openssl${LUA_VERSION}
+}
+
+src_install() {
+ emake DESTDIR="${D}" prefix="${EPREFIX}/usr" install${LUA_VERSION}
+}