summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-12-11 13:32:00 +0100
committerDavid Seifert <soap@gentoo.org>2019-12-11 13:32:00 +0100
commit398a42634f34afa1979d88ae1d8b38194e911c2d (patch)
treed6a45bdf7b35b71c192602a46e8d98d12a88cb02 /dev-lua/luarocks/luarocks-2.2.0.ebuild
parentdev-ros/geometric_shapes: Remove old (diff)
downloadgentoo-398a42634f34afa1979d88ae1d8b38194e911c2d.tar.gz
gentoo-398a42634f34afa1979d88ae1d8b38194e911c2d.tar.bz2
gentoo-398a42634f34afa1979d88ae1d8b38194e911c2d.zip
*/*: [QA] Remove redundant `|| die` guards
* Since all ebuilds in the tree are EAPI>=4, `|| die` on builtin commands is redundant and dead code. Closes: https://github.com/gentoo/gentoo/pull/13940 Reviewed-by: Ulrich Müller <ulm@gentoo.org> Reviewed-by: Michał Górny <mgorny@gentoo.org> Reviewed-by: Andreas K. Hüttel <dilfridge@gentoo.org> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-lua/luarocks/luarocks-2.2.0.ebuild')
-rw-r--r--dev-lua/luarocks/luarocks-2.2.0.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/dev-lua/luarocks/luarocks-2.2.0.ebuild b/dev-lua/luarocks/luarocks-2.2.0.ebuild
index a64514f182e2..5a450c989c0d 100644
--- a/dev-lua/luarocks/luarocks-2.2.0.ebuild
+++ b/dev-lua/luarocks/luarocks-2.2.0.ebuild
@@ -39,12 +39,12 @@ src_configure() {
src_compile() {
# -j1 b/c make tries to delete files it has yet to create (bug #402005)
- emake DESTDIR="${D}" -j1 || die "make failed"
+ emake DESTDIR="${D}" -j1
}
src_install() {
# -j1 b/c otherwise it fails to find src/bin/luarocks
- emake DESTDIR="${D}" -j1 install || die "einstall"
+ emake DESTDIR="${D}" -j1 install
}
pkg_preinst() {