summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-07-02 16:46:47 +0200
committerConrad Kostecki <conikost@gentoo.org>2022-07-02 16:58:40 +0200
commitdc04d9230ad4fa5acd6b844d14d37ff6840d768f (patch)
tree9ea25cbee34a59129a18bcd927523d1f9d0aa7e8 /dev-lua/luarocks
parentnet-ftp/pure-ftpd: drop 1.0.50-r3 (diff)
downloadgentoo-dc04d9230ad4fa5acd6b844d14d37ff6840d768f.tar.gz
gentoo-dc04d9230ad4fa5acd6b844d14d37ff6840d768f.tar.bz2
gentoo-dc04d9230ad4fa5acd6b844d14d37ff6840d768f.zip
dev-lua/luarocks: add 3.9.1
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-lua/luarocks')
-rw-r--r--dev-lua/luarocks/Manifest1
-rw-r--r--dev-lua/luarocks/luarocks-3.9.1.ebuild86
2 files changed, 87 insertions, 0 deletions
diff --git a/dev-lua/luarocks/Manifest b/dev-lua/luarocks/Manifest
index 2c52ea13e7ff..844a1a721f0c 100644
--- a/dev-lua/luarocks/Manifest
+++ b/dev-lua/luarocks/Manifest
@@ -1 +1,2 @@
DIST luarocks-3.9.0.tar.gz 252777 BLAKE2B fba01692057ea5f4a926db4b31d4a299238079af1dfd15078cbff6d3d17d1b87f9f30db8477b1b706ec4602fe9ef82533ad3cc58f8059fe84490b464da0b3c15 SHA512 ccdee2ff14f52428923d5148f3d86d2ad40f84685988a12419c191c73a4df6cfacb0defbea40556493645619fdbef807e198fbae85be69c4075b5212353c1f2d
+DIST luarocks-3.9.1.tar.gz 253375 BLAKE2B 6d622e87dc385d0851ef6366e0b6832f1a453d2590c090b06ec6ab81b8a15930c1496bf2ac00ed6b15a44dfbc43b1f235092947389714b72f3442f802236fab3 SHA512 2dfc1326118c2868b05a17acc5fe8d2c07503ef2bb3f2560a3d7ce385b85893d593bacfab7086c57923f042d7e7cfd09a0a9795afc473a73edbba0a44d23ed60
diff --git a/dev-lua/luarocks/luarocks-3.9.1.ebuild b/dev-lua/luarocks/luarocks-3.9.1.ebuild
new file mode 100644
index 000000000000..7928ca87e717
--- /dev/null
+++ b/dev-lua/luarocks/luarocks-3.9.1.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+LUA_COMPAT=( lua5-{1..4} luajit )
+
+inherit lua-single
+
+DESCRIPTION="A package manager for the Lua programming language"
+HOMEPAGE="https://luarocks.org"
+SRC_URI="https://luarocks.org/releases/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+REQUIRED_USE="${LUA_REQUIRED_USE}"
+RESTRICT="test"
+
+RDEPEND="${LUA_DEPS}"
+
+DEPEND="
+ net-misc/curl
+ dev-libs/openssl:0
+ ${RDEPEND}
+"
+
+BDEPEND="
+ virtual/pkgconfig
+ test? (
+ $(lua_gen_cond_dep 'dev-lua/busted[${LUA_USEDEP}]')
+ $(lua_gen_cond_dep 'dev-lua/busted-htest[${LUA_USEDEP}]')
+ ${RDEPEND}
+ )
+"
+
+src_prepare() {
+ default
+
+ # If 'dev-lang/lua' is a new, fresh installation, no 'LUA_LIBDIR' exists,
+ # as no compiled modules are installed on a new, fresh installation,
+ # so this check must be disabled, otherwise 'configure' will fail.
+ sed -e '/LUA_LIBDIR is not a valid directory/d' -i configure || die
+}
+
+src_configure() {
+ local myeconfargs=(
+ "--prefix=${EPREFIX}/usr"
+ "--rocks-tree=$(lua_get_lmod_dir)"
+ "--with-lua-include=$(lua_get_include_dir)"
+ "--with-lua-interpreter=${ELUA}"
+ "--with-lua-lib=$(lua_get_cmod_dir)"
+ )
+
+ # Since the configure script is handcrafted,
+ # and yells at unknown options, do not use 'econf'.
+ ./configure "${myeconfargs[@]}" || die
+}
+
+src_test() {
+ busted --lua=${ELUA} || die
+}
+
+src_install() {
+ default
+
+ { find "${D}" -type f -exec sed -i -e "s:${D}::g" {} \;; } || die
+}
+
+pkg_postinst() {
+ local lua_abi_ver
+ if use lua_single_target_luajit; then
+ lua_abi_ver="5.1"
+ else
+ lua_abi_ver=${ELUA#lua}
+ fi
+ elog
+ elog "To manage rocks for a Lua version other than the current ${CATEGORY}/${PN} default (${lua_abi_ver})"
+ elog "you can use the command-line option --lua-version, e.g."
+ elog
+ elog " luarocks --lua-version 5.3 install luasocket"
+ elog
+ elog "(use 5.1 for luajit). Note that the relevant Lua version must already be present in the system."
+ elog
+}