summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-12-30 20:12:17 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-12-31 19:42:20 +0100
commitbe0ab352405aa2d5d968a8c3905557b914df9626 (patch)
tree5b5da6a6ab8feb0c82b1f5c6b02e9fafdee83463 /dev-lua/luv
parentsys-kernel/gentoo-sources: Linux patch 5.4.7 (diff)
downloadgentoo-be0ab352405aa2d5d968a8c3905557b914df9626.tar.gz
gentoo-be0ab352405aa2d5d968a8c3905557b914df9626.tar.bz2
gentoo-be0ab352405aa2d5d968a8c3905557b914df9626.zip
*/*: Switch proxy-maint to cmake.eclass
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-lua/luv')
-rw-r--r--dev-lua/luv/luv-1.32.0.0.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/dev-lua/luv/luv-1.32.0.0.ebuild b/dev-lua/luv/luv-1.32.0.0.ebuild
index 41098ce6bbc4..3d5ee15c180b 100644
--- a/dev-lua/luv/luv-1.32.0.0.ebuild
+++ b/dev-lua/luv/luv-1.32.0.0.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake-utils unpacker
+inherit cmake unpacker
# e.g. MY_PV = a.b.c-d
MY_PV="$(ver_rs 3 -)"
@@ -38,7 +38,7 @@ src_prepare() {
# Fix libdir
# Match '/lib/' and '/lib"' without capturing / or ", replacing with libdir
sed -i -r "s/\/lib(\"|\/)/\/$(get_libdir)\1/g" CMakeLists.txt || die "Failed to sed CMakeLists.txt"
- cmake-utils_src_prepare
+ cmake_src_prepare
}
src_configure() {
@@ -50,7 +50,7 @@ src_configure() {
-DWITH_LUA_ENGINE=$(usex luajit LuaJIT Lua)
-DWITH_SHARED_LIBUV=ON
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_test() {