summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-10-02 16:42:57 +0200
committerConrad Kostecki <conikost@gentoo.org>2022-10-02 16:42:57 +0200
commita395db6f68f198abd890253d30244c826d0d3b14 (patch)
tree4c5a5af8bc35815d065fc9e5eb06bfceae42d04b /dev-lua
parentnet-firewall/iptables: remove unused file (diff)
downloadgentoo-a395db6f68f198abd890253d30244c826d0d3b14.tar.gz
gentoo-a395db6f68f198abd890253d30244c826d0d3b14.tar.bz2
gentoo-a395db6f68f198abd890253d30244c826d0d3b14.zip
dev-lua/luaexpat: drop 1.4.1
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-lua')
-rw-r--r--dev-lua/luaexpat/Manifest1
-rw-r--r--dev-lua/luaexpat/luaexpat-1.4.1.ebuild73
2 files changed, 0 insertions, 74 deletions
diff --git a/dev-lua/luaexpat/Manifest b/dev-lua/luaexpat/Manifest
index 6a6c432fc9cd..fc186e79bd24 100644
--- a/dev-lua/luaexpat/Manifest
+++ b/dev-lua/luaexpat/Manifest
@@ -1,2 +1 @@
-DIST luaexpat-1.4.1.tar.gz 52159 BLAKE2B dd870d2d2db8bc1e399a306eff91138752f346f50ec1283a611c3ef42591e5176beab59aa96b87c772ba0320d98fc8a5907048e539cde6c14757e9a026aacc81 SHA512 fbc03287a237c13f395574ddf08a931ded0f457728b01bdc0a0533d212a0c908d74230be3c9e7f85a54ac244043cd853be3bf13d284185ad3e3ce6818d157635
DIST luaexpat-1.5.0.tar.gz 53520 BLAKE2B 1793f842771e730022abf512731eece538b6edefd10786295842f467af3cbfbdc94e65ea035b1ce9bc849a1ee4f0ca445bd0b66816a6d18bb786d19ced6b3586 SHA512 0ac151148101d62f1358f5f310be57de5379891ceda76f0eb821a8b56d0d9c781feaf1db601d982339cd4837f9504b1f9b8b14ebf3a7245925473f6824bbc8b3
diff --git a/dev-lua/luaexpat/luaexpat-1.4.1.ebuild b/dev-lua/luaexpat/luaexpat-1.4.1.ebuild
deleted file mode 100644
index 653582b9bb6d..000000000000
--- a/dev-lua/luaexpat/luaexpat-1.4.1.ebuild
+++ /dev/null
@@ -1,73 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-LUA_COMPAT=( lua5-{1..4} luajit )
-
-inherit lua toolchain-funcs
-
-DESCRIPTION="A SAX XML parser based on the Expat library"
-HOMEPAGE="https://github.com/lunarmodules/luaexpat"
-SRC_URI="https://github.com/lunarmodules/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 sparc x86"
-REQUIRED_USE="${LUA_REQUIRED_USE}"
-
-RDEPEND="
- dev-libs/expat
- ${LUA_DEPS}
-"
-DEPEND="${RDEPEND}"
-BDEPEND="virtual/pkgconfig"
-
-HTML_DOCS=( "docs/." )
-
-src_prepare() {
- default
-
- # Respect users CFLAGS
- sed -e 's/-O2//g' -i Makefile || die
-
- lua_copy_sources
-}
-
-lua_src_compile() {
- pushd "${BUILD_DIR}" || die
-
- local myemakeargs=(
- "CC=$(tc-getCC)"
- "LUA_INC=$(lua_get_CFLAGS)"
- )
-
- emake "${myemakeargs[@]}"
-
- popd
-}
-
-src_compile() {
- lua_foreach_impl lua_src_compile
-}
-
-lua_src_install() {
- pushd "${BUILD_DIR}" || die
-
- local myemakeargs=(
- "DESTDIR=${ED}"
- "LUA_CDIR=$(lua_get_cmod_dir)"
- "LUA_INC=$(lua_get_include_dir)"
- "LUA_LDIR=$(lua_get_lmod_dir)"
- )
-
- emake "${myemakeargs[@]}" install
-
- popd
-}
-
-src_install() {
- lua_foreach_impl lua_src_install
-
- einstalldocs
-}