summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ml/camomile
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ml/camomile')
-rw-r--r--dev-ml/camomile/Manifest2
-rw-r--r--dev-ml/camomile/camomile-0.8.4.ebuild38
-rw-r--r--dev-ml/camomile/camomile-0.8.5.ebuild38
-rw-r--r--dev-ml/camomile/metadata.xml8
4 files changed, 86 insertions, 0 deletions
diff --git a/dev-ml/camomile/Manifest b/dev-ml/camomile/Manifest
new file mode 100644
index 000000000000..10f7f1ebec18
--- /dev/null
+++ b/dev-ml/camomile/Manifest
@@ -0,0 +1,2 @@
+DIST camomile-0.8.4.tar.bz2 2649800 SHA256 ef521f96fe984e6b0118041ed68a7a165beda54d8541c248ed402b7ef693de50 SHA512 f8d9b5288636eb3123b539a2c09bcd2f674acf10b16b83abea5d9e7f7f34a7359e36572f4ab3bc1ebeb42562e30f4fa9a1986e50060175186c0c2739e64130d1 WHIRLPOOL d2eb6b3c413424cb0c7e53cffeb01431f805f9124db6822e3b0fd8101cabee0ecec4caf2436d5151cd658bf53fe971842a3f5e3e901cc74b9ae35353e4be96a9
+DIST camomile-0.8.5.tar.bz2 2607084 SHA256 85806b051cf059b93676a10a3f66051f7f322cad6e3248172c3e5275f79d7100 SHA512 ef4da32f955e69e0b2958b4b2bf12ae94e210d8aa7cee5a9030607b79ac43a884758549f3164c223fb07d987a4a50b15f0bc5083ff67120270409f7fb9928014 WHIRLPOOL 72bed65fb030548430a352b76a63b1171b964ad78676a6ce0bb2a8d3555ea097e0002321a3c2d13ec933ca29755f4780c77f28e485053d9ddbd6908e8c4cf6b5
diff --git a/dev-ml/camomile/camomile-0.8.4.ebuild b/dev-ml/camomile/camomile-0.8.4.ebuild
new file mode 100644
index 000000000000..6ca2a14610a7
--- /dev/null
+++ b/dev-ml/camomile/camomile-0.8.4.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit findlib eutils
+
+DESCRIPTION="Camomile is a comprehensive Unicode library for ocaml"
+HOMEPAGE="http://github.com/yoriyuki/Camomile/wiki"
+SRC_URI="http://github.com/downloads/yoriyuki/Camomile/${P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ppc x86"
+IUSE="debug +ocamlopt"
+
+RDEPEND="
+ >=dev-lang/ocaml-3.10.2:=[ocamlopt?]
+ || ( dev-ml/camlp4:= <dev-lang/ocaml-4.02.0 )
+"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ econf $(use_enable debug)
+}
+
+src_compile() {
+ emake -j1 byte unidata unimaps charmap_data locale_data
+ if use ocamlopt; then
+ emake -j1 opt
+ fi
+}
+
+src_install() {
+ dodir /usr/bin
+ findlib_src_install DATADIR="${D}/usr/share" BINDIR="${D}/usr/bin"
+}
diff --git a/dev-ml/camomile/camomile-0.8.5.ebuild b/dev-ml/camomile/camomile-0.8.5.ebuild
new file mode 100644
index 000000000000..7c160ac3d60c
--- /dev/null
+++ b/dev-ml/camomile/camomile-0.8.5.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit findlib eutils
+
+DESCRIPTION="Camomile is a comprehensive Unicode library for ocaml"
+HOMEPAGE="http://github.com/yoriyuki/Camomile/wiki"
+SRC_URI="https://github.com/yoriyuki/Camomile/releases/download/rel-${PV}/${P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug +ocamlopt"
+
+RDEPEND="
+ >=dev-lang/ocaml-3.10.2:=[ocamlopt?]
+ || ( dev-ml/camlp4:= <dev-lang/ocaml-4.02.0 )
+"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ econf $(use_enable debug)
+}
+
+src_compile() {
+ emake -j1 byte unidata unimaps charmap_data locale_data
+ if use ocamlopt; then
+ emake -j1 opt
+ fi
+}
+
+src_install() {
+ dodir /usr/bin
+ findlib_src_install DATADIR="${D}/usr/share" BINDIR="${D}/usr/bin"
+}
diff --git a/dev-ml/camomile/metadata.xml b/dev-ml/camomile/metadata.xml
new file mode 100644
index 000000000000..c2fd0b301e0c
--- /dev/null
+++ b/dev-ml/camomile/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ml</herd>
+ <upstream>
+ <remote-id type="github">yoriyuki/Camomile</remote-id>
+ </upstream>
+</pkgmetadata>