summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-11-28 21:26:10 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-11-28 21:27:33 +0100
commit6eabcc4855612fae35b56578a81f88c2b355a86a (patch)
treeaadc4a863b2af13c52c7d5e9ffe61259f084e08b /dev-ml/jsonm/jsonm-1.0.0.ebuild
parentdev-ml/uutf: bump to 1.0.0 (diff)
downloadgentoo-6eabcc4855612fae35b56578a81f88c2b355a86a.tar.gz
gentoo-6eabcc4855612fae35b56578a81f88c2b355a86a.tar.bz2
gentoo-6eabcc4855612fae35b56578a81f88c2b355a86a.zip
dev-ml/jsonm: bump to 1.0.0
Package-Manager: portage-2.3.2
Diffstat (limited to 'dev-ml/jsonm/jsonm-1.0.0.ebuild')
-rw-r--r--dev-ml/jsonm/jsonm-1.0.0.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-ml/jsonm/jsonm-1.0.0.ebuild b/dev-ml/jsonm/jsonm-1.0.0.ebuild
new file mode 100644
index 000000000000..71e10a865591
--- /dev/null
+++ b/dev-ml/jsonm/jsonm-1.0.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+DESCRIPTION="Non-blocking streaming JSON codec for OCaml"
+HOMEPAGE="http://erratique.ch/software/jsonm"
+SRC_URI="http://erratique.ch/software/jsonm/releases/${P}.tbz"
+
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="dev-ml/uutf:=
+ dev-lang/ocaml:=
+ dev-ml/uchar:="
+DEPEND="${RDEPEND}
+ dev-ml/topkg
+ dev-ml/opam
+ dev-ml/ocamlbuild
+ dev-ml/findlib"
+
+DOCS=( CHANGES README )
+
+src_compile() {
+ ocaml pkg/pkg.ml build || die
+}
+
+src_install() {
+ opam-installer -i \
+ --prefix="${ED}/usr" \
+ --libdir="${D}/$(ocamlc -where)" \
+ --docdir="${ED}/usr/share/doc/${PF}" \
+ ${PN}.install || die
+ dodoc CHANGES.md TODO.md README.md
+}