summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2022-01-25 19:20:00 +0100
committerAlfredo Tupone <tupone@gentoo.org>2022-01-25 19:20:00 +0100
commit4aab99227ae24fb8f52268214c7acc96bbb2a8f0 (patch)
tree33d9e2ec0b9ffedbaa87209c1bdc7d08793b5fb5 /dev-ml/luv/luv-0.5.11.ebuild
parentapp-portage/metagen: 0.7.3 (diff)
downloadgentoo-4aab99227ae24fb8f52268214c7acc96bbb2a8f0.tar.gz
gentoo-4aab99227ae24fb8f52268214c7acc96bbb2a8f0.tar.bz2
gentoo-4aab99227ae24fb8f52268214c7acc96bbb2a8f0.zip
dev-ml/luv: 0.5.11 bump
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-ml/luv/luv-0.5.11.ebuild')
-rw-r--r--dev-ml/luv/luv-0.5.11.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-ml/luv/luv-0.5.11.ebuild b/dev-ml/luv/luv-0.5.11.ebuild
new file mode 100644
index 000000000000..a8a5f1531183
--- /dev/null
+++ b/dev-ml/luv/luv-0.5.11.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="Binding to libuv: cross-platform asynchronous I/O"
+HOMEPAGE="https://github.com/aantron/luv"
+SRC_URI="https://github.com/aantron/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="+ocamlopt test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-lang/ocaml:=[ocamlopt?]
+ dev-libs/libuv:=
+ dev-ml/ocaml-ctypes:=[ocamlopt?]
+ dev-ml/result:=[ocamlopt?]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="sys-devel/gnuconfig
+ test? ( dev-ml/alcotest[ocamlopt?] )"
+
+src_prepare() {
+ default
+
+ cp "${BROOT}"/usr/share/gnuconfig/config.{guess,sub} src/c/vendor/configure/ || die
+}