summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-08-02 13:28:41 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-08-02 13:29:08 +0200
commit451d1a4a629391718e1cb11628941b43fefb65c3 (patch)
tree3f0d5505bafc55c2685661b5c1dfcb30863a34f1 /dev-ml/ocaml-make
parentdev-python/radon: Tested on ~x86 (diff)
downloadgentoo-451d1a4a629391718e1cb11628941b43fefb65c3.tar.gz
gentoo-451d1a4a629391718e1cb11628941b43fefb65c3.tar.bz2
gentoo-451d1a4a629391718e1cb11628941b43fefb65c3.zip
dev-ml/ocaml-make: bump to 6.39.0 from github
Package-Manager: Portage-2.3.6, Repoman-2.3.3
Diffstat (limited to 'dev-ml/ocaml-make')
-rw-r--r--dev-ml/ocaml-make/Manifest1
-rw-r--r--dev-ml/ocaml-make/metadata.xml2
-rw-r--r--dev-ml/ocaml-make/ocaml-make-6.39.0.ebuild31
3 files changed, 33 insertions, 1 deletions
diff --git a/dev-ml/ocaml-make/Manifest b/dev-ml/ocaml-make/Manifest
index c975f7583849..637f296a1a42 100644
--- a/dev-ml/ocaml-make/Manifest
+++ b/dev-ml/ocaml-make/Manifest
@@ -1 +1,2 @@
DIST ocaml-makefile-6.37.0.tar.gz 49202 SHA256 99ff58080ed154cc4bd70f915fe4760dffb026a1c0447caa0b3bdb982b24b0a8 SHA512 19d318f8b03116c3e999b61c1a2708f483873ab7ae9260225df79888a86eb39e77867fdefe0df23a50ac1fd422b3b774f96b5b58d9dec449710527df1075a36d WHIRLPOOL d681ae29db4dc6c2731f7a7655295e4c462f3dd24608cf4c4c628f00615531d3ec8f869f1732702e5c2523605a7a7d84a043b8b6deddafed6d0e4ee530e19c7c
+DIST ocaml-makefile-6.39.0.tbz 42477 SHA256 96fb83f9edc5dcda956c332c3300248463370bd1442734ee12951536fecb6277 SHA512 54a52c243ce23eba286502aa28ccdbb412aba7cf3ed90e3079ab1b187e61edc8a3197536d5c054b03a871eadbdd0e3b93c47904cb0594ccc2c4ce66ed31daa21 WHIRLPOOL 3f16e4f2a42508eb2b2f168467e36d07fb4f2cb13052d5f6a625cf2d724cfb7cf385ffaadc3518d5fe05e28789a60184e6791db2d81d339377321a569e8e2367
diff --git a/dev-ml/ocaml-make/metadata.xml b/dev-ml/ocaml-make/metadata.xml
index e9d7d07d42e8..c6bc6c199a22 100644
--- a/dev-ml/ocaml-make/metadata.xml
+++ b/dev-ml/ocaml-make/metadata.xml
@@ -6,6 +6,6 @@
<name>Gentoo ML Project</name>
</maintainer>
<upstream>
- <remote-id type="bitbucket">mmottl/ocaml-makefile</remote-id>
+ <remote-id type="github">mmottl/ocaml-makefile</remote-id>
</upstream>
</pkgmetadata>
diff --git a/dev-ml/ocaml-make/ocaml-make-6.39.0.ebuild b/dev-ml/ocaml-make/ocaml-make-6.39.0.ebuild
new file mode 100644
index 000000000000..e220e306ac95
--- /dev/null
+++ b/dev-ml/ocaml-make/ocaml-make-6.39.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+
+DESCRIPTION="Generic O'Caml Makefile for GNU Make"
+HOMEPAGE="http://mmottl.github.io/ocaml-makefile/ https://github.com/mmottl/ocaml-makefile"
+LICENSE="LGPL-2.1"
+
+DEPEND=""
+RDEPEND=">=dev-lang/ocaml-3.06-r1
+ >=dev-ml/findlib-0.8"
+SRC_URI="https://github.com/mmottl/ocaml-makefile/releases/download/${PV}/ocaml-makefile-${PV}.tbz"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="examples"
+S="${WORKDIR}/${PN}file-${PV}"
+
+src_install () {
+ # Just put the OCamlMakefile into /usr/include
+ # where GNU Make will automatically pick it up.
+ insinto /usr/include
+ doins OCamlMakefile
+ # install documentation
+ dodoc README.md CHANGES.md
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r calc camlp4 gtk idl threads
+ fi
+}