summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2022-04-27 08:25:51 +0200
committerAlfredo Tupone <tupone@gentoo.org>2022-04-27 08:34:22 +0200
commit543ac040a4c564a9493a4da38f8d47452506de0f (patch)
treed32a2f1c4089bac4dbc05f17bc2e8a00b4f42b4d /dev-ml/ocaml_intrinsics/ocaml_intrinsics-0.15.1.ebuild
parentdev-ruby/rails: add 6.0.4.8 (diff)
downloadgentoo-543ac040a4c564a9493a4da38f8d47452506de0f.tar.gz
gentoo-543ac040a4c564a9493a4da38f8d47452506de0f.tar.bz2
gentoo-543ac040a4c564a9493a4da38f8d47452506de0f.zip
dev-ml/ocaml_intrinsics: add to tree
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-ml/ocaml_intrinsics/ocaml_intrinsics-0.15.1.ebuild')
-rw-r--r--dev-ml/ocaml_intrinsics/ocaml_intrinsics-0.15.1.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-ml/ocaml_intrinsics/ocaml_intrinsics-0.15.1.ebuild b/dev-ml/ocaml_intrinsics/ocaml_intrinsics-0.15.1.ebuild
new file mode 100644
index 000000000000..8e29520e8c44
--- /dev/null
+++ b/dev-ml/ocaml_intrinsics/ocaml_intrinsics-0.15.1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="invoke amd64 instructions (such as clz,popcnt,rdtsc,rdpmc)"
+HOMEPAGE="https://github.com/janestreet/ocaml_intrinsics"
+SRC_URI="https://github.com/janestreet/${PN}/archive/refs/tags/v${PV}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="~amd64"
+IUSE="+ocamlopt"
+
+DEPEND="
+ >=dev-lang/ocaml-4.08
+ dev-ml/dune-configurator:=
+"
+RDEPEND="${DEPEND}"
+BDEPEND=""