summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-10-18 10:48:25 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-10-18 10:48:25 +0200
commit8798bf91e5d2965f4abf802302769ff3a196a6a7 (patch)
treea2803bd89e176fabb552a69d8ff0274f9e2fd3f7 /dev-ml/ocamlgraph
parentdev-tex/biblatex-apa: version bump (diff)
downloadgentoo-8798bf91e5d2965f4abf802302769ff3a196a6a7.tar.gz
gentoo-8798bf91e5d2965f4abf802302769ff3a196a6a7.tar.bz2
gentoo-8798bf91e5d2965f4abf802302769ff3a196a6a7.zip
dev-ml/ocamlgraph: bump to 1.8.8
Package-Manager: Portage-2.3.11, Repoman-2.3.3
Diffstat (limited to 'dev-ml/ocamlgraph')
-rw-r--r--dev-ml/ocamlgraph/Manifest1
-rw-r--r--dev-ml/ocamlgraph/ocamlgraph-1.8.8.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/dev-ml/ocamlgraph/Manifest b/dev-ml/ocamlgraph/Manifest
index f8415c114993..d61796edf3a7 100644
--- a/dev-ml/ocamlgraph/Manifest
+++ b/dev-ml/ocamlgraph/Manifest
@@ -1 +1,2 @@
DIST ocamlgraph-1.8.7.tar.gz 272625 SHA256 df06ca06d25231bb8e162d6b853177cb7fc1565c8f1ec99ca051727d46c985a0 SHA512 27559293bf576ecc9cf49090e24905c50d00ebaeb444a3c917826f3cfe1e7ceab34b43e30f98634811b1688b675d8747b590b5bb103a720d099304f5031feb2e WHIRLPOOL 3b290012a97c96c75b1b63dec056c7afb6d7c1882fc61fd3a88b32397a2e871aa9e872950e6a6e7333450f3b46181df6e27f4fc3464e5c9a3776285a904d4727
+DIST ocamlgraph-1.8.8.tar.gz 282729 SHA256 d9eabefb73cad7bc59b3870f832cd0154f8b60feca89ef087f06e59cb9092f55 SHA512 ccb07d4a7fb0c3026ad2d4563e1ca0a88483ac3cf43c9378989ae5c031961853a11c9673c06b54a16733c5755d9c0a2783c5f475afdcc7692d2bf3d4778f5bc5 WHIRLPOOL adebbe7c1807dace65a2f2cf8ed3ce88ba7dba053d58cd81edfa2ab83e84fda5cc7ce0f0e3101063692feb0db6ca02340dfee602c950a07b4784beab4b4a4b61
diff --git a/dev-ml/ocamlgraph/ocamlgraph-1.8.8.ebuild b/dev-ml/ocamlgraph/ocamlgraph-1.8.8.ebuild
new file mode 100644
index 000000000000..71e564d353db
--- /dev/null
+++ b/dev-ml/ocamlgraph/ocamlgraph-1.8.8.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit findlib
+
+DESCRIPTION="O'Caml Graph library"
+HOMEPAGE="http://ocamlgraph.lri.fr/index.en.html"
+SRC_URI="http://ocamlgraph.lri.fr/download/${P}.tar.gz"
+LICENSE="LGPL-2.1"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86"
+RDEPEND=">=dev-lang/ocaml-3.10.2:=[ocamlopt?]
+ gtk? ( dev-ml/lablgtk:=[gnomecanvas,ocamlopt?] )"
+DEPEND="${RDEPEND}
+ doc? ( dev-tex/hevea dev-ml/ocamlweb )"
+IUSE="doc examples gtk +ocamlopt"
+
+src_compile() {
+ emake byte
+ use ocamlopt && emake opt
+
+ if use doc; then
+ emake doc
+ fi
+
+ if use gtk; then
+ emake OCAMLBEST=$(usex ocamlopt opt byte) viewer dgraph editor
+ fi
+}
+
+src_install() {
+ findlib_src_preinst
+ use ocamlopt || export WANT_OCAMLOPT=no
+ use gtk && export WANT_GTK=yes
+ emake install-findlib
+
+ if use gtk ; then
+ local ext=byte
+ use ocamlopt && ext=opt
+ newbin dgraph/dgraph.${ext} ${PN}-dgraph
+ newbin editor/editor.${ext} ${PN}-editor
+ newbin view_graph/viewgraph.${ext} ${PN}-viewgraph
+ fi
+
+ dodoc README.adoc CREDITS FAQ CHANGES
+ if use doc; then
+ dohtml doc/*
+ fi
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}