summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Bauman <bman@gentoo.org>2020-09-24 15:44:05 -0400
committerAaron Bauman <bman@gentoo.org>2020-09-24 15:53:30 -0400
commit417d77a18acc05318f6f599ea85f7ced383416a4 (patch)
treea224a304845394eae88fccd5f739b7c2faa3f6fd /dev-ml/ocamlnet
parentdev-ml/alcotest: drop old EAPI=5 (diff)
downloadgentoo-417d77a18acc05318f6f599ea85f7ced383416a4.tar.gz
gentoo-417d77a18acc05318f6f599ea85f7ced383416a4.tar.bz2
gentoo-417d77a18acc05318f6f599ea85f7ced383416a4.zip
dev-ml/ocamlnet: drop old EAPI=5
Signed-off-by: Aaron Bauman <bman@gentoo.org>
Diffstat (limited to 'dev-ml/ocamlnet')
-rw-r--r--dev-ml/ocamlnet/Manifest1
-rw-r--r--dev-ml/ocamlnet/ocamlnet-4.1.3.ebuild72
2 files changed, 0 insertions, 73 deletions
diff --git a/dev-ml/ocamlnet/Manifest b/dev-ml/ocamlnet/Manifest
index 07c535b63237..59ad21965868 100644
--- a/dev-ml/ocamlnet/Manifest
+++ b/dev-ml/ocamlnet/Manifest
@@ -1,3 +1,2 @@
DIST ocamlnet-4.1.2.tar.gz 4623183 BLAKE2B 7e8d5cdc823b9e924258f75f00957ba185d49555377ba2a2d960c47e2ea958059e1ab62e27be63770bb4f547e1fa0cb788a54c3e698180b2b15f0097fe84455a SHA512 69f42042a54efd662db2217224da53513fc7e72c7b2313d4a4a1128f1b4624f4f6298434f5b19f354b832119ff151abc81e85eb0108d6eb24f30f82d176e0b4d
-DIST ocamlnet-4.1.3.tar.gz 4553037 BLAKE2B 177d2a3b947e6123bdef0ee180c612f832a22dfd90fe0c44b60ba2ebea3629103db9730eb1b926b7d7bf39b489934b8949b0fd08e5155c7f41e3c065c215558c SHA512 683ab6f529639c9da01478ba8ba7a1bf89a418ad3872331bb3e29067c0a75ddc0db996630ce5a5dd116967d6e3e756ade02d9a78b865bbc226f95d01af9e3956
DIST ocamlnet-4.1.4.tar.gz 4552969 BLAKE2B 3dfedcd09eb91d1ca8e13b7a87dfe70cfb88d57d0b4fa970fe6179affa05ba3fdeaad0dfbb6ac267e7a6530c289408b1a8ad66a805226245f80fe66770addad5 SHA512 ca502444f81898ccda27d61760a357aad59624cf3c4c025d49dd1c2e7bc3ef497c199634247ba7731e016c234e5cd92d2599d1ef9ecd55c3b6e7a64fc4773ee0
diff --git a/dev-ml/ocamlnet/ocamlnet-4.1.3.ebuild b/dev-ml/ocamlnet/ocamlnet-4.1.3.ebuild
deleted file mode 100644
index 1d38ddb0e813..000000000000
--- a/dev-ml/ocamlnet/ocamlnet-4.1.3.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-
-inherit eutils findlib
-
-MY_P=${P/_beta/test}
-DESCRIPTION="Modules for OCaml application-level Internet protocols"
-HOMEPAGE="http://projects.camlcity.org/projects/ocamlnet.html"
-SRC_URI="http://download.camlcity.org/download/${MY_P}.tar.gz"
-
-LICENSE="ZLIB GPL-2+"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="gtk kerberos tk httpd +ocamlopt +pcre ssl zip"
-RESTRICT="installsources strip"
-
-# the auth-dh compile flag has been disabled as well, since it depends on
-# ocaml-cryptgps, which is not available.
-
-RDEPEND=">=dev-ml/findlib-1.0
- pcre? ( >=dev-ml/pcre-ocaml-5:= )
- >=dev-lang/ocaml-3.10.2:=[ocamlopt?]
- tk? ( dev-ml/labltk:= )
- ssl? ( net-libs/gnutls:= )
- gtk? ( >=dev-ml/lablgtk-2:= )
- kerberos? ( virtual/krb5 )
- zip? ( dev-ml/camlzip:= )
- "
-DEPEND="${RDEPEND}
- virtual/pkgconfig
-"
-
-S=${WORKDIR}/${MY_P}
-
-ocamlnet_use_with() {
- if use $1; then
- echo "-with-$2"
- else
- echo "-without-$2"
- fi
-}
-
-ocamlnet_use_enable() {
- if use $1; then
- echo "-enable-$2"
- else
- echo "-disable-$2"
- fi
-}
-
-src_configure() {
- ./configure \
- -bindir /usr/bin \
- -datadir /usr/share/${PN} \
- $(ocamlnet_use_enable ssl gnutls) \
- $(ocamlnet_use_enable gtk gtk2) \
- $(ocamlnet_use_enable kerberos gssapi) \
- $(ocamlnet_use_enable pcre pcre) \
- $(ocamlnet_use_enable tk tcl) \
- $(ocamlnet_use_enable zip zip) \
- $(ocamlnet_use_with httpd nethttpd) \
- || die "Error : econf failed!"
-}
-
-src_compile() {
- emake -j1 all
- if use ocamlopt; then
- emake -j1 opt
- fi
-}