summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-05-23 15:36:41 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-05-24 13:07:15 +0200
commit93b3ba9bff570d01b0a4e2568f5d6dee19437942 (patch)
tree48edc6613f851527cc9446b8ecaff8338da9695d /dev-ml/octavius/octavius-1.1.0.ebuild
parentdev-ml/core: bump to 0.9.1 (diff)
downloadgentoo-93b3ba9bff570d01b0a4e2568f5d6dee19437942.tar.gz
gentoo-93b3ba9bff570d01b0a4e2568f5d6dee19437942.tar.bz2
gentoo-93b3ba9bff570d01b0a4e2568f5d6dee19437942.zip
dev-ml/octavius: Bump to 1.1.0
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-ml/octavius/octavius-1.1.0.ebuild')
-rw-r--r--dev-ml/octavius/octavius-1.1.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-ml/octavius/octavius-1.1.0.ebuild b/dev-ml/octavius/octavius-1.1.0.ebuild
new file mode 100644
index 000000000000..f5e88e6df419
--- /dev/null
+++ b/dev-ml/octavius/octavius-1.1.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit findlib
+
+DESCRIPTION="ocamldoc comment syntax parser"
+HOMEPAGE="https://github.com/ocaml-doc/octavius"
+SRC_URI="https://github.com/ocaml-doc/octavius/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="dev-lang/ocaml:="
+RDEPEND="${DEPEND}"
+DEPEND="${DEPEND}
+ dev-ml/jbuilder
+ dev-ml/opam
+ dev-ml/ocamlbuild"
+
+src_install() {
+ opam-installer -i \
+ --prefix="${ED}/usr" \
+ --libdir="${D}/$(ocamlc -where)" \
+ --docdir="${ED}/usr/share/doc/${PF}" \
+ ${PN}.install || die
+}