summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ml/pa_bench
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ml/pa_bench')
-rw-r--r--dev-ml/pa_bench/Manifest3
-rw-r--r--dev-ml/pa_bench/metadata.xml5
-rw-r--r--dev-ml/pa_bench/pa_bench-109.55.02.ebuild24
-rw-r--r--dev-ml/pa_bench/pa_bench-111.28.00.ebuild25
-rw-r--r--dev-ml/pa_bench/pa_bench-112.06.00.ebuild25
5 files changed, 82 insertions, 0 deletions
diff --git a/dev-ml/pa_bench/Manifest b/dev-ml/pa_bench/Manifest
new file mode 100644
index 000000000000..6f159fd0081e
--- /dev/null
+++ b/dev-ml/pa_bench/Manifest
@@ -0,0 +1,3 @@
+DIST pa_bench-109.55.02.tar.gz 51237 SHA256 98f0158e0997ab400d182537a6f6bff4ebccf0e14424fa470391b17c2e1e5dc8 SHA512 fa129c3d3b1c3a6e6f09f43751eba8cb4bb775b6a1b2031249507c05538364710844d0d6efc58b283552980629d0f2a2189b75aa24d58daa8d8ce12883f2ee89 WHIRLPOOL f0b81d9c6ac377684adc0a86b91042a1ce1ba2d15cd9f86093cd58d44f90d8917807c9ebc460b577251d8194a97ae06561e51de22ccb586ba53518809fbd26e3
+DIST pa_bench-111.28.00.tar.gz 53158 SHA256 2cbb6fca9ba8889c97236e05d92451cf3880aabbe4430519d131f5f68d80f4f3 SHA512 0eb7af5e2db9889dcbae244569a3cd5c5f631e7abc70684056f1c11d8702225f16e954d79e98ec373af424819183aa33835a8b70cb14fe544ffc475e98684ef1 WHIRLPOOL 5a7b32062b9599b5d25c1b34009e47d899a33a4ea092aa10de9f896bcedf0dfc4766872b4155cb11e4a4ef0319aec26b2f1ac8082e54f59762e7ff3cc3ee2177
+DIST pa_bench-112.06.00.tar.gz 54371 SHA256 e3401e37f1d3d4acb957fd46a192d0ffcefeb0bedee63bbeb26969af1d540870 SHA512 1e75c5b765051357f17bfe1213af16174a07903da7c9ecff3ce937227385d815c25f6430f103be3b65b69ba0d7a3a22051ef7bf28d577cf26e87c3a628040fdc WHIRLPOOL c2453c243590bbea85cba7ac3c85b6ffc245ec157bfa453d2c0b787961b72a759b7f845a40ec67d114c7ebf5f18e4677ab34743bd7e3cc05c31b0d85e5dbde79
diff --git a/dev-ml/pa_bench/metadata.xml b/dev-ml/pa_bench/metadata.xml
new file mode 100644
index 000000000000..2193d772e351
--- /dev/null
+++ b/dev-ml/pa_bench/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ml</herd>
+</pkgmetadata>
diff --git a/dev-ml/pa_bench/pa_bench-109.55.02.ebuild b/dev-ml/pa_bench/pa_bench-109.55.02.ebuild
new file mode 100644
index 000000000000..a29cccf54b23
--- /dev/null
+++ b/dev-ml/pa_bench/pa_bench-109.55.02.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit oasis
+
+MY_P=${PN/-/_}-${PV}
+DESCRIPTION="Syntax extension writing inline benchmarks"
+HOMEPAGE="http://www.janestreet.com/ocaml"
+SRC_URI="http://ocaml.janestreet.com/ocaml-core/${PV%.*}.00/individual/${MY_P}.tar.gz
+ http://dev.gentoo.org/~aballier/distfiles/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=">=dev-ml/type-conv-${PV}:=
+ dev-ml/pa_ounit:="
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
diff --git a/dev-ml/pa_bench/pa_bench-111.28.00.ebuild b/dev-ml/pa_bench/pa_bench-111.28.00.ebuild
new file mode 100644
index 000000000000..2f250bcb4fe6
--- /dev/null
+++ b/dev-ml/pa_bench/pa_bench-111.28.00.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit oasis
+
+MY_P=${PN/-/_}-${PV}
+DESCRIPTION="Syntax extension writing inline benchmarks"
+HOMEPAGE="http://www.janestreet.com/ocaml"
+SRC_URI="http://ocaml.janestreet.com/ocaml-core/${PV%.*}.00/individual/${MY_P}.tar.gz
+ http://dev.gentoo.org/~aballier/distfiles/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=">=dev-ml/type-conv-109:=
+ dev-ml/pa_ounit:=
+ || ( dev-ml/camlp4:= <dev-lang/ocaml-4.02.0 )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
diff --git a/dev-ml/pa_bench/pa_bench-112.06.00.ebuild b/dev-ml/pa_bench/pa_bench-112.06.00.ebuild
new file mode 100644
index 000000000000..6ab293278823
--- /dev/null
+++ b/dev-ml/pa_bench/pa_bench-112.06.00.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit oasis
+
+MY_P=${PN/-/_}-${PV}
+DESCRIPTION="Syntax extension writing inline benchmarks"
+HOMEPAGE="http://www.janestreet.com/ocaml"
+SRC_URI="http://ocaml.janestreet.com/ocaml-core/${PV%.*}.00/individual/${MY_P}.tar.gz
+ http://dev.gentoo.org/~aballier/distfiles/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=">=dev-ml/type-conv-109:=
+ dev-ml/pa_ounit:=
+ dev-ml/camlp4:="
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"