summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2022-04-24 10:30:34 +0200
committerAlfredo Tupone <tupone@gentoo.org>2022-04-24 10:30:34 +0200
commitbac60b0e784db4d01077322e213656c6197acc08 (patch)
tree3f90a310683bb6ded373acf67461bc9a53fdc046 /dev-ml/ppx_hash
parentpackage.mask: add ppx_hash to janestreet mask (diff)
downloadgentoo-bac60b0e784db4d01077322e213656c6197acc08.tar.gz
gentoo-bac60b0e784db4d01077322e213656c6197acc08.tar.bz2
gentoo-bac60b0e784db4d01077322e213656c6197acc08.zip
dev-ml/ppx_hash: 0.15.0 bump
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-ml/ppx_hash')
-rw-r--r--dev-ml/ppx_hash/Manifest1
-rw-r--r--dev-ml/ppx_hash/ppx_hash-0.15.0.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/dev-ml/ppx_hash/Manifest b/dev-ml/ppx_hash/Manifest
index ec6e5429ab05..fff4d3fb54d6 100644
--- a/dev-ml/ppx_hash/Manifest
+++ b/dev-ml/ppx_hash/Manifest
@@ -1 +1,2 @@
DIST ppx_hash-0.14.0.tar.gz 27859 BLAKE2B 0d89eeec154e62ae42ddaff6b0ccdf827ad768e0f19dcdfd4f8b940f594856c8fc036fa02a2462666f2ee4b675e1594837d196fb92cdbb9f8bdf4e171ce90374 SHA512 21d68c0655c21fcd0cecceb8c69e45706b57db160e49c3b112e67cc874a8084946dbae8709ed99f24e7282182c7238cf95ef00bec3ac5a271409e9d5f788467c
+DIST ppx_hash-0.15.0.tar.gz 28632 BLAKE2B 07c2416bcd1504bc82970a569984fdf225bf74e98d3b8e401b32370eee657a2b1b53a1903a702fcb04c295d1df08de67b9f6971ec8f1dcbf31e87c36136b27b2 SHA512 333d2b232b1d5c15fe144bafb7ad4c843e5381e71b21b25a6fb9c03b1ee98ba81580de7036580ac2d04dcdfed0af20003875b9374412b8ef130b4647c30fee6a
diff --git a/dev-ml/ppx_hash/ppx_hash-0.15.0.ebuild b/dev-ml/ppx_hash/ppx_hash-0.15.0.ebuild
new file mode 100644
index 000000000000..287a652b531d
--- /dev/null
+++ b/dev-ml/ppx_hash/ppx_hash-0.15.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="PPX rewriter that generates hash functions from type expressions and definitions"
+HOMEPAGE="https://github.com/janestreet/ppx_hash"
+SRC_URI="https://github.com/janestreet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="+ocamlopt"
+
+DEPEND="
+ dev-ml/base:${SLOT}
+ dev-ml/ppx_compare:${SLOT}
+ dev-ml/ppx_sexp_conv:${SLOT}
+ >=dev-ml/ppxlib-0.23.0:=
+ >=dev-ml/ocaml-compiler-libs-0.11.0:=
+"
+RDEPEND="${DEPEND}"