summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-04-01 18:25:36 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-04-02 10:37:53 +0200
commit528ab61dd388c469dec686fa788a008706e79b64 (patch)
tree4f384f069e096f57c80fc99d28f9ec9026ed2217 /dev-ml/ppx_js_style
parentdev-ml/octavius: initial import (diff)
downloadgentoo-528ab61dd388c469dec686fa788a008706e79b64.tar.gz
gentoo-528ab61dd388c469dec686fa788a008706e79b64.tar.bz2
gentoo-528ab61dd388c469dec686fa788a008706e79b64.zip
dev-ml/ppx_js_style: initial import
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-ml/ppx_js_style')
-rw-r--r--dev-ml/ppx_js_style/Manifest1
-rw-r--r--dev-ml/ppx_js_style/metadata.xml8
-rw-r--r--dev-ml/ppx_js_style/ppx_js_style-0.9.0.ebuild32
3 files changed, 41 insertions, 0 deletions
diff --git a/dev-ml/ppx_js_style/Manifest b/dev-ml/ppx_js_style/Manifest
new file mode 100644
index 000000000000..77b0b21a85b8
--- /dev/null
+++ b/dev-ml/ppx_js_style/Manifest
@@ -0,0 +1 @@
+DIST ppx_js_style-0.9.0.tar.gz 8182 SHA256 3120899e2b9bc0f9067485a3d4d9b94692dc6e2d796de5ee36ad7a142e937cb1 SHA512 9790223a2d8f6db090cfa4d7ff3d3d1c8a22b07863dd3c5674216836b23cfdb3b014ebc092e173ddfe725ccf73fc7830a8a88effab1df9d80875f918b9558051 WHIRLPOOL 877b0e31a32cd5a601a4cb5c8f271c9bbe367813990f89c3088e4bbf16930aa58bfc5d695ab119e26b029161bbe0bfeb45a0e1a8faffafc588fd247ac561adda
diff --git a/dev-ml/ppx_js_style/metadata.xml b/dev-ml/ppx_js_style/metadata.xml
new file mode 100644
index 000000000000..ffac4d7ebc01
--- /dev/null
+++ b/dev-ml/ppx_js_style/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>Gentoo ML Project</name>
+</maintainer>
+</pkgmetadata>
diff --git a/dev-ml/ppx_js_style/ppx_js_style-0.9.0.ebuild b/dev-ml/ppx_js_style/ppx_js_style-0.9.0.ebuild
new file mode 100644
index 000000000000..b04e6622ad19
--- /dev/null
+++ b/dev-ml/ppx_js_style/ppx_js_style-0.9.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Code style checker for Jane Street Packages"
+HOMEPAGE="https://github.com/janestreet/ppx_js_style"
+SRC_URI="https://github.com/janestreet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="
+ dev-lang/ocaml:=
+ dev-ml/ppx_core:=
+ dev-ml/ppx_driver:=
+ dev-ml/ppx_metaquot:=
+ dev-ml/ocaml-migrate-parsetree:=
+ dev-ml/octavius:=
+ "
+RDEPEND="${DEPEND}"
+DEPEND="${DEPEND} dev-ml/opam dev-ml/jbuilder"
+
+src_install() {
+ opam-installer -i \
+ --prefix="${ED}/usr" \
+ --libdir="${D}/$(ocamlc -where)" \
+ --docdir="${ED}/usr/share/doc/${PF}" \
+ ${PN}.install || die
+}