summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2023-06-30 14:41:28 +0200
committerAlfredo Tupone <tupone@gentoo.org>2023-06-30 15:13:51 +0200
commit851e914cfef0850805964822c2d4809b0c5638bc (patch)
tree30935a8b8d8fdc576f731151bb0f2896eb5f8e0f /dev-ml/stdio/stdio-0.16.0.ebuild
parentdev-ml/ppx_assert: add 0.16.0 (diff)
downloadgentoo-851e914cfef0850805964822c2d4809b0c5638bc.tar.gz
gentoo-851e914cfef0850805964822c2d4809b0c5638bc.tar.bz2
gentoo-851e914cfef0850805964822c2d4809b0c5638bc.zip
dev-ml/stdio: add 0.16.0
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-ml/stdio/stdio-0.16.0.ebuild')
-rw-r--r--dev-ml/stdio/stdio-0.16.0.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-ml/stdio/stdio-0.16.0.ebuild b/dev-ml/stdio/stdio-0.16.0.ebuild
new file mode 100644
index 000000000000..171197bf5c82
--- /dev/null
+++ b/dev-ml/stdio/stdio-0.16.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="Standard IO Library for OCaml"
+HOMEPAGE="https://github.com/janestreet/stdio"
+SRC_URI="https://github.com/janestreet/stdio/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="+ocamlopt"
+
+RDEPEND="
+ >=dev-lang/ocaml-4.14
+ dev-ml/base:${SLOT}
+"
+DEPEND="${RDEPEND}"