summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-11-06 03:24:14 +0000
committerSam James <sam@gentoo.org>2021-11-06 03:24:14 +0000
commit4aa28a2698b8de5cff5c1390470339942a7a4026 (patch)
tree559b1d3a26a1b0351b52cb63f0963ad29f3c79d6 /dev-ml
parentdev-ml/opam-installer: add 2.0.10 (diff)
downloadgentoo-4aa28a2698b8de5cff5c1390470339942a7a4026.tar.gz
gentoo-4aa28a2698b8de5cff5c1390470339942a7a4026.tar.bz2
gentoo-4aa28a2698b8de5cff5c1390470339942a7a4026.zip
dev-ml/opam-repository: add 2.0.10
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/opam-repository/Manifest1
-rw-r--r--dev-ml/opam-repository/opam-repository-2.0.10.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-ml/opam-repository/Manifest b/dev-ml/opam-repository/Manifest
index 0b145947da01..ed498336536d 100644
--- a/dev-ml/opam-repository/Manifest
+++ b/dev-ml/opam-repository/Manifest
@@ -1,3 +1,4 @@
+DIST opam-2.0.10.tar.gz 641739 BLAKE2B 7cd201fe6bed2ae81fc8d9d0a7063b284621e579713c2b8672a5ea37cd7516a030367664823c75594a789136ffe5b313818fa120fb64e499b8276706700df776 SHA512 49218a14c3b7e2f47052c1fb6907b54086f5af4adb43d120065c77f2c573d72136ac64f55f577a613eb43ebe29fbe14f9ac0e25756209ca7a572aa35a4410a5d
DIST opam-2.0.8.tar.gz 643221 BLAKE2B 66510a18285f315fe95665e8ba2f334dd44211c716543cdc25f2951a7dfe537f115981046e5963fd08deea4c76f5672fa7cf8e7af2274a713a3165bdd0bac8c2 SHA512 14737dc994be2c54dfeaf2658d3713178033e1bc2b4b845a58b4bfc118bbbf12b502924add0ae32b4b2b6c1944462e5ee7143df3de362d9ee39573249d013bc9
DIST opam-2.0.9.tar.gz 644429 BLAKE2B d96ee79685a8ee8ff82c7570a747c80e38d86e513736a27904a4e471d1eaf432db72998251ac786cb8fbf1ad425fff42b772c5d26934e0929aae75c0946d4659 SHA512 0d8ee19ac0f3df9de4fd9cfa8daab1f7228f090f5e2e7e26bedf24d8c2ab377aade95048f2d7cd9ee9dbbe738729e26dc99f41f730fa2252df74953362464a22
DIST opam-2.1.0-dose3-6.patch.xz 5896 BLAKE2B f605064ebae7d327895729962a345a3c679519895aa2568f0c2d199d4ba9d6ae948a4fc418cfd26cc65079eb6ef3545f24a35e08c969d215529664a80d0c9147 SHA512 e00da74d7baef62319e884e3a05112bcf86a02d887c274bd15fb0d15bb8198e9a37a421f388bec3fce198e7a1b4d37024b18609dc65978c6ee8a7889df9bd608
diff --git a/dev-ml/opam-repository/opam-repository-2.0.10.ebuild b/dev-ml/opam-repository/opam-repository-2.0.10.ebuild
new file mode 100644
index 000000000000..b7f297cca04b
--- /dev/null
+++ b/dev-ml/opam-repository/opam-repository-2.0.10.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune
+
+DESCRIPTION="opam repository libraries"
+HOMEPAGE="https://opam.ocaml.org/ https://github.com/ocaml/opam"
+SRC_URI="https://github.com/ocaml/opam/archive/${PV/_/-}.tar.gz -> opam-${PV}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~sam/distfiles/dev-ml/opam/opam-2.1.0-dose3-6.patch.xz"
+S="${WORKDIR}/opam-${PV/_/-}"
+
+LICENSE="LGPL-2.1"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="+ocamlopt"
+RESTRICT="test"
+
+RDEPEND="
+ ~dev-ml/opam-format-${PV}:=
+ dev-ml/re:=
+ >=dev-ml/dose3-6.0:=
+ dev-ml/opam-file-format:=
+"
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${WORKDIR}"/opam-2.1.0-dose3-6.patch )
+
+src_prepare() {
+ default
+ cat <<- EOF >> "${S}/dune"
+ (env
+ (dev
+ (flags (:standard -warn-error -3-9-33)))
+ (release
+ (flags (:standard -warn-error -3-9-33))))
+ EOF
+}