summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-05-03 12:37:54 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-05-03 12:40:50 +0200
commit5db2f4b1f0e67846d69bb725e39557c98f11ee51 (patch)
treedd6f68e72f45734844101702763d34bdb436753f /dev-ml
parentnet-misc/bird: Version bump to 1.6.0; as requested by Moyaze Shivji in the LI... (diff)
downloadgentoo-5db2f4b1f0e67846d69bb725e39557c98f11ee51.tar.gz
gentoo-5db2f4b1f0e67846d69bb725e39557c98f11ee51.tar.bz2
gentoo-5db2f4b1f0e67846d69bb725e39557c98f11ee51.zip
dev-ml/ocamlbuild: bump to 0.9.2
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/ocamlbuild/Manifest1
-rw-r--r--dev-ml/ocamlbuild/ocamlbuild-0.9.2.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-ml/ocamlbuild/Manifest b/dev-ml/ocamlbuild/Manifest
index 53846547f22a..d7ccb433cfba 100644
--- a/dev-ml/ocamlbuild/Manifest
+++ b/dev-ml/ocamlbuild/Manifest
@@ -1 +1,2 @@
DIST ocamlbuild-0.9.1.tar.gz 160896 SHA256 7a31fde2d863768372851665e3ce64064c35e38d2b2f3cbd060a6df426f16ee8 SHA512 07da313f896fd31fab42881515f33544a587f831aa0928540af2351bf8d59b14115a144b17d156cb2599ce5d568684192a922f9f85f86ddd7299b8e194fd85c6 WHIRLPOOL f28e3ce19371dc26d6992035e47a72cb82adde2869dd5188a8ea0ed6aee481633e0ada4ec28428a2f58e51582f60c3a486066d0f7e09dda4e8c374f977f420a8
+DIST ocamlbuild-0.9.2.tar.gz 163014 SHA256 257a3961da1aa47deb3de8da238ebe1daf13a73efef2228f97a064a90f91c6bc SHA512 6f6fa2ca0030256b61a9f93275f26327a032594a1ddd288e1eb9f4c41dfc139e4cdb6cd66ae8e383dd2f8aabb435181abfbf6b4aa0892ef6fa420c29e33b391a WHIRLPOOL 4b1285a3177787c9d4d1e4581dec4079a1144568512c8871b2ed9436bea941c9447130af616c418d7c18157f0818de26f6344635c7e63e4ec13acaa5229cf77a
diff --git a/dev-ml/ocamlbuild/ocamlbuild-0.9.2.ebuild b/dev-ml/ocamlbuild/ocamlbuild-0.9.2.ebuild
new file mode 100644
index 000000000000..7fe9092e2788
--- /dev/null
+++ b/dev-ml/ocamlbuild/ocamlbuild-0.9.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="OCamlbuild"
+HOMEPAGE="https://github.com/ocaml/ocamlbuild"
+SRC_URI="https://github.com/ocaml/ocamlbuild/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="+ocamlopt"
+
+DEPEND=">=dev-lang/ocaml-4.02.3-r1:=[ocamlopt?]"
+RDEPEND="${DEPEND}
+ !<dev-ml/findlib-1.6.1-r1
+"
+
+src_configure() {
+ emake -f configure.make Makefile.config \
+ PREFIX="${EPREFIX}/usr" \
+ BINDIR="${EPREFIX}/usr/bin" \
+ LIBDIR="$(ocamlc -where)" \
+ OCAML_NATIVE=$(usex ocamlopt true false) \
+ OCAML_NATIVE_TOOLS=$(usex ocamlopt true false) \
+ NATDYNLINK=$(usex ocamlopt true false)
+}
+
+src_install() {
+ emake CHECK_IF_PREINSTALLED=false DESTDIR="${D}" install
+ dodoc Changes
+}