summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-05-03 18:29:56 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-05-03 19:44:22 +0200
commit6f9ce785a4a5d5a9b4593d900557d23e4c81ac73 (patch)
treef3d74c628d5333018ce3da4a9f2c31890b59f886 /dev-ml
parentdev-ml/ppx_sexp_message: fix build with ocaml 4.03 (diff)
downloadgentoo-6f9ce785a4a5d5a9b4593d900557d23e4c81ac73.tar.gz
gentoo-6f9ce785a4a5d5a9b4593d900557d23e4c81ac73.tar.bz2
gentoo-6f9ce785a4a5d5a9b4593d900557d23e4c81ac73.zip
dev-ml/ppx_pipebang: fix build with ocaml 4.03
Package-Manager: portage-2.2.28 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/ppx_pipebang/files/oc43.patch46
-rw-r--r--dev-ml/ppx_pipebang/ppx_pipebang-113.33.00.ebuild4
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-ml/ppx_pipebang/files/oc43.patch b/dev-ml/ppx_pipebang/files/oc43.patch
new file mode 100644
index 000000000000..5f10fc02053f
--- /dev/null
+++ b/dev-ml/ppx_pipebang/files/oc43.patch
@@ -0,0 +1,46 @@
+diff -uNr ppx_pipebang-113.33.00/_oasis ppx_pipebang-113.33.00+4.03/_oasis
+--- ppx_pipebang-113.33.00/_oasis 2016-03-09 16:44:54.000000000 +0100
++++ ppx_pipebang-113.33.00+4.03/_oasis 2016-03-22 15:13:51.000000000 +0100
+@@ -1,8 +1,8 @@
+ OASISFormat: 0.4
+-OCamlVersion: >= 4.02.3
++OCamlVersion: >= 4.03.0
+ FindlibVersion: >= 1.3.2
+ Name: ppx_pipebang
+-Version: 113.33.00
++Version: 113.33.00+4.03
+ Synopsis: A ppx rewriter that inlines reverse application operators `|>` and `|!`
+ Authors: Jane Street Group, LLC <opensource@janestreet.com>
+ Copyrights: (C) 2015-2016 Jane Street Group LLC <opensource@janestreet.com>
+diff -uNr ppx_pipebang-113.33.00/opam ppx_pipebang-113.33.00+4.03/opam
+--- ppx_pipebang-113.33.00/opam 2016-03-18 12:08:01.000000000 +0100
++++ ppx_pipebang-113.33.00+4.03/opam 2016-03-22 17:51:37.000000000 +0100
+@@ -16,4 +16,4 @@
+ "ppx_driver"
+ "ppx_tools" {>= "0.99.3"}
+ ]
+-available: [ ocaml-version >= "4.02.3" ]
++available: [ ocaml-version >= "4.03.0" ]
+diff -uNr ppx_pipebang-113.33.00/src/ppx_pipebang.ml ppx_pipebang-113.33.00+4.03/src/ppx_pipebang.ml
+--- ppx_pipebang-113.33.00/src/ppx_pipebang.ml 2016-03-09 16:44:54.000000000 +0100
++++ ppx_pipebang-113.33.00+4.03/src/ppx_pipebang.ml 2016-03-22 15:13:51.000000000 +0100
+@@ -11,16 +11,16 @@
+ let loc = e.pexp_loc in
+ match e.pexp_desc with
+ | Pexp_apply ({ pexp_desc = Pexp_ident { txt = Lident ("|!" | "|>"); _ }; _ },
+- [("", x); ("", y)]) -> begin
++ [(Nolabel, x); (Nolabel, y)]) -> begin
+ let x = self#expression x in
+ let y = self#expression y in
+ match y with
+ | { pexp_desc = Pexp_construct (id, None); _ } ->
+ { y with pexp_desc = Pexp_construct (id, Some x) }
+ | { pexp_desc = Pexp_apply (f, args); pexp_attributes = []; _ } ->
+- { e with pexp_desc = Pexp_apply (f, args @ [("", x)]) }
++ { e with pexp_desc = Pexp_apply (f, args @ [(Nolabel, x)]) }
+ | _ ->
+- { e with pexp_desc = Pexp_apply (y, [("", x)]) }
++ { e with pexp_desc = Pexp_apply (y, [(Nolabel, x)]) }
+ end
+ | Pexp_ident { txt = Lident ("|!" | "|>" as s); _ } ->
+ Location.raise_errorf ~loc "%s must be applied to two arguments" s
diff --git a/dev-ml/ppx_pipebang/ppx_pipebang-113.33.00.ebuild b/dev-ml/ppx_pipebang/ppx_pipebang-113.33.00.ebuild
index ae35794117cb..867ca54721e0 100644
--- a/dev-ml/ppx_pipebang/ppx_pipebang-113.33.00.ebuild
+++ b/dev-ml/ppx_pipebang/ppx_pipebang-113.33.00.ebuild
@@ -22,6 +22,10 @@ DEPEND="dev-ml/ppx_tools:=
RDEPEND="${DEPEND}"
DEPEND="${DEPEND} dev-ml/opam"
+src_prepare() {
+ has_version '>=dev-lang/ocaml-4.03' && epatch "${FILESDIR}/oc43.patch"
+}
+
src_configure() {
emake setup.exe
OASIS_SETUP_COMMAND="./setup.exe" oasis_src_configure