summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-07-28 10:50:34 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-07-29 12:05:38 +0200
commitc02297c9c11addcd6f954b564e58b148f0bc2872 (patch)
treeafe3e56d8f1dfdd779b1eab49b488a809a72fc0e /dev-ml
parentdev-ml/ocaml-stdint: bump to 0.4.1 (diff)
downloadgentoo-c02297c9c11addcd6f954b564e58b148f0bc2872.tar.gz
gentoo-c02297c9c11addcd6f954b564e58b148f0bc2872.tar.bz2
gentoo-c02297c9c11addcd6f954b564e58b148f0bc2872.zip
dev-ml/ocaml-dispatch: bump to 0.4.0
Package-Manager: Portage-2.3.6, Repoman-2.3.3
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/ocaml-dispatch/Manifest1
-rw-r--r--dev-ml/ocaml-dispatch/ocaml-dispatch-0.4.0.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-ml/ocaml-dispatch/Manifest b/dev-ml/ocaml-dispatch/Manifest
index 2ab3e314bede..f9f4dc4fc5f2 100644
--- a/dev-ml/ocaml-dispatch/Manifest
+++ b/dev-ml/ocaml-dispatch/Manifest
@@ -1 +1,2 @@
DIST ocaml-dispatch-0.3.0.tar.gz 51453 SHA256 ebb6bb60ec5a7c17a68711a801006f204b283989b5b9fa1dbe9bd781645f3913 SHA512 0f09eae45a2ecae27d07e247b6a47f307e074342e337e7be262f5183f77090f0aef81fb5c0bf499732bd0a711d4d51775cbcea5e463011f43a1777582d78806b WHIRLPOOL f77f459b34df41506ef1eb13e4d880a0bfed8166e60e2770b0cb6dc3ac2285281f4fc35c2b12465743492d8f730b6ad5585e995a3152a2c5e72638c335158256
+DIST ocaml-dispatch-0.4.0.tar.gz 7554 SHA256 6c8e77f2960742c16e187355bd1bdaf51ff83c377bf91c6cf4db72de026de5b2 SHA512 d5318bda4079c21820fce5b21d178ed88fd0535a5cdc559dd6ceeb4d06ffb08456ee5aec1e56efd40b6d4f456f7d5c7eda17dc728666e6514dc936898b605b36 WHIRLPOOL 646bcbe74eb10f8935010c797d65c65bf5e74bb532ae375cad00953fcdc0cd9ca93a28e5a453db311114aaf296805893877e8a3bc65cd86ece995e9cea6cf934
diff --git a/dev-ml/ocaml-dispatch/ocaml-dispatch-0.4.0.ebuild b/dev-ml/ocaml-dispatch/ocaml-dispatch-0.4.0.ebuild
new file mode 100644
index 000000000000..562ef548b9a1
--- /dev/null
+++ b/dev-ml/ocaml-dispatch/ocaml-dispatch-0.4.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit findlib
+
+DESCRIPTION="Path-based dispatching for client- and server-side applications"
+HOMEPAGE="https://github.com/inhabitedtype/ocaml-dispatch"
+SRC_URI="https://github.com/inhabitedtype/ocaml-dispatch/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="test"
+
+DEPEND="
+ dev-ml/result:=
+ dev-lang/ocaml:=
+"
+RDEPEND="${DEPEND}"
+DEPEND="${DEPEND}
+ dev-ml/jbuilder
+ dev-ml/opam
+ test? ( dev-ml/ounit )
+"
+
+src_compile() {
+ jbuilder build -p dispatch || die
+}
+
+oinstall() {
+ opam-installer -i \
+ --prefix="${ED}/usr" \
+ --libdir="${D}/$(ocamlc -where)" \
+ --docdir="${ED}/usr/share/doc/${PF}" \
+ --mandir="${ED}/usr/share/man" \
+ ${1}.install || die
+}
+
+src_install() {
+ oinstall dispatch
+}