summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-04-25 18:28:21 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-04-25 19:32:17 +0200
commitd655259576d18ba2caf5a30ab16f443cdaec372d (patch)
tree443974429a9a6281590a3d8899759c55bd016d12 /dev-ml
parentapp-misc/ranger: version bump to 1.9.0_beta5 (diff)
downloadgentoo-d655259576d18ba2caf5a30ab16f443cdaec372d.tar.gz
gentoo-d655259576d18ba2caf5a30ab16f443cdaec372d.tar.bz2
gentoo-d655259576d18ba2caf5a30ab16f443cdaec372d.zip
dev-ml/cppo: bump to 1.5.0
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/cppo/Manifest1
-rw-r--r--dev-ml/cppo/cppo-1.5.0.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-ml/cppo/Manifest b/dev-ml/cppo/Manifest
index 2e5eec56ff82..53a0d4f2a0b8 100644
--- a/dev-ml/cppo/Manifest
+++ b/dev-ml/cppo/Manifest
@@ -1 +1,2 @@
DIST cppo-1.4.1.tar.gz 26547 SHA256 5b7efc30256e1568a0f39ddeadc54ff57c4ec1b183ae034db36e27c0ad51f509 SHA512 efbc82d2eb31b9e16c43ffbd7a2a56a5356934c32bee62205f55295a9342e4747ce13b9ad6572f3180e656b215a9255d402712ff7bae1ef9e8eccdabb2d00c16 WHIRLPOOL 3d6b6a44282e9c1e96840da1bfb7b0641c7349bb6099cd61f62a00487696b65db0075a69a6375484c16c1e11d54f36dccffcb86d92a960594d8d4c8c256b14ee
+DIST cppo-1.5.0.tar.gz 26963 SHA256 00c6d6d470da0d529928f0a82d5f88052c4df279a70da20e0b4f025b26a36819 SHA512 2cc144815b818242b6bb1dee213aa65345620eaf1afe59b25d118399d9a02d577aa9dc61dd5756661e44411acccdb2fc0320a8984e5f0d2a7390fcc816bac7e0 WHIRLPOOL 02fd8fb5c5fd3b7287c69997eefdc6f46300eed0031b9ffa8ea545f9b31b4a33d5af9e5038216cd4f8a57103563f1bc6650e7bfce12fc82f07d4c49c2438a6b1
diff --git a/dev-ml/cppo/cppo-1.5.0.ebuild b/dev-ml/cppo/cppo-1.5.0.ebuild
new file mode 100644
index 000000000000..933faf0db619
--- /dev/null
+++ b/dev-ml/cppo/cppo-1.5.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+inherit findlib
+
+DESCRIPTION="An equivalent of the C preprocessor for OCaml programs"
+HOMEPAGE="http://mjambon.com/cppo.html https://github.com/mjambon/cppo/"
+SRC_URI="https://github.com/mjambon/cppo/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0/${PV}"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+
+IUSE="examples"
+
+RDEPEND=">=dev-lang/ocaml-3.12:=
+ dev-ml/ocamlbuild:="
+DEPEND="${RDEPEND}"
+
+src_install() {
+ findlib_src_preinst
+ mkdir -p "${ED}"/usr/bin
+ emake PREFIX="${ED}"/usr install
+ dodoc README.md Changes
+ if use examples ; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}