summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-10-15 18:34:26 +1300
committerKent Fredric <kentnl@gentoo.org>2017-10-15 18:34:26 +1300
commit3f891881099584e9f4abaddc4765ba127d54cd4a (patch)
tree509116a46f4097840b314af255c1240b5be01a5e /dev-perl/Bio-Das/Bio-Das-1.170.0-r2.ebuild
parentdev-perl/Data-Dump-Streamer: Cleanup old re bug #615698 (diff)
downloadgentoo-3f891881099584e9f4abaddc4765ba127d54cd4a.tar.gz
gentoo-3f891881099584e9f4abaddc4765ba127d54cd4a.tar.bz2
gentoo-3f891881099584e9f4abaddc4765ba127d54cd4a.zip
dev-perl/Bio-Das: Fix tests w/o CGI-pm
- Fence optional deps for CGI.pm - Add USE="examples" Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'dev-perl/Bio-Das/Bio-Das-1.170.0-r2.ebuild')
-rw-r--r--dev-perl/Bio-Das/Bio-Das-1.170.0-r2.ebuild22
1 files changed, 21 insertions, 1 deletions
diff --git a/dev-perl/Bio-Das/Bio-Das-1.170.0-r2.ebuild b/dev-perl/Bio-Das/Bio-Das-1.170.0-r2.ebuild
index 9637c477fa28..fbd25fa1e003 100644
--- a/dev-perl/Bio-Das/Bio-Das-1.170.0-r2.ebuild
+++ b/dev-perl/Bio-Das/Bio-Das-1.170.0-r2.ebuild
@@ -5,6 +5,7 @@ EAPI=6
DIST_AUTHOR=LDS
DIST_VERSION=1.17
+DIST_EXAMPLES=("eg/*")
inherit perl-module
DESCRIPTION="Interface to Distributed Annotation System"
@@ -20,11 +21,27 @@ DEPEND=">=virtual/perl-IO-Compress-1.0
>=virtual/perl-MIME-Base64-2.12"
RDEPEND="${DEPEND}"
+optdep_notice() {
+ local i
+ elog "This package has several modules which may require additional dependencies"
+ elog "to use. However, it is up to you to install them separately if you need this"
+ elog "optional functionality:"
+ elog
+ i="$(if has_version 'dev-perl/CGI'; then echo '[I]'; else echo '[ ]'; fi)"
+ elog " $i dev-perl/CGI"
+ elog " - Running a reference DAS server driven by an AGP File via"
+ elog " Bio::Das::AGPServer::Daemon"
+
+ if use test; then
+ elog
+ elog "This module will perform additional tests if these dependencies are"
+ elog "pre-installed"
+ fi
+}
src_test() {
local MODULES=(
"Bio::Das ${DIST_VERSION}"
"Bio::Das::AGPServer::Config 1.0"
- "Bio::Das::AGPServer::Daemon"
"Bio::Das::AGPServer::Parser"
"Bio::Das::AGPServer::SQLStorage"
"Bio::Das::AGPServer::SQLStorage::CSV::DB"
@@ -49,6 +66,9 @@ src_test() {
"Bio::Das::TypeHandler"
"Bio::Das::Util 0.01"
)
+ has_version dev-perl/CGI && MODULES+=(
+ "Bio::Das::AGPServer::Daemon"
+ )
local failed=()
for dep in "${MODULES[@]}"; do
ebegin "Compile testing ${dep}"