summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-perl/Class-InsideOut
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-perl/Class-InsideOut')
-rw-r--r--dev-perl/Class-InsideOut/Class-InsideOut-1.130.0-r1.ebuild36
-rw-r--r--dev-perl/Class-InsideOut/Manifest1
-rw-r--r--dev-perl/Class-InsideOut/metadata.xml9
3 files changed, 46 insertions, 0 deletions
diff --git a/dev-perl/Class-InsideOut/Class-InsideOut-1.130.0-r1.ebuild b/dev-perl/Class-InsideOut/Class-InsideOut-1.130.0-r1.ebuild
new file mode 100644
index 000000000000..bb74a80033ad
--- /dev/null
+++ b/dev-perl/Class-InsideOut/Class-InsideOut-1.130.0-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+MODULE_AUTHOR=DAGOLDEN
+MODULE_VERSION=1.13
+inherit perl-module
+
+DESCRIPTION='A safe, simple inside-out object construction kit'
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ virtual/perl-Carp
+ dev-perl/Class-ISA
+ virtual/perl-Exporter
+ >=virtual/perl-Scalar-List-Utils-1.90.0
+ virtual/perl-Storable
+"
+DEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.300.0
+ test? (
+ virtual/perl-File-Spec
+ virtual/perl-File-Temp
+ virtual/perl-IO
+ virtual/perl-Scalar-List-Utils
+ >=virtual/perl-Test-Simple-0.45
+ virtual/perl-XSLoader
+ virtual/perl-threads
+ )
+"
+
+SRC_TEST="do"
diff --git a/dev-perl/Class-InsideOut/Manifest b/dev-perl/Class-InsideOut/Manifest
new file mode 100644
index 000000000000..ef57fc91c672
--- /dev/null
+++ b/dev-perl/Class-InsideOut/Manifest
@@ -0,0 +1 @@
+DIST Class-InsideOut-1.13.tar.gz 46507 SHA256 11acd51c990ad7a73181f1d086526ab8c567d22ccdc75e4b5ffd7db9a2a5f108 SHA512 38175467338784d796ff90c8a0befefc4a4b7bafc6906a530a707eff8419b09b197bdfa2ea4a7012a5a8daf7992623001ff7f1fd45c6c5d5d5363c3919f53e73 WHIRLPOOL d8797b2f584501856d5e47e6c41373b761bfa2521df66ef78315f1fb1977079c76e106ba3844e435d393c358df012c1cb97005af88676ce36e0d8a9b938095bf
diff --git a/dev-perl/Class-InsideOut/metadata.xml b/dev-perl/Class-InsideOut/metadata.xml
new file mode 100644
index 000000000000..df2c11afe021
--- /dev/null
+++ b/dev-perl/Class-InsideOut/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <upstream>
+ <remote-id type="cpan">Class-InsideOut</remote-id>
+ <remote-id type="cpan-module">Class::InsideOut</remote-id>
+ </upstream>
+</pkgmetadata>