summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-10-05 18:30:55 +1300
committerKent Fredric <kentnl@gentoo.org>2017-10-06 00:03:09 +1300
commit4aadbf045debeb60a050f4dc3ec167925bba151f (patch)
treeb69025db90e7a00f4322045d82f84462f763a9df /dev-perl/Coro
parentmedia-libs/openjpeg: Bump to version 2.3.0 (diff)
downloadgentoo-4aadbf045debeb60a050f4dc3ec167925bba151f.tar.gz
gentoo-4aadbf045debeb60a050f4dc3ec167925bba151f.tar.bz2
gentoo-4aadbf045debeb60a050f4dc3ec167925bba151f.zip
dev-perl/Coro: Bump to version 6.514.0
- Patches all upstremed - Add USE="examples" - Fix automagic building of EV/Event Upstream: - Fixes for supporting API changes in Perl 5.22, 5.24, 5.26... - disable FORTIFY_SOURCE to avoid fortifed-but-broken longjmp in some libc's - Partially improved JIT allocation - Fixes for statevar types on newer perls - safe_cancel no longer croaks from already destroyed threads. Package-Manager: Portage-2.3.8, Repoman-2.3.3 dev-perl/Coro: fix automagic builds Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'dev-perl/Coro')
-rw-r--r--dev-perl/Coro/Coro-6.514.0.ebuild38
-rw-r--r--dev-perl/Coro/Manifest1
-rw-r--r--dev-perl/Coro/files/6.514.0-ev-config.patch74
-rw-r--r--dev-perl/Coro/metadata.xml4
4 files changed, 117 insertions, 0 deletions
diff --git a/dev-perl/Coro/Coro-6.514.0.ebuild b/dev-perl/Coro/Coro-6.514.0.ebuild
new file mode 100644
index 000000000000..5cbecd4664f6
--- /dev/null
+++ b/dev-perl/Coro/Coro-6.514.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=MLEHMANN
+DIST_VERSION=6.514
+DIST_EXAMPLES=( "eg/*" )
+inherit perl-module
+
+DESCRIPTION="The only real threads in perl"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+ev event"
+
+RDEPEND="
+ >=dev-perl/AnyEvent-5
+ ev? ( >=dev-perl/EV-4.0.0 )
+ event? ( >=dev-perl/Event-0.890.0 )
+ >=dev-perl/Guard-0.500.0
+ virtual/perl-Scalar-List-Utils
+ >=virtual/perl-Storable-2.150.0
+ dev-perl/common-sense
+"
+DEPEND="${RDEPEND}
+ dev-perl/Canary-Stability
+ >=virtual/perl-ExtUtils-MakeMaker-6.520.0
+"
+PATCHES=(
+ "${FILESDIR}/${PV}-ev-config.patch"
+)
+src_configure() {
+ local myopts=()
+ use ev && myopts+=("EV")
+ use event && myopts+=( "Event" )
+ GENTOO_OPTS="${myopts[@]}" perl-module_src_configure
+}
diff --git a/dev-perl/Coro/Manifest b/dev-perl/Coro/Manifest
index 59f0efd6346b..2daf92352231 100644
--- a/dev-perl/Coro/Manifest
+++ b/dev-perl/Coro/Manifest
@@ -1 +1,2 @@
DIST Coro-6.511.tar.gz 195173 SHA256 7e3ed48cdb3f3742d94ae3ab3d088c3ab818c521f8681da6c5f656bd49ac53ea SHA512 c3e591539e3313403496d3396e68147942e45590732bbaed7b3020fdc79e1e726c3addc3fc5d5d3e173c2b3faff4de2a9d0bae19f91cdc684285c2751b809681 WHIRLPOOL 3a56fca3116d1b2b6cd727078ebed9811aa627756c08c439ee6bceabba75117c904b692bf147f251dcd978abcf63e0d0f24e9ef068adf1592c4ff9539ae64daf
+DIST Coro-6.514.tar.gz 195122 SHA256 d83343839290a72db302a14b1ad86f0069f0bba6d45f947252d9db490edecd62 SHA512 340eea9bc2a33c40813f4852d3a12ff947426fd329a4867a36262a9ece936c9e43d36ba5e4355d1f8f91cb40690de3bb1637ab0b0651518c22fb17a34ee90b37 WHIRLPOOL 8a4f5c4e7e58698ac70dc6d958405e65f98675526637f1a329cc3f4e244d6d0b27b5bd1b30ea742619f98ea2d57d507745f75feb78c7906b2e3bbd792ae9baf5
diff --git a/dev-perl/Coro/files/6.514.0-ev-config.patch b/dev-perl/Coro/files/6.514.0-ev-config.patch
new file mode 100644
index 000000000000..7b775b557eda
--- /dev/null
+++ b/dev-perl/Coro/files/6.514.0-ev-config.patch
@@ -0,0 +1,74 @@
+From bada194851e0a6839f78e811bfc63c2d5e8877dc Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentnl@gentoo.org>
+Date: Thu, 5 Oct 2017 22:02:38 +1300
+Subject: Make EV/Event not auto-compiled, but rely on configuration
+
+---
+ Makefile.PL | 51 ++++++++++-----------------------------------------
+ 1 file changed, 10 insertions(+), 41 deletions(-)
+
+diff --git a/Makefile.PL b/Makefile.PL
+index e58e210..25243ff 100644
+--- a/Makefile.PL
++++ b/Makefile.PL
+@@ -17,47 +17,16 @@ EOF
+
+ print "*** *** *** *** *** *** *** *** *** *** *** *** *** *** *** *** *** ***\n\n";
+
+-if (eval { require Event }) {
+- if ($Event::VERSION < 0.86 or $Event::VERSION == 0.88) {
+- print <<EOF
+-
+-***
+-*** WARNING: Event version $Event::VERSION found, NOT building Event support.
+-***
+-*** This version of Event is broken. The only currently known non-broken
+-*** versions of Event are 0.87 and 0.89+. Please install one of those
+-*** versions.
+-***
+-
+-EOF
+- } else {
+- $EVENT = 1;
+- $DEFINE .= " -DHAVE_EVENT=1";
+- print "\nEvent version $Event::VERSION found, building Event support.\n\n";
+- }
+-} else {
+- print "\n*** Event not found, not building Event support.\n\n";
+-}
+-
+-if (eval { require EV }) {
+- if ($EV::VERSION < 4.0) {
+- print <<EOF
+-
+-***
+-*** WARNING: EV version $EV::VERSION found, NOT building EV support.
+-***
+-*** This version is ABI-incompatible with Coro, please upgrade to at least 4.0.
+-***
+-
+-EOF
+- } else {
+- $EV = 1;
+- $DEFINE .= " -DHAVE_EV=1";
+- print "\nEV version $EV::VERSION found, building EV support.\n\n";
+- }
+-} else {
+- print "\n*** EV not found, not building EV support.\n\n";
+-}
++$EVENT = ( $ENV{GENTOO_OPTS} =~ /\bEvent\b/ );
++$EV = ( $ENV{GENTOO_OPTS} =~ /\bEV\b/ );
++$EVENT and do {
++ require Event;
++ Event->VERSION(0.89);
++};
++$EV and do {
++ require EV;
++ EV->VERSION(4.0);
++};
+
+ WriteMakefile(
+ dist => {
+--
+2.14.1
+
diff --git a/dev-perl/Coro/metadata.xml b/dev-perl/Coro/metadata.xml
index 9595d5b9e4cf..b9f208cf2546 100644
--- a/dev-perl/Coro/metadata.xml
+++ b/dev-perl/Coro/metadata.xml
@@ -5,6 +5,10 @@
<email>perl@gentoo.org</email>
<name>Gentoo Perl Project</name>
</maintainer>
+ <use>
+ <flag name="ev">Build support for using <pkg>dev-perl/EV</pkg> as an event-loop via Coro::EV</flag>
+ <flag name="event">Build support for using <pkg>dev-perl/Event</pkg> as an event-loop via Coro::Event</flag>
+ </use>
<upstream>
<remote-id type="cpan">Coro</remote-id>
<remote-id type="cpan-module">Coro</remote-id>