summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-06-20 08:25:33 +1200
committerKent Fredric <kentnl@gentoo.org>2017-06-20 08:29:11 +1200
commit21e52ef28c4eeab96f2146bafcdb40dc6e1a74b1 (patch)
treeb9942db13cd57a08d67a3d6fa8cc7d58e2a03c73 /dev-perl/Crypt-SSLeay
parentsys-apps/nix: bump up to 1.11.11 (diff)
downloadgentoo-21e52ef28c4eeab96f2146bafcdb40dc6e1a74b1.tar.gz
gentoo-21e52ef28c4eeab96f2146bafcdb40dc6e1a74b1.tar.bz2
gentoo-21e52ef28c4eeab96f2146bafcdb40dc6e1a74b1.zip
dev-perl/Crypt-SSLeay: Fix for '.' in @INC re bug #615126
Hand-spun patch because the alternatives appearing upstream are frankly nuts and combine 2 types of wrong to do things that nobody needs to do. Bug: https://bugs.gentoo.org/615126 Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-perl/Crypt-SSLeay')
-rw-r--r--dev-perl/Crypt-SSLeay/Crypt-SSLeay-0.720.0-r1.ebuild2
-rw-r--r--dev-perl/Crypt-SSLeay/Crypt-SSLeay-0.720.0-r2.ebuild3
-rw-r--r--dev-perl/Crypt-SSLeay/files/Crypt-SSLeay-0.720.0-no-dot-inc.patch27
3 files changed, 30 insertions, 2 deletions
diff --git a/dev-perl/Crypt-SSLeay/Crypt-SSLeay-0.720.0-r1.ebuild b/dev-perl/Crypt-SSLeay/Crypt-SSLeay-0.720.0-r1.ebuild
index c73f9942ad0b..74a59504087c 100644
--- a/dev-perl/Crypt-SSLeay/Crypt-SSLeay-0.720.0-r1.ebuild
+++ b/dev-perl/Crypt-SSLeay/Crypt-SSLeay-0.720.0-r1.ebuild
@@ -34,7 +34,7 @@ PDEPEND="
dev-perl/libwww-perl
>=dev-perl/LWP-Protocol-https-6.20.0
"
-
+PATCHES=("${FILESDIR}/${P}-no-dot-inc.patch")
export OPTIMIZE="${CFLAGS}"
#myconf="--lib=${EPREFIX}/usr"
diff --git a/dev-perl/Crypt-SSLeay/Crypt-SSLeay-0.720.0-r2.ebuild b/dev-perl/Crypt-SSLeay/Crypt-SSLeay-0.720.0-r2.ebuild
index 05331fb8687f..73bfd20fbcf2 100644
--- a/dev-perl/Crypt-SSLeay/Crypt-SSLeay-0.720.0-r2.ebuild
+++ b/dev-perl/Crypt-SSLeay/Crypt-SSLeay-0.720.0-r2.ebuild
@@ -36,4 +36,5 @@ PDEPEND="
>=dev-perl/LWP-Protocol-https-6.20.0
"
-PATCHES=( "${FILESDIR}"/${PN}-0.720.0-no-ssl3.patch )
+PATCHES=( "${FILESDIR}"/${PN}-0.720.0-no-ssl3.patch
+ "${FILESDIR}/${P}-no-dot-inc.patch" )
diff --git a/dev-perl/Crypt-SSLeay/files/Crypt-SSLeay-0.720.0-no-dot-inc.patch b/dev-perl/Crypt-SSLeay/files/Crypt-SSLeay-0.720.0-no-dot-inc.patch
new file mode 100644
index 000000000000..9ea1c6b8f6dd
--- /dev/null
+++ b/dev-perl/Crypt-SSLeay/files/Crypt-SSLeay-0.720.0-no-dot-inc.patch
@@ -0,0 +1,27 @@
+From: Kent Fredric <kentfredric@gmail.com>
+Date: Tue, 20 Jun 2017 08:04:39 +1200
+Subject: [PATCH] Remove need for '.' in @INC
+
+https://github.com/nanis/Crypt-SSLeay/pull/7
+
+---
+ Makefile.PL | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/Makefile.PL b/Makefile.PL
+index fcc3a7d..937789a 100644
+--- a/Makefile.PL
++++ b/Makefile.PL
+@@ -8,7 +8,8 @@ use Getopt::Long qw( GetOptionsFromArray );
+ use Path::Class;
+ use Try::Tiny;
+
+-use inc::IO::Interactive::Tiny;
++use lib 'inc';
++use IO::Interactive::Tiny;
+
+ caller
+ or run(\@ARGV, [qw{ssl crypto ssl32 ssleay32 eay32 libeay32 z}]);
+--
+2.13.1
+