summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-06-11 05:32:10 +1200
committerKent Fredric <kentnl@gentoo.org>2017-06-11 06:31:55 +1200
commit1bc4c8bb8aebffe75e54c261e115080498143cc6 (patch)
tree3aa15974b3827614383566200b952e60f2a72263 /dev-perl/DBD-mysql
parentdev-util/valgrind: remove older versions, bug #618382 (diff)
downloadgentoo-1bc4c8bb8aebffe75e54c261e115080498143cc6.tar.gz
gentoo-1bc4c8bb8aebffe75e54c261e115080498143cc6.tar.bz2
gentoo-1bc4c8bb8aebffe75e54c261e115080498143cc6.zip
dev-perl/DBD-mysql: Fix tests for '.' in @INC re bug #613608
Apply modified patche(s) from upstream to fix dependency on '.' in @INC during tests. Bug: https://bugs.gentoo.org/613608 Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-perl/DBD-mysql')
-rw-r--r--dev-perl/DBD-mysql/DBD-mysql-4.41.0.ebuild2
-rw-r--r--dev-perl/DBD-mysql/DBD-mysql-4.42.0.ebuild2
-rw-r--r--dev-perl/DBD-mysql/files/4.041-no-dot-inc.patch103
-rw-r--r--dev-perl/DBD-mysql/files/4.042-no-dot-inc.patch178
4 files changed, 283 insertions, 2 deletions
diff --git a/dev-perl/DBD-mysql/DBD-mysql-4.41.0.ebuild b/dev-perl/DBD-mysql/DBD-mysql-4.41.0.ebuild
index 928fc38218fb..25b0b306ccc8 100644
--- a/dev-perl/DBD-mysql/DBD-mysql-4.41.0.ebuild
+++ b/dev-perl/DBD-mysql/DBD-mysql-4.41.0.ebuild
@@ -30,7 +30,7 @@ DEPEND="${RDEPEND}
virtual/perl-Time-HiRes
)
"
-
+PATCHES=( "${FILESDIR}/${DIST_VERSION}-no-dot-inc.patch" )
src_configure() {
if use test; then
myconf="${myconf} --testdb=test \
diff --git a/dev-perl/DBD-mysql/DBD-mysql-4.42.0.ebuild b/dev-perl/DBD-mysql/DBD-mysql-4.42.0.ebuild
index 91fa6f7a5e09..2e632cb8f4a7 100644
--- a/dev-perl/DBD-mysql/DBD-mysql-4.42.0.ebuild
+++ b/dev-perl/DBD-mysql/DBD-mysql-4.42.0.ebuild
@@ -31,7 +31,7 @@ DEPEND="${RDEPEND}
virtual/perl-Time-HiRes
)
"
-
+PATCHES=( "${FILESDIR}/${DIST_VERSION}-no-dot-inc.patch" )
src_configure() {
if use test; then
myconf="${myconf} --testdb=test \
diff --git a/dev-perl/DBD-mysql/files/4.041-no-dot-inc.patch b/dev-perl/DBD-mysql/files/4.041-no-dot-inc.patch
new file mode 100644
index 000000000000..f26837f548a8
--- /dev/null
+++ b/dev-perl/DBD-mysql/files/4.041-no-dot-inc.patch
@@ -0,0 +1,103 @@
+From 497224cad8b6469913c61ee856228bc1d0280980 Mon Sep 17 00:00:00 2001
+From: Pali <pali@cpan.org>
+Date: Mon, 17 Apr 2017 21:38:58 +0200
+Subject: [PATCH] Fix tests on Perl On 5.25.10 or greater with
+ -Ddefault_inc_excludes_dot
+
+Some tests do not include dot in %INC and fails with error:
+Can't locate t/lib.pl in @INC
+
+Fixes: https://rt.cpan.org/Public/Bug/Display.html?id=120709
+---
+ t/40server_prepare_crash.t | 3 ++-
+ t/rt25389-bin-case.t | 3 ++-
+ t/rt50304-column_info_parentheses.t | 3 ++-
+ t/rt61849-bind-param-buffer-overflow.t | 3 ++-
+ t/rt75353-innodb-lock-timeout.t | 3 ++-
+ t/rt83494-quotes-comments.t | 3 ++-
+ 11 files changed, 22 insertions(+), 11 deletions(-)
+
+diff --git a/t/40server_prepare_crash.t b/t/40server_prepare_crash.t
+index e3777b9..d04eb9c 100644
+--- a/t/40server_prepare_crash.t
++++ b/t/40server_prepare_crash.t
+@@ -5,7 +5,8 @@ use Test::More;
+ use DBI;
+
+ use vars qw($test_dsn $test_user $test_password);
+-require "t/lib.pl";
++use lib 't', '.';
++require "lib.pl";
+
+ my $dbh = DbiTestConnect($test_dsn, $test_user, $test_password, { PrintError => 1, RaiseError => 1, AutoCommit => 0, mysql_server_prepare => 1, mysql_server_prepare_disable_fallback => 1 });
+ plan skip_all => "You must have MySQL version 4.1.3 and greater for this test to run" if $dbh->{mysql_clientversion} < 40103 or $dbh->{mysql_serverversion} < 40103;
+diff --git a/t/rt25389-bin-case.t b/t/rt25389-bin-case.t
+index cbda8b7..3aee41b 100644
+--- a/t/rt25389-bin-case.t
++++ b/t/rt25389-bin-case.t
+@@ -4,7 +4,8 @@ use warnings;
+ use DBI;
+
+ use vars qw($test_dsn $test_user $test_password);
+-require "t/lib.pl";
++use lib 't', '.';
++require "lib.pl";
+
+ use Test::More;
+
+diff --git a/t/rt50304-column_info_parentheses.t b/t/rt50304-column_info_parentheses.t
+index 76f9eff..6c3aac5 100644
+--- a/t/rt50304-column_info_parentheses.t
++++ b/t/rt50304-column_info_parentheses.t
+@@ -4,7 +4,8 @@ use warnings;
+ use DBI;
+
+ use vars qw($test_dsn $test_user $test_password $state);
+-require "t/lib.pl";
++use lib 't', '.';
++require "lib.pl";
+
+ use Test::More;
+
+diff --git a/t/rt61849-bind-param-buffer-overflow.t b/t/rt61849-bind-param-buffer-overflow.t
+index 82baf2f..a3c75de 100644
+--- a/t/rt61849-bind-param-buffer-overflow.t
++++ b/t/rt61849-bind-param-buffer-overflow.t
+@@ -5,7 +5,8 @@ use Test::More;
+ use DBI;
+
+ use vars qw($test_dsn $test_user $test_password);
+-require "t/lib.pl";
++use lib 't', '.';
++require "lib.pl";
+
+ my $INSECURE_VALUE_FROM_USER = "xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx";
+
+diff --git a/t/rt75353-innodb-lock-timeout.t b/t/rt75353-innodb-lock-timeout.t
+index a1f437d..95694db 100644
+--- a/t/rt75353-innodb-lock-timeout.t
++++ b/t/rt75353-innodb-lock-timeout.t
+@@ -5,7 +5,8 @@ use Test::More;
+ use DBI;
+
+ use vars qw($test_dsn $test_user $test_password);
+-require "t/lib.pl";
++use lib 't', '.';
++require "lib.pl";
+
+ my $dbh1 = DbiTestConnect($test_dsn, $test_user, $test_password, { RaiseError => 1, AutoCommit => 0 });
+
+diff --git a/t/rt83494-quotes-comments.t b/t/rt83494-quotes-comments.t
+index c48b0b9..83919f2 100644
+--- a/t/rt83494-quotes-comments.t
++++ b/t/rt83494-quotes-comments.t
+@@ -9,7 +9,8 @@ use DBI;
+ use Test::More;
+
+ use vars qw($test_dsn $test_user $test_password $state);
+-require "t/lib.pl";
++use lib 't', '.';
++require "lib.pl";
+
+ my $dbh = DbiTestConnect($test_dsn, $test_user, $test_password,
+ { RaiseError => 1, PrintError => 0, AutoCommit => 0 });
diff --git a/dev-perl/DBD-mysql/files/4.042-no-dot-inc.patch b/dev-perl/DBD-mysql/files/4.042-no-dot-inc.patch
new file mode 100644
index 000000000000..274605c44c7d
--- /dev/null
+++ b/dev-perl/DBD-mysql/files/4.042-no-dot-inc.patch
@@ -0,0 +1,178 @@
+From 497224cad8b6469913c61ee856228bc1d0280980 Mon Sep 17 00:00:00 2001
+From: Pali <pali@cpan.org>
+Date: Mon, 17 Apr 2017 21:38:58 +0200
+Subject: [PATCH] Fix tests on Perl On 5.25.10 or greater with
+ -Ddefault_inc_excludes_dot
+
+Some tests do not include dot in %INC and fails with error:
+Can't locate t/lib.pl in @INC
+
+Fixes: https://rt.cpan.org/Public/Bug/Display.html?id=120709
+---
+ t/40server_prepare_crash.t | 3 ++-
+ t/55utf8_jp.t | 3 ++-
+ t/cve-2017-3302.t | 3 ++-
+ t/magic.t | 3 ++-
+ t/rt110983-valid-mysqlfd.t | 3 ++-
+ t/rt118977-zerofill.t | 3 ++-
+ t/rt25389-bin-case.t | 3 ++-
+ t/rt50304-column_info_parentheses.t | 3 ++-
+ t/rt61849-bind-param-buffer-overflow.t | 3 ++-
+ t/rt75353-innodb-lock-timeout.t | 3 ++-
+ t/rt83494-quotes-comments.t | 3 ++-
+ 11 files changed, 22 insertions(+), 11 deletions(-)
+
+diff --git a/t/40server_prepare_crash.t b/t/40server_prepare_crash.t
+index e3777b9..d04eb9c 100644
+--- a/t/40server_prepare_crash.t
++++ b/t/40server_prepare_crash.t
+@@ -5,7 +5,8 @@ use Test::More;
+ use DBI;
+
+ use vars qw($test_dsn $test_user $test_password);
+-require "t/lib.pl";
++use lib 't', '.';
++require "lib.pl";
+
+ my $dbh = DbiTestConnect($test_dsn, $test_user, $test_password, { PrintError => 1, RaiseError => 1, AutoCommit => 0, mysql_server_prepare => 1, mysql_server_prepare_disable_fallback => 1 });
+ plan skip_all => "You must have MySQL version 4.1.3 and greater for this test to run" if $dbh->{mysql_clientversion} < 40103 or $dbh->{mysql_serverversion} < 40103;
+diff --git a/t/55utf8_jp.t b/t/55utf8_jp.t
+index 638d494..88874c3 100644
+--- a/t/55utf8_jp.t
++++ b/t/55utf8_jp.t
+@@ -6,7 +6,8 @@ use DBI;
+ use Encode;
+
+ use vars qw($test_dsn $test_user $test_password);
+-require "t/lib.pl";
++use lib 't', '.';
++require "lib.pl";
+
+ my $dbh = DbiTestConnect($test_dsn, $test_user, $test_password, { mysql_enable_utf8 => 1, PrintError => 1, RaiseError => 1 });
+
+diff --git a/t/cve-2017-3302.t b/t/cve-2017-3302.t
+index b2de927..fbca0e3 100644
+--- a/t/cve-2017-3302.t
++++ b/t/cve-2017-3302.t
+@@ -6,7 +6,8 @@ if ($ENV{SKIP_CRASH_TESTING}) {
+ no warnings 'once';
+ use DBI;
+ use vars qw($test_dsn $test_user $test_password $test_db);
+-require "t/lib.pl";
++use lib 't', '.';
++require "lib.pl";
+ eval {
+ $dbh = DBI->connect($test_dsn, $test_user, $test_password, {RaiseError => 1, mysql_server_prepare => 1});
+ } or do {
+diff --git a/t/magic.t b/t/magic.t
+index 2720655..a7978a4 100644
+--- a/t/magic.t
++++ b/t/magic.t
+@@ -5,7 +5,8 @@ use Test::More;
+ use DBI;
+
+ use vars qw($test_dsn $test_user $test_password);
+-require "t/lib.pl";
++use lib 't', '.';
++require "lib.pl";
+
+ my $tb = Test::More->builder;
+ binmode $tb->failure_output, ":utf8";
+diff --git a/t/rt110983-valid-mysqlfd.t b/t/rt110983-valid-mysqlfd.t
+index ad59762..12dace7 100644
+--- a/t/rt110983-valid-mysqlfd.t
++++ b/t/rt110983-valid-mysqlfd.t
+@@ -5,7 +5,8 @@ use Test::More;
+ use DBI;
+
+ use vars qw($test_dsn $test_user $test_password);
+-require "t/lib.pl";
++use lib 't', '.';
++require "lib.pl";
+
+ my $dbh = DbiTestConnect($test_dsn, $test_user, $test_password, { RaiseError => 1, AutoCommit => 0 });
+
+diff --git a/t/rt118977-zerofill.t b/t/rt118977-zerofill.t
+index 1992c4c..328766b 100644
+--- a/t/rt118977-zerofill.t
++++ b/t/rt118977-zerofill.t
+@@ -5,7 +5,8 @@ use Test::More;
+ use DBI;
+
+ use vars qw($test_dsn $test_user $test_password);
+-require "t/lib.pl";
++use lib 't', '.';
++require "lib.pl";
+
+ my $dbh = DbiTestConnect($test_dsn, $test_user, $test_password, { PrintError => 1, RaiseError => 1 });
+
+diff --git a/t/rt25389-bin-case.t b/t/rt25389-bin-case.t
+index cbda8b7..3aee41b 100644
+--- a/t/rt25389-bin-case.t
++++ b/t/rt25389-bin-case.t
+@@ -4,7 +4,8 @@ use warnings;
+ use DBI;
+
+ use vars qw($test_dsn $test_user $test_password);
+-require "t/lib.pl";
++use lib 't', '.';
++require "lib.pl";
+
+ use Test::More;
+
+diff --git a/t/rt50304-column_info_parentheses.t b/t/rt50304-column_info_parentheses.t
+index 76f9eff..6c3aac5 100644
+--- a/t/rt50304-column_info_parentheses.t
++++ b/t/rt50304-column_info_parentheses.t
+@@ -4,7 +4,8 @@ use warnings;
+ use DBI;
+
+ use vars qw($test_dsn $test_user $test_password $state);
+-require "t/lib.pl";
++use lib 't', '.';
++require "lib.pl";
+
+ use Test::More;
+
+diff --git a/t/rt61849-bind-param-buffer-overflow.t b/t/rt61849-bind-param-buffer-overflow.t
+index 82baf2f..a3c75de 100644
+--- a/t/rt61849-bind-param-buffer-overflow.t
++++ b/t/rt61849-bind-param-buffer-overflow.t
+@@ -5,7 +5,8 @@ use Test::More;
+ use DBI;
+
+ use vars qw($test_dsn $test_user $test_password);
+-require "t/lib.pl";
++use lib 't', '.';
++require "lib.pl";
+
+ my $INSECURE_VALUE_FROM_USER = "xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx";
+
+diff --git a/t/rt75353-innodb-lock-timeout.t b/t/rt75353-innodb-lock-timeout.t
+index a1f437d..95694db 100644
+--- a/t/rt75353-innodb-lock-timeout.t
++++ b/t/rt75353-innodb-lock-timeout.t
+@@ -5,7 +5,8 @@ use Test::More;
+ use DBI;
+
+ use vars qw($test_dsn $test_user $test_password);
+-require "t/lib.pl";
++use lib 't', '.';
++require "lib.pl";
+
+ my $dbh1 = DbiTestConnect($test_dsn, $test_user, $test_password, { RaiseError => 1, AutoCommit => 0 });
+
+diff --git a/t/rt83494-quotes-comments.t b/t/rt83494-quotes-comments.t
+index c48b0b9..83919f2 100644
+--- a/t/rt83494-quotes-comments.t
++++ b/t/rt83494-quotes-comments.t
+@@ -9,7 +9,8 @@ use DBI;
+ use Test::More;
+
+ use vars qw($test_dsn $test_user $test_password $state);
+-require "t/lib.pl";
++use lib 't', '.';
++require "lib.pl";
+
+ my $dbh = DbiTestConnect($test_dsn, $test_user, $test_password,
+ { RaiseError => 1, PrintError => 0, AutoCommit => 0 });