summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-09-28 03:01:45 +0100
committerSam James <sam@gentoo.org>2023-09-28 03:01:45 +0100
commit20da821e358921a833fd1227ee3fe6c730bf750f (patch)
tree5ebecf16a8ecfea803dbc0c71501dfd2fe2ea49e /dev-perl/File-Find-Object-Rule/File-Find-Object-Rule-0.31.300-r1.ebuild
parentdev-libs/rinutils: Keyword 0.10.2-r1 hppa, #909051 (diff)
downloadgentoo-20da821e358921a833fd1227ee3fe6c730bf750f.tar.gz
gentoo-20da821e358921a833fd1227ee3fe6c730bf750f.tar.bz2
gentoo-20da821e358921a833fd1227ee3fe6c730bf750f.zip
dev-perl/File-Find-Object-Rule: drop unnecessary dev-perl/PathTools dep
PathTools is within Perl's core (dist/) and is better maintained in there with e.g. Perl 5.38 fixes. We should last-rite PathTools. (Note that the version of CPAN isn't updated.) Bug: https://bugs.gentoo.org/911168 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-perl/File-Find-Object-Rule/File-Find-Object-Rule-0.31.300-r1.ebuild')
-rw-r--r--dev-perl/File-Find-Object-Rule/File-Find-Object-Rule-0.31.300-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-perl/File-Find-Object-Rule/File-Find-Object-Rule-0.31.300-r1.ebuild b/dev-perl/File-Find-Object-Rule/File-Find-Object-Rule-0.31.300-r1.ebuild
new file mode 100644
index 000000000000..a0606cd921cb
--- /dev/null
+++ b/dev-perl/File-Find-Object-Rule/File-Find-Object-Rule-0.31.300-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR="SHLOMIF"
+DIST_VERSION="0.0313"
+inherit perl-module
+
+DESCRIPTION="Alternative interface to File::Find::Object"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ virtual/perl-Carp
+ dev-perl/Class-XSAccessor
+ dev-perl/File-Find-Object
+ dev-perl/Number-Compare
+ dev-perl/Text-Glob
+"
+BDEPEND="
+ ${RDEPEND}
+ >=dev-perl/Module-Build-0.280.0
+ test? (
+ virtual/perl-File-Path
+ dev-perl/File-TreeCreate
+ virtual/perl-IO
+ )
+"