summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-perl/File-Map
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-perl/File-Map')
-rw-r--r--dev-perl/File-Map/File-Map-0.560.0.ebuild30
-rw-r--r--dev-perl/File-Map/File-Map-0.610.0.ebuild30
-rw-r--r--dev-perl/File-Map/File-Map-0.630.0.ebuild36
-rw-r--r--dev-perl/File-Map/Manifest3
-rw-r--r--dev-perl/File-Map/metadata.xml13
5 files changed, 112 insertions, 0 deletions
diff --git a/dev-perl/File-Map/File-Map-0.560.0.ebuild b/dev-perl/File-Map/File-Map-0.560.0.ebuild
new file mode 100644
index 000000000000..7cbce2fce9c3
--- /dev/null
+++ b/dev-perl/File-Map/File-Map-0.560.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=LEONT
+MODULE_VERSION=0.56
+inherit perl-module
+
+DESCRIPTION="Memory mapping made simple and safe"
+
+SLOT="0"
+KEYWORDS="amd64 arm ppc x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ dev-perl/Const-Fast
+ dev-perl/PerlIO-Layers
+ >=dev-perl/Sub-Exporter-Progressive-0.1.5
+"
+DEPEND="${RDEPEND}
+ dev-perl/Module-Build
+ test? (
+ dev-perl/Test-Exception
+ dev-perl/Test-NoWarnings
+ dev-perl/Test-Warn
+ )
+"
+SRC_TEST=do
diff --git a/dev-perl/File-Map/File-Map-0.610.0.ebuild b/dev-perl/File-Map/File-Map-0.610.0.ebuild
new file mode 100644
index 000000000000..d1d477fcd411
--- /dev/null
+++ b/dev-perl/File-Map/File-Map-0.610.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=LEONT
+MODULE_VERSION=0.61
+inherit perl-module
+
+DESCRIPTION="Memory mapping made simple and safe"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ dev-perl/Const-Fast
+ dev-perl/PerlIO-Layers
+ >=dev-perl/Sub-Exporter-Progressive-0.1.5
+"
+DEPEND="${RDEPEND}
+ dev-perl/Module-Build
+ test? (
+ dev-perl/Test-Exception
+ dev-perl/Test-NoWarnings
+ dev-perl/Test-Warn
+ )
+"
+SRC_TEST=do
diff --git a/dev-perl/File-Map/File-Map-0.630.0.ebuild b/dev-perl/File-Map/File-Map-0.630.0.ebuild
new file mode 100644
index 000000000000..69cdc4495971
--- /dev/null
+++ b/dev-perl/File-Map/File-Map-0.630.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=LEONT
+MODULE_VERSION=0.63
+inherit perl-module
+
+DESCRIPTION="Memory mapping made simple and safe"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ virtual/perl-Carp
+ dev-perl/PerlIO-Layers
+ >=dev-perl/Sub-Exporter-Progressive-0.1.5
+ virtual/perl-XSLoader
+"
+DEPEND="${RDEPEND}
+ >=dev-perl/Module-Build-0.360.100
+ test? (
+ virtual/perl-File-Spec
+ virtual/perl-IO
+ virtual/perl-Scalar-List-Utils
+ dev-perl/Test-Fatal
+ virtual/perl-Test-Simple
+ >=dev-perl/Test-Warnings-0.5.0
+ virtual/perl-Time-HiRes
+ )
+"
+
+SRC_TEST="do parallel"
diff --git a/dev-perl/File-Map/Manifest b/dev-perl/File-Map/Manifest
new file mode 100644
index 000000000000..8ee50e5dfbd4
--- /dev/null
+++ b/dev-perl/File-Map/Manifest
@@ -0,0 +1,3 @@
+DIST File-Map-0.56.tar.gz 73947 SHA256 960d614c038e2fb74d4a14543b82e6158d7d7e296a3acbe6a683c3280c73e535 SHA512 e9ab48c525fde25207866e69894c0ffa4e71bd213f5dd39e1b423ace62376c10c83c862693d84860b91e57cea4c275dc0f7f52650f32ad5e3087feb6b6312d68 WHIRLPOOL 9fe0ace81d5f28958984860a70c0497e879cd9c7e5945658041ef1ec10199fc4050f80b26e328480d127471314fe342c9911a6f15b783bae62c935b05d2cdc99
+DIST File-Map-0.61.tar.gz 74315 SHA256 b3bf7d3de1a4bafe1b67928986e00351d3b1b15f8417086d71048e4a7d8815b2 SHA512 ee5da6b777e5e85beeab33e4df4780e0096bac8ab26862b328126935634a4ccff667c1277698a9ed7219c34ac13315f783148062c3553fb57d1b40396bf0771b WHIRLPOOL c46ad0f8a5929ca102e563a186dfe1f3dabd98b0e254dcfdc5492d8be4afdd51a971f81a53c456c4f7c953e21d95723b499902fc42435cf2e5f522386696fb38
+DIST File-Map-0.63.tar.gz 76363 SHA256 1c30716a66a4be27ca8905506a251907bf8f6fa30a902e095eb6b2495482ad50 SHA512 7d84791381a3ad740fd4d1008ee2c18dcb16f75d3e6c2f283278e3157cd00e4288161aa2bd74c08e577964cd250da8b650b573d66527622897754f1fb28e9359 WHIRLPOOL 195978544875ca6ca34ea30dd3fd899920e60e8f0547f4945d92ec5b3944d93d57446d4a93ab1c92ae57ff8536a4623e238c1e02af9263174bb938661863123c
diff --git a/dev-perl/File-Map/metadata.xml b/dev-perl/File-Map/metadata.xml
new file mode 100644
index 000000000000..eb9dc383bb65
--- /dev/null
+++ b/dev-perl/File-Map/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<herd>perl</herd>
+<longdescription lang="en">
+ File::Map maps files or anonymous memory into perl variables.
+</longdescription>
+<upstream>
+ <remote-id type="cpan">File-Map</remote-id>
+ <remote-id type="cpan-module">File::Map</remote-id>
+</upstream>
+</pkgmetadata>