summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-09-09 08:59:59 +0100
committerSam James <sam@gentoo.org>2023-09-09 09:07:37 +0100
commit2bed4de848f1baff2736ae334c68a3dda64510c0 (patch)
tree90ab1036beeff69cea5adfaa16b5dc00021f8ce9 /dev-perl/Glib-Object-Introspection/Glib-Object-Introspection-0.51.0.ebuild
parentdev-perl/Email-Abstract: add 3.10.0 (diff)
downloadgentoo-2bed4de848f1baff2736ae334c68a3dda64510c0.tar.gz
gentoo-2bed4de848f1baff2736ae334c68a3dda64510c0.tar.bz2
gentoo-2bed4de848f1baff2736ae334c68a3dda64510c0.zip
dev-perl/Glib-Object-Introspection: add 0.51.0
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-perl/Glib-Object-Introspection/Glib-Object-Introspection-0.51.0.ebuild')
-rw-r--r--dev-perl/Glib-Object-Introspection/Glib-Object-Introspection-0.51.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-perl/Glib-Object-Introspection/Glib-Object-Introspection-0.51.0.ebuild b/dev-perl/Glib-Object-Introspection/Glib-Object-Introspection-0.51.0.ebuild
new file mode 100644
index 000000000000..2683fe8a0478
--- /dev/null
+++ b/dev-perl/Glib-Object-Introspection/Glib-Object-Introspection-0.51.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=XAOC
+DIST_VERSION=0.051
+inherit perl-module xdg-utils
+
+DESCRIPTION="Dynamically create Perl language bindings"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-perl/glib-perl-1.320.0
+ >=dev-libs/gobject-introspection-1.0
+ >=dev-libs/libffi-3.0.0:=
+ >=dev-libs/glib-2.0.0
+"
+DEPEND="
+ ${RDEPEND}
+"
+BDEPEND="
+ ${RDEPEND}
+ >=dev-perl/ExtUtils-Depends-0.300.0
+ >=dev-perl/ExtUtils-PkgConfig-1.0.0
+"
+
+pkg_setup() {
+ # bug #599128
+ xdg_environment_reset
+}