summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentfredric@gmail.com>2016-02-22 13:10:54 +1300
committerKent Fredric <kentfredric@gmail.com>2016-02-27 21:39:56 +1300
commit560d030c1c4eb83d3bdcc354a8b980f3a36dbaae (patch)
tree96558b08cdd5e8fab043b8eabb2b74a07b21205c /dev-perl/Mail-IMAPClient
parentdev-perl/Mail-Builder: Bump to version 2.90.0 (diff)
downloadgentoo-560d030c1c4eb83d3bdcc354a8b980f3a36dbaae.tar.gz
gentoo-560d030c1c4eb83d3bdcc354a8b980f3a36dbaae.tar.bz2
gentoo-560d030c1c4eb83d3bdcc354a8b980f3a36dbaae.zip
dev-perl/Mail-IMAPClient: Bump to version 3.380.0
- Use EAPI6 - Patched to prune garbage checks and waits in Makefile.PL - Nuked tests that require an IMAP server manually configured by way of test.txt in root - Dropped a few keywords: - ~arm, ~ia64, ~ppc64, ~sparc is missing in Authen-NTLM Package-Manager: portage-2.2.27
Diffstat (limited to 'dev-perl/Mail-IMAPClient')
-rw-r--r--dev-perl/Mail-IMAPClient/Mail-IMAPClient-3.380.0.ebuild47
-rw-r--r--dev-perl/Mail-IMAPClient/Manifest1
-rw-r--r--dev-perl/Mail-IMAPClient/files/3.38-makefilepl.patch89
-rw-r--r--dev-perl/Mail-IMAPClient/metadata.xml6
4 files changed, 143 insertions, 0 deletions
diff --git a/dev-perl/Mail-IMAPClient/Mail-IMAPClient-3.380.0.ebuild b/dev-perl/Mail-IMAPClient/Mail-IMAPClient-3.380.0.ebuild
new file mode 100644
index 000000000000..197eee9d535d
--- /dev/null
+++ b/dev-perl/Mail-IMAPClient/Mail-IMAPClient-3.380.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DIST_AUTHOR=PLOBBES
+DIST_VERSION=3.38
+inherit perl-module
+
+DESCRIPTION="IMAP client module for Perl"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~s390 ~sh ~x86"
+IUSE="test ntlm md5 ssl zlib"
+
+PATCHES=(
+ "${FILESDIR}/${DIST_VERSION}-makefilepl.patch"
+)
+PERL_RM_FILES=(
+ "t/quota.t" # Requires imap server config in test.txt
+ "t/basic.t"
+)
+# IO::File, IO::Select, IO::Socket, IO::Socket::INET -> perl-IO
+# Digest::HMAC_MD5 -> Digest-HMAC
+RDEPEND="
+ virtual/perl-Carp
+ virtual/perl-File-Temp
+ >=virtual/perl-IO-1.260.0
+ virtual/perl-Scalar-List-Utils
+ virtual/perl-MIME-Base64
+ >=dev-perl/Parse-RecDescent-1.967.9
+ ntlm? ( dev-perl/Authen-NTLM )
+ md5? (
+ dev-perl/Authen-SASL
+ dev-perl/Digest-HMAC
+ virtual/perl-Digest-MD5
+ )
+ ssl? ( dev-perl/IO-Socket-SSL )
+ zlib? ( virtual/perl-IO-Compress )
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-Test-Simple
+ )
+"
diff --git a/dev-perl/Mail-IMAPClient/Manifest b/dev-perl/Mail-IMAPClient/Manifest
index c7d4e2e41b24..c045b918e45e 100644
--- a/dev-perl/Mail-IMAPClient/Manifest
+++ b/dev-perl/Mail-IMAPClient/Manifest
@@ -1,2 +1,3 @@
DIST Mail-IMAPClient-3.35.tar.gz 186010 SHA256 8a4503833ce87d980be2d54603d94de4b365c2369eab19b095216506ce40f663 SHA512 c8fc11d098a0c0370347155e860e4eb1b0842c5de825f206d166bd6d99d510a492aa0ebe5a15f561aae1f379641f502fc4984660be2a0b42be52a01a58661595 WHIRLPOOL 264bb7cf85466a65a13184a1c008d8913f8b77af9954983e83b7eb5542747d5cf146fd6dc4d089020ab25183781e1394366d109b489973cf9ac7b4739fd0b017
DIST Mail-IMAPClient-3.37.tar.gz 188964 SHA256 481df10e0426938dcf6ae641e8e15098ddaeb44ca247772a27b87278f78ba9f3 SHA512 e6baeb880610d55991342fc50acd5bb666a4d94856f4d158172eb5e430aa62296847cb4cec4706398dfbaf7af657ca0024ef92bbb455addd0cd648c47d847fef WHIRLPOOL 7801f9032ad445a0c8994523f5c7bc6455a69b52b16690a00d352575436cc487324f7e1671a808ae84f36af363b521fd752818151dd67c5852da42653398e9db
+DIST Mail-IMAPClient-3.38.tar.gz 190487 SHA256 d0f346d111dba93548ceac1192a993210ffcd5f81f83638ee277607bfacc1a4d SHA512 aa2d4ae43ac221db5b99d20884d34ce41fabdc593cee48e7daf7d7048dd351026231f9a4193044f42eb17c8d303b5af0b924bea17fed27c4d0934ca2935b73f3 WHIRLPOOL 29116d21168eb03db194ba80ede6a50074798cebdd07e8a1f35ecb0e45911af0fd71378662039da325c0a56aa915a7a209254efb3816e50453fc637c151e93e3
diff --git a/dev-perl/Mail-IMAPClient/files/3.38-makefilepl.patch b/dev-perl/Mail-IMAPClient/files/3.38-makefilepl.patch
new file mode 100644
index 000000000000..1224701a2988
--- /dev/null
+++ b/dev-perl/Mail-IMAPClient/files/3.38-makefilepl.patch
@@ -0,0 +1,89 @@
+diff -Naur Mail-IMAPClient-3.38/Makefile.PL Mail-IMAPClient-3.38/Makefile.PL
+--- Mail-IMAPClient-3.38/Makefile.PL
++++ Mail-IMAPClient-3.38/Makefile.PL
+@@ -4,39 +4,6 @@
+
+ use 5.008_001;
+
+-my @missing;
+-my %optional = (
+- "Authen::NTLM" => { for => "Authmechanism 'NTLM'" },
+- "Authen::SASL" => { for => "Authmechanism 'DIGEST-MD5'" },
+- "Compress::Zlib" => { for => "COMPRESS DEFLATE support" },
+- "Digest::HMAC_MD5" => { for => "Authmechanism 'CRAM-MD5'" },
+- "Digest::MD5" => { for => "Authmechanism 'DIGEST-MD5'" },
+- "IO::Socket::SSL" => { for => "SSL enabled connections (Ssl => 1)" },
+- "Test::Pod" => { for => "Pod tests", ver => "1.00" },
+-);
+-
+-foreach my $mod ( sort keys %optional ) {
+- my $for = $optional{$mod}->{"for"} || "";
+- my $ver = $optional{$mod}->{"ver"} || "";
+- eval "use $mod $ver ();";
+- push @missing, $mod . ( $for ? " for $for" : "" ) if $@;
+-}
+-
+-# similar message to one used in DBI:
+-if (@missing) {
+- print( "The following optional modules were not found:",
+- map( "\n\t" . $_, @missing ), "\n" );
+-
+- print <<'MSG';
+-Optional modules are available from any CPAN mirror, reference:
+- http://search.cpan.org/
+- http://www.perl.com/CPAN/modules/by-module
+- http://www.perl.org/CPAN/modules/by-module
+-
+-MSG
+- sleep 3;
+-}
+-
+ # HACK: die on broken Parse::RecDescent 1.966002 through 1.967009
+ # - rt.cpan.org#74593: Recent changes break Module::ExtractUse and ...
+ # - rt.cpan.org#74733: Fails with Parse::RecDescent >= 1.966_002
+@@ -94,45 +61,4 @@
+ clean => { FILES => 'test.txt' },
+ );
+
+-set_test_data();
+-
+ exit 0;
+-
+-###
+-### HELPERS
+-###
+-
+-sub set_test_data {
+- unless ( -f "lib/Mail/IMAPClient.pm" ) {
+- warn("ERROR: not in installation directory\n");
+- return;
+- }
+-
+- if ( -s "./test.txt" ) {
+- print("The file test.txt will be used for extended tests.\n");
+- return;
+- }
+-
+- print <<EOF;
+-
+-(OPTIONAL) For extended tests during 'make test', create a file
+-'test.txt' in the top level directory of this distribution (the same
+-directory as the Makefile.PL, etc.). This file must contain an IMAP
+-server name or IP (server=...), a user account (user=...), and a
+-password (passed=...). A port (port=....) and an authentication
+-mechanism to be used (authmechanism=...) can also be specified.
+-
+-Example:
+-
+---- BEGIN: test.txt ---
+-server=localhost
+-user=mytestuser
+-passed=mypassword
+-port=143
+---- END: test.txt ---
+-
+-NOTE: When testing is completed, be sure to remove test.txt (either by
+-hand or by 'make clean').
+-
+-EOF
+-}
diff --git a/dev-perl/Mail-IMAPClient/metadata.xml b/dev-perl/Mail-IMAPClient/metadata.xml
index 8e012e705178..0ab914be90f3 100644
--- a/dev-perl/Mail-IMAPClient/metadata.xml
+++ b/dev-perl/Mail-IMAPClient/metadata.xml
@@ -5,6 +5,12 @@
<email>perl@gentoo.org</email>
<name>Gentoo Perl Project</name>
</maintainer>
+ <use>
+ <flag name="ntlm">Install support for NTLM Authentication</flag>
+ <flag name="md5">Install support for DIGEST-MD5 and CRAM-MD5 Authentication</flag>
+ <flag name="ssl">Install support for SSL Connections</flag>
+ <flag name="zlib">Install support for COMPRESS DEFLATE connections</flag>
+ </use>
<upstream>
<remote-id type="cpan">Mail-IMAPClient</remote-id>
<remote-id type="cpan-module">Mail::IMAPClient</remote-id>