summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-perl/Net-IMAP-Simple
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-perl/Net-IMAP-Simple')
-rw-r--r--dev-perl/Net-IMAP-Simple/Manifest2
-rw-r--r--dev-perl/Net-IMAP-Simple/Net-IMAP-Simple-1.220.100-r1.ebuild36
-rw-r--r--dev-perl/Net-IMAP-Simple/Net-IMAP-Simple-1.220.600.ebuild24
-rw-r--r--dev-perl/Net-IMAP-Simple/metadata.xml14
4 files changed, 76 insertions, 0 deletions
diff --git a/dev-perl/Net-IMAP-Simple/Manifest b/dev-perl/Net-IMAP-Simple/Manifest
new file mode 100644
index 000000000000..f09f83b985e9
--- /dev/null
+++ b/dev-perl/Net-IMAP-Simple/Manifest
@@ -0,0 +1,2 @@
+DIST Net-IMAP-Simple-1.2201.tar.gz 44932 SHA256 a62680a8020fa353f17d921626e27c628caa44e0e94c79987901d29d3946c1ac SHA512 bf837d956fbfca975e15c59bdb933ff07ad121fbd65f9de80d3eab0b077b90995990e0421624a9d0494893df651de290a0e1dc0ec2e7a212942cdcd1a2f529e1 WHIRLPOOL 1442403c55ca57194e708ccfb35ff80c0de5d7d47f747934e00f013b30ebdb79efb2e1ca55cdb3edf8f17979ec8dc6cbddf14485cb9f1c99001b1de8a45712b0
+DIST Net-IMAP-Simple-1.2206.tar.gz 45239 SHA256 759431477fe5f2b9d408c33fd6364264ae3f6b4acce89081d2f6406ba5562991 SHA512 60a23afe3740ee12cf5f997fa14aaa7a3b39cc0ca71bae6420346e05e99cb0ae0ba51f5bd52156bd3cb4f59b17f7558481d70c6dcce497d9da05b1546adc2af1 WHIRLPOOL b583830e6d54fe4bb4a616fe390ca9e11dd6760e5a7534d2df7b48bf99397971c1d0102919ed1db9ee79f66cdd79948c10e7a920e44f66d7fa0dfcb0a5cb54f6
diff --git a/dev-perl/Net-IMAP-Simple/Net-IMAP-Simple-1.220.100-r1.ebuild b/dev-perl/Net-IMAP-Simple/Net-IMAP-Simple-1.220.100-r1.ebuild
new file mode 100644
index 000000000000..00b25002cd82
--- /dev/null
+++ b/dev-perl/Net-IMAP-Simple/Net-IMAP-Simple-1.220.100-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=JETTERO
+MODULE_VERSION=1.2201
+inherit perl-module
+
+DESCRIPTION="Perl extension for simple IMAP account handling"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-perl/Class-Accessor
+ dev-perl/Coro
+ dev-perl/DateTime
+ dev-perl/DateTime-Format-Mail
+ dev-perl/DateTime-Format-Natural
+ dev-perl/Email-Address
+ dev-perl/Email-MIME
+ dev-perl/Email-MIME-ContentType
+ dev-perl/Email-Simple
+ dev-perl/Encode-IMAPUTF7
+ virtual/perl-MIME-Base64
+ dev-perl/List-MoreUtils
+ dev-perl/Net-SSLeay
+ dev-perl/Net-Server-Coro
+ dev-perl/regexp-common
+ dev-perl/DateTime-Format-Strptime
+ dev-perl/Parse-RecDescent"
+DEPEND="${RDEPEND}"
+
+SRC_TEST="do"
diff --git a/dev-perl/Net-IMAP-Simple/Net-IMAP-Simple-1.220.600.ebuild b/dev-perl/Net-IMAP-Simple/Net-IMAP-Simple-1.220.600.ebuild
new file mode 100644
index 000000000000..91b98cbac6fa
--- /dev/null
+++ b/dev-perl/Net-IMAP-Simple/Net-IMAP-Simple-1.220.600.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=JETTERO
+MODULE_VERSION=1.2206
+inherit perl-module
+
+DESCRIPTION="Perl extension for simple IMAP account handling"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-perl/Parse-RecDescent
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+"
+
+SRC_TEST="do parallel"
diff --git a/dev-perl/Net-IMAP-Simple/metadata.xml b/dev-perl/Net-IMAP-Simple/metadata.xml
new file mode 100644
index 000000000000..3345c86ace9c
--- /dev/null
+++ b/dev-perl/Net-IMAP-Simple/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <upstream>
+ <remote-id type="cpan">Net-IMAP-Simple</remote-id>
+ <remote-id type="cpan-module">Net::IMAP::Simple</remote-id>
+ <remote-id type="cpan-module">Net::IMAP::Simple::PipeSocket</remote-id>
+ <remote-id type="cpan-module">Net::IMAP::SimpleX</remote-id>
+ <remote-id type="cpan-module">Net::IMAP::SimpleX::Body</remote-id>
+ <remote-id type="cpan-module">Net::IMAP::SimpleX::BodySummary</remote-id>
+ <remote-id type="cpan-module">Net::IMAP::SimpleX::NIL</remote-id>
+ </upstream>
+</pkgmetadata>