summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-06-19 02:35:22 +0100
committerSam James <sam@gentoo.org>2023-06-19 02:35:22 +0100
commitc50a8b49fb4143ad73ef40889521e573c62e8bde (patch)
tree934575855115cfe8ebc8af07bf351c7d174044ec /dev-perl/Perl-Tidy/Perl-Tidy-20230309.0.0.ebuild
parentdev-perl/PGPLOT: add 2.280.0 (diff)
downloadgentoo-c50a8b49fb4143ad73ef40889521e573c62e8bde.tar.gz
gentoo-c50a8b49fb4143ad73ef40889521e573c62e8bde.tar.bz2
gentoo-c50a8b49fb4143ad73ef40889521e573c62e8bde.zip
dev-perl/Perl-Tidy: add 20230309.0.0
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-perl/Perl-Tidy/Perl-Tidy-20230309.0.0.ebuild')
-rw-r--r--dev-perl/Perl-Tidy/Perl-Tidy-20230309.0.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-perl/Perl-Tidy/Perl-Tidy-20230309.0.0.ebuild b/dev-perl/Perl-Tidy/Perl-Tidy-20230309.0.0.ebuild
new file mode 100644
index 000000000000..564314f083b4
--- /dev/null
+++ b/dev-perl/Perl-Tidy/Perl-Tidy-20230309.0.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=SHANCOCK
+DIST_VERSION=20230309
+DIST_EXAMPLES=( "examples/*" )
+
+inherit perl-module
+
+DESCRIPTION="Perl script indenter and beautifier"
+HOMEPAGE="https://perltidy.sourceforge.net/ https://metacpan.org/release/Perl-Tidy"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+
+BDEPEND="virtual/perl-ExtUtils-MakeMaker"
+
+src_install() {
+ perl-module_src_install
+
+ # Compressing html is bad
+ docompress -x /usr/share/doc/${PF}/stylekey.html
+ docompress -x /usr/share/doc/${PF}/tutorial.html
+ docompress -x /usr/share/doc/${PF}/perltidy.html
+
+ dodoc docs/stylekey.html
+ dodoc docs/tutorial.html
+ dodoc docs/perltidy.html
+}