summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentfredric@gmail.com>2016-04-13 23:01:18 +1200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2016-04-15 21:55:31 +0200
commitb60cef546e9aa40d8c88d40cc31cdcc91e6a56c0 (patch)
treed587cdb4b61353e79e1125359fc79a7301b9e6d8 /dev-perl/Test-Fatal/Test-Fatal-0.14.0.ebuild
parentdev-perl/Test-Exception: Bump to version 0.430.0 (diff)
downloadgentoo-b60cef546e9aa40d8c88d40cc31cdcc91e6a56c0.tar.gz
gentoo-b60cef546e9aa40d8c88d40cc31cdcc91e6a56c0.tar.bz2
gentoo-b60cef546e9aa40d8c88d40cc31cdcc91e6a56c0.zip
dev-perl/Test-Fatal: Bump to version 0.14.0
- EAPI6 - USE "examples" Upstream: - Fix TODO + $T::B::Level interaction bugs Package-Manager: portage-2.2.28 RepoMan-Options: --ignore-arches --include-arches="alpha amd64 amd64-fbsd arm arm64 hppa ia64 m68k mips nios2 ppc ppc64 riscv s390 sh sparc sparc-fbsd x86 x86-fbsd"
Diffstat (limited to 'dev-perl/Test-Fatal/Test-Fatal-0.14.0.ebuild')
-rw-r--r--dev-perl/Test-Fatal/Test-Fatal-0.14.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-perl/Test-Fatal/Test-Fatal-0.14.0.ebuild b/dev-perl/Test-Fatal/Test-Fatal-0.14.0.ebuild
new file mode 100644
index 000000000000..efcb3dcf56e5
--- /dev/null
+++ b/dev-perl/Test-Fatal/Test-Fatal-0.14.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DIST_AUTHOR=RJBS
+DIST_VERSION=0.014
+DIST_EXAMPLES=("examples/*")
+inherit perl-module
+
+DESCRIPTION="Incredibly simple helpers for testing code with exceptions"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="test"
+
+RDEPEND="
+ virtual/perl-Carp
+ >=virtual/perl-Exporter-5.570.0
+ virtual/perl-Test-Simple
+ >=dev-perl/Try-Tiny-0.70.0
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ >=virtual/perl-CPAN-Meta-2.120.900
+ virtual/perl-File-Spec
+ >=virtual/perl-Test-Simple-0.960.0
+ )"