summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-10-17 04:07:39 +0100
committerSam James <sam@gentoo.org>2024-10-17 04:11:41 +0100
commit00d1c7ff252ed9c8861ad69ffe867133032dd04b (patch)
tree9e70c4d23c75eb848fc65f54a9ff6bfa8c298fca /dev-perl/Time-Out/Time-Out-1.0.0.ebuild
parentvirtual/perl-Test-Harness: add 3.500.0 (diff)
downloadgentoo-00d1c7ff252ed9c8861ad69ffe867133032dd04b.tar.gz
gentoo-00d1c7ff252ed9c8861ad69ffe867133032dd04b.tar.bz2
gentoo-00d1c7ff252ed9c8861ad69ffe867133032dd04b.zip
dev-perl/Time-Out: add 1.0.0
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-perl/Time-Out/Time-Out-1.0.0.ebuild')
-rw-r--r--dev-perl/Time-Out/Time-Out-1.0.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-perl/Time-Out/Time-Out-1.0.0.ebuild b/dev-perl/Time-Out/Time-Out-1.0.0.ebuild
new file mode 100644
index 000000000000..562b8a77c0d4
--- /dev/null
+++ b/dev-perl/Time-Out/Time-Out-1.0.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=SVW
+inherit perl-module
+
+DESCRIPTION="Easily timeout long running operations"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-perl/Try-Tiny
+"
+BDEPEND="
+ ${RDEPEND}
+ >=dev-perl/ExtUtils-MakeMaker-CPANfile-0.90.0
+ >=virtual/perl-ExtUtils-MakeMaker-6.760.0
+ test? (
+ dev-perl/Test-Fatal
+ >=virtual/perl-Test-Harness-3.500.0
+ dev-perl/Test-Needs
+ )
+"
+
+PERL_RM_FILES=( "t/pod.t" )