summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2017-06-29 23:21:00 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2017-06-29 23:21:09 +0200
commit8d7f7f316be4ebcbd580e0013aae89d36511ae08 (patch)
treecb3b3d36e519bb6c495f213665e0bf21c1a8bb8d /dev-perl/Wx/Wx-0.993.200.ebuild
parentdev-vcs/gitolite-gentoo: bump. (diff)
downloadgentoo-8d7f7f316be4ebcbd580e0013aae89d36511ae08.tar.gz
gentoo-8d7f7f316be4ebcbd580e0013aae89d36511ae08.tar.bz2
gentoo-8d7f7f316be4ebcbd580e0013aae89d36511ae08.zip
dev-perl/Wx: Version bump, fixes bug 615246
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-perl/Wx/Wx-0.993.200.ebuild')
-rw-r--r--dev-perl/Wx/Wx-0.993.200.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-perl/Wx/Wx-0.993.200.ebuild b/dev-perl/Wx/Wx-0.993.200.ebuild
new file mode 100644
index 000000000000..569387538158
--- /dev/null
+++ b/dev-perl/Wx/Wx-0.993.200.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+WX_GTK_VER="3.0"
+DIST_AUTHOR=MDOOTSON
+DIST_VERSION=0.9932
+DIST_EXAMPLES=("samples/*")
+inherit wxwidgets virtualx perl-module
+
+DESCRIPTION="Perl bindings for wxGTK"
+HOMEPAGE="http://wxperl.sourceforge.net/ ${HOMEPAGE}"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=dev-perl/Alien-wxWidgets-0.670.0
+ x11-libs/wxGTK:${WX_GTK_VER}
+ >=virtual/perl-File-Spec-0.820.0
+"
+DEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.480.0
+ >=virtual/perl-ExtUtils-ParseXS-3.150.0
+ >=dev-perl/ExtUtils-XSpp-0.160.200
+ >=virtual/perl-if-0.30.0
+ test? (
+ >=virtual/perl-Test-Harness-2.260.0
+ >=virtual/perl-Test-Simple-0.430.0
+ )
+"
+
+src_prepare() {
+ need-wxwidgets base-unicode
+ perl-module_src_prepare
+}
+
+src_test() {
+ # the webview/t/03_threads.t test tends to hang or crash in weird
+ # ways depending on local configuration. eg, backtraces involving
+ # all of webkit-gtk, kpartsplugin and kdelibs...
+ perl_rm_files t/12_pod.t ext/webview/t/03_threads.t
+ virtx perl-module_src_test
+}